Error when installing: undeclared identifier 'ev_default_fork' #2

Open
tadman opened this Issue Aug 7, 2013 · 0 comments

Comments

Projects
None yet
1 participant
@tadman

tadman commented Aug 7, 2013

Under OS X 10.8.4, Node 0.10.13:

gyp http 200 http://nodejs.org/dist/v0.10.13/node-v0.10.13.tar.gz
  CC(target) Release/obj.target/aeternum/deps/aeternum/aeternum.o
  LIBTOOL-STATIC Release/aeternum.a
  CXX(target) Release/obj.target/prefork/src/prefork.o
../src/prefork.cc:28:3: error: use of undeclared identifier 'ev_default_fork'; did you mean 'uv_default_loop'?
  ev_default_fork();
  ^~~~~~~~~~~~~~~
  uv_default_loop
/Users/tadman/.node-gyp/0.10.13/deps/uv/include/uv.h:259:22: note: 'uv_default_loop' declared here
UV_EXTERN uv_loop_t* uv_default_loop(void);
                     ^
1 error generated.
make: *** [Release/obj.target/prefork/src/prefork.o] Error 1

Is this an issue with the newer version of NodeJS?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment