New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Settings does not update when selecting default browser #784

Merged
merged 1 commit into from Aug 25, 2018

Conversation

Projects
None yet
2 participants
@JonET
Contributor

JonET commented Aug 25, 2018

A (probably naive) attempt at fixing a bug I came across where changing the default browser failed to update the settings panel until the table cell was moved off screen. I'm not an ios dev, so feel free to tell me what I did is completely bad/wrong.

awfulappbug

@nolanw

This comment has been minimized.

Show comment
Hide comment
@nolanw

nolanw Aug 25, 2018

Member

Good find, and that fix works for me!

Usually I prefer to reload just the relevant rows of the table, instead of reloading the whole thing. However, the settings screen here is a total mess, so I'm happy just reloading things. If we ever get around to tidying the screen up, that's when I'd expect to take another look.

Thanks for the fix!

Member

nolanw commented Aug 25, 2018

Good find, and that fix works for me!

Usually I prefer to reload just the relevant rows of the table, instead of reloading the whole thing. However, the settings screen here is a total mess, so I'm happy just reloading things. If we ever get around to tidying the screen up, that's when I'd expect to take another look.

Thanks for the fix!

@nolanw nolanw merged commit 4496fcc into Awful:master Aug 25, 2018

1 check passed

continuous-integration/travis-ci/pr The Travis CI build passed
Details
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment