New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Add deprecation warning for support for PowerShell 3/4. #5149

Closed
twitchax opened this Issue Dec 14, 2017 · 4 comments

Comments

Projects
None yet
4 participants
@twitchax
Contributor

twitchax commented Dec 14, 2017

What the title says.

@doctordns

This comment has been minimized.

Contributor

doctordns commented Dec 15, 2017

This is a great idea.

Can I ask that any deprecation information points to a web page that explains the issue, using more words that are appropriate for a warning message. I just want the warning message to be actionable.

@markcowl

This comment has been minimized.

Member

markcowl commented Jan 12, 2018

  • Add this to the psm1 script for profile, and save the information so that this only prints once per machine.
@markcowl

This comment has been minimized.

Member

markcowl commented Jan 12, 2018

  • 'PowerShell version 3 and 4 will no longer be supported starting in May 2018. Please update to the latest version of PowerShell 5.1 ' Also add this to the top of all release notes.

@markcowl markcowl removed their assignment Jan 12, 2018

@markcowl markcowl modified the milestones: 2018-01-26, 2018-02-09 Jan 24, 2018

@maddieclayton maddieclayton self-assigned this Jan 25, 2018

@markcowl

This comment has been minimized.

Member

markcowl commented Feb 7, 2018

Fixed.

@markcowl markcowl closed this Feb 7, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment