Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Fix error message string for unsupported node version #708

Merged
merged 5 commits into from Apr 5, 2013

Conversation

Projects
None yet
3 participants
Member

markcowl commented Apr 5, 2013

No description provided.

@christav christav commented on an outdated diff Apr 5, 2013

lib/azure.js
@@ -19,7 +19,7 @@ var azureutil = require('./util/util');
var nodeVersion = azureutil.getNodeVersion();
if (nodeVersion.major === 0 && nodeVersion.minor > 8 && !(nodeVersion.minor === 10 && nodeVersion.patch >= 3)) {
- throw new Error('The Windows Azure node SDK does not work with node versions > 0.8.0 and < 0.10.3. Please upgrade to node >= 0.10.3');
+ throw new Error('The Windows Azure node SDK does not work with node versions > 0.8 and < 0.10.3. Please upgrade to node >= 0.10.3');
}
@christav

christav Apr 5, 2013

Contributor

Since there's never going to be another 0.8 version, can we put 0.8.22 explicitly?

Member

markcowl commented Apr 5, 2013

fixed

@andrerod andrerod pushed a commit that referenced this pull request Apr 5, 2013

André Rodrigues Merge pull request #708 from markcowl/errorFix
Fix error message string for unsupported node version
2e69334

@andrerod andrerod merged commit 2e69334 into Azure:release-0.7.2 Apr 5, 2013

1 check failed

default The Travis build failed
Details
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment