New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

TypeError: unsupported operand type(s) for -=: 'Retry' and 'int' #420

Closed
jongio opened this Issue Nov 16, 2017 · 7 comments

Comments

Projects
None yet
4 participants
@jongio
Contributor

jongio commented Nov 16, 2017

When running sudo pip install -U azure-iot-edge-runtime-ctl on Raspbian Stretch Lite, I got the following error, but only got it once. It went away after I tried a second time.

pi@jongpi6-lite:~ $ sudo pip install -U azure-iot-edge-runtime-ctl

Collecting cffi>=1.7 (from cryptography>=1.3.4; extra == "tls"->docker[tls]==2.6->azure-iot-edge-runtime-ctl)
Exception:
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/pip/basecommand.py", line 215, in main
    status = self.run(options, args)
  File "/usr/lib/python2.7/dist-packages/pip/commands/install.py", line 353, in run
    wb.build(autobuilding=True)
  File "/usr/lib/python2.7/dist-packages/pip/wheel.py", line 749, in build
    self.requirement_set.prepare_files(self.finder)
  File "/usr/lib/python2.7/dist-packages/pip/req/req_set.py", line 380, in prepare_files
    ignore_dependencies=self.ignore_dependencies))
  File "/usr/lib/python2.7/dist-packages/pip/req/req_set.py", line 554, in _prepare_file
    require_hashes
  File "/usr/lib/python2.7/dist-packages/pip/req/req_install.py", line 278, in populate_link
    self.link = finder.find_requirement(self, upgrade)
  File "/usr/lib/python2.7/dist-packages/pip/index.py", line 465, in find_requirement
    all_candidates = self.find_all_candidates(req.name)
  File "/usr/lib/python2.7/dist-packages/pip/index.py", line 423, in find_all_candidates
    for page in self._get_pages(url_locations, project_name):
  File "/usr/lib/python2.7/dist-packages/pip/index.py", line 568, in _get_pages
    page = self._get_page(location)
  File "/usr/lib/python2.7/dist-packages/pip/index.py", line 683, in _get_page
    return HTMLPage.get_page(link, session=self.session)
  File "/usr/lib/python2.7/dist-packages/pip/index.py", line 792, in get_page
    "Cache-Control": "max-age=600",
  File "/usr/share/python-wheels/requests-2.12.4-py2.py3-none-any.whl/requests/sessions.py", line 501, in get
    return self.request('GET', url, **kwargs)
  File "/usr/lib/python2.7/dist-packages/pip/download.py", line 386, in request
    return super(PipSession, self).request(method, url, *args, **kwargs)
  File "/usr/share/python-wheels/requests-2.12.4-py2.py3-none-any.whl/requests/sessions.py", line 488, in request
    resp = self.send(prep, **send_kwargs)
  File "/usr/share/python-wheels/requests-2.12.4-py2.py3-none-any.whl/requests/sessions.py", line 609, in send
    r = adapter.send(request, **kwargs)
  File "/usr/share/python-wheels/CacheControl-0.11.7-py2.py3-none-any.whl/cachecontrol/adapter.py", line 47, in send
    resp = super(CacheControlAdapter, self).send(request, **kw)
  File "/usr/share/python-wheels/requests-2.12.4-py2.py3-none-any.whl/requests/adapters.py", line 423, in send
    timeout=timeout
  File "/usr/share/python-wheels/urllib3-1.19.1-py2.py3-none-any.whl/urllib3/connectionpool.py", line 643, in urlopen
    _stacktrace=sys.exc_info()[2])
  File "/usr/share/python-wheels/urllib3-1.19.1-py2.py3-none-any.whl/urllib3/util/retry.py", line 315, in increment
    total -= 1
TypeError: unsupported operand type(s) for -=: 'Retry' and 'int'

@RogerDawson

This comment has been minimized.

Show comment
Hide comment
@RogerDawson

RogerDawson Nov 30, 2017

I got this also.

RogerDawson commented Nov 30, 2017

I got this also.

@darobs

This comment has been minimized.

Show comment
Hide comment
@darobs

darobs Dec 1, 2017

Contributor

I created a new Raspbian Stretch Lite image last night, and was able to run the command first time without any trouble:

$ pip --version
pip 9.0.1 from /usr/lib/python2.7/dist-packages (python 2.7)
$ python --version
Python 2.7.13
$ uname -a
Linux angular-pi4 4.9.41-v7+ #1023 SMP Tue Aug 8 16:00:15 BST 2017 armv7l GNU/Linux
$ lsb_release -a
No LSB modules are available.
Distributor ID: Raspbian
Description:    Raspbian GNU/Linux 9.1 (stretch)
Release:        9.1
Codename:       stretch

I even tried uninstalling it and reinstalling it, with and without the cache.

Is there something I'm missing?

Contributor

darobs commented Dec 1, 2017

I created a new Raspbian Stretch Lite image last night, and was able to run the command first time without any trouble:

$ pip --version
pip 9.0.1 from /usr/lib/python2.7/dist-packages (python 2.7)
$ python --version
Python 2.7.13
$ uname -a
Linux angular-pi4 4.9.41-v7+ #1023 SMP Tue Aug 8 16:00:15 BST 2017 armv7l GNU/Linux
$ lsb_release -a
No LSB modules are available.
Distributor ID: Raspbian
Description:    Raspbian GNU/Linux 9.1 (stretch)
Release:        9.1
Codename:       stretch

I even tried uninstalling it and reinstalling it, with and without the cache.

Is there something I'm missing?

@jongio

This comment has been minimized.

Show comment
Hide comment
@jongio

jongio Dec 1, 2017

Contributor

It is intermittent.

Contributor

jongio commented Dec 1, 2017

It is intermittent.

@jongio

This comment has been minimized.

Show comment
Hide comment
@jongio

jongio Mar 6, 2018

Contributor

Saw this again today on pi

Contributor

jongio commented Mar 6, 2018

Saw this again today on pi

@jongio

This comment has been minimized.

Show comment
Hide comment
@jongio

jongio Mar 9, 2018

Contributor

Upgrading pip might solve this, but not confirmed

pip install --upgrade pip

Contributor

jongio commented Mar 9, 2018

Upgrading pip might solve this, but not confirmed

pip install --upgrade pip

@duncanhoggan

This comment has been minimized.

Show comment
Hide comment
@duncanhoggan

duncanhoggan May 8, 2018

I had the same issue, looks like there is a system cryptography dependency missing.
I installed build essentials using the following...

sudo apt-get install build-essential libssl-dev libffi-dev python-dev

and everything is good, @jonbgallant please confirm.

duncanhoggan commented May 8, 2018

I had the same issue, looks like there is a system cryptography dependency missing.
I installed build essentials using the following...

sudo apt-get install build-essential libssl-dev libffi-dev python-dev

and everything is good, @jonbgallant please confirm.

@jongio

This comment has been minimized.

Show comment
Hide comment
@jongio

jongio May 8, 2018

Contributor

I haven't seen this in a while. Let's close with that resolution and reopen if we see it again.

Contributor

jongio commented May 8, 2018

I haven't seen this in a while. Let's close with that resolution and reopen if we see it again.

@jongio jongio closed this May 8, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment