New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Vanilla template Stateful service Asp.net Core not working version 6.1.480 #969

Closed
francescocristallo opened this Issue Apr 7, 2018 · 2 comments

Comments

Projects
None yet
5 participants
@francescocristallo

francescocristallo commented Apr 7, 2018

I formatted my PC, reinstalled VS2017 on Windows 10 x64 (English International), imported my project and the stateful services were not working anymore. Meanwhile the Refresh 3 came out, I installed it.
Couldn't make the Stateful services work in any way in the local cluster. The stateless works just fine.

I created a new project with an Empty Stateful Asp.net Core service and is not working.
To replicate the problem:

File => New Project => Service Fabric Application => Stateful Asp.net Core => Empty => Debug

Launch debug, the error is:

The service host terminated with exit code: 2148734499

The local cluster mode is 1 Node.

You seriously need to put more info in there, every update there is something not working, packaging not restoring or new errors popping up without explanation.
I'm stuck in development until I figure out why even a zero code app is not working.

1

2

TESTS:

  1. Tried with 5 Nodes mode type with same error.
  2. Used the Stateful service template (Non the Asp.net Core one), same errors:

capture

4png

What is exit code: 2148734499?

How do I solve this? Why it's happening on a New project without any modification?

@francescocristallo francescocristallo changed the title from Valilla template Stateful service Asp.net Core not working to Valilla template Stateful service Asp.net Core 6.1.480 not working Apr 7, 2018

@francescocristallo francescocristallo changed the title from Valilla template Stateful service Asp.net Core 6.1.480 not working to Vanilla template Stateful service Asp.net Core not working version 6.1.480 Apr 7, 2018

@francescocristallo

This comment has been minimized.

francescocristallo commented Apr 7, 2018

I'm using SDK 3.0.480
I think this is related to #643 and #902 @hrushib

Adding new ArgumentException(); fixed the problem.

capture

But I still want to know why this happens, I spent almost a day on this, I can imagine most programmers trying once Service Fabric where the basic template does not work and give up.

I also changed the system language to US (non international) and it didn't fix it.

@hrushib

This comment has been minimized.

hrushib commented Apr 10, 2018

@francescocristallo, as mentioned in earlier incidents this mainly happens due to known issue with CoreCLR dotnet/coreclr#12668 on non en-us version of Windows 10 which results in Stateful service process crashing with -2146232797, refer to #619 for details.

This issue is fixed in 2.0.3 version of coreclr, so you can use this version or higher to get your code running without the above work around. To make sure that you use 2.0.3 (or higher) add below line in your csproj under properties.
<RuntimeFrameworkVersion>2.0.3</RuntimeFrameworkVersion>

@dbreshears, we should update templates to include above line in csproj.

Closing this issue, given that @francescocristallo unblocked him using the workaround and this reply answers his his question on why this happens.

@hrushib hrushib closed this Apr 10, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment