Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

AADSTS50058 #423

Closed
mohanskumar opened this Issue Oct 26, 2016 · 6 comments

Comments

Projects
None yet
3 participants
@mohanskumar
Copy link

mohanskumar commented Oct 26, 2016

encountering the following error often, when trying to login to the app after a while.

Using Chrome in Mac and session storage. Adal 1.0.12 and adal-angular 1.0.12.

AADSTS50058: A silent sign-in request was sent but no user is signed in. The cookies used to represent the user's session were not sent in the request to Azure AD. This can happen if the user is using Internet Explorer or Edge, and the web app sending the silent sign-in request is in different IE security zone than the Azure AD endpoint (login.microsoftonline.com).
Trace ID: 3945d3c6-8e19-409e-92a8-5212363eb2b1
Correlation ID: ef302455-d122-4950-9f8e-6ae6345fcdf4
Timestamp: 2016-10-26 15:42:09Z"

@tushargupta51

This comment has been minimized.

@brphelps

This comment has been minimized.

Copy link

brphelps commented Oct 27, 2016

Just to be clear, we started seeing this issue recently as well. The error message is likely conflating two different cases -- we explicitly added all sites in the passive auth chain to our trusted sites and still see the problem.

One developer on our side explained that with .12, we're no longer getting a cookie that we still get with .10 -- i.e. this issue is a regression specific to .12.

Please feel free to engage us internally as well.

@tushargupta51

This comment has been minimized.

Copy link
Contributor

tushargupta51 commented Oct 31, 2016

One developer on our side explained that with .12, we're no longer getting a cookie that we still get with .10 -- i.e. this issue is a regression specific to .12.

@brphelps Can you share logs and fiddler traces? I need to look at the complete network to see if cookie is being set on login or not.

@tushargupta51

This comment has been minimized.

Copy link
Contributor

tushargupta51 commented Nov 9, 2016

@mohanskumar Is it still an issue for you?
@brphelps Based on the internal thread, you need to check the value of domain_hint parameter.

@mohanskumar

This comment has been minimized.

Copy link
Author

mohanskumar commented Nov 10, 2016

I am all set. thank you so much. 👍

On Tue, Nov 8, 2016 at 10:44 PM, tushar gupta notifications@github.com
wrote:

@mohanskumar https://github.com/mohanskumar Is it still an issue for
you?
@brphelps https://github.com/brphelps Based on the internal thread, you
need to check the value of domain_hint parameter.


You are receiving this because you were mentioned.
Reply to this email directly, view it on GitHub
#423 (comment),
or mute the thread
https://github.com/notifications/unsubscribe-auth/AD2qIhNYqU0ny2qs4_o5s0iUUMLc-slNks5q8UG7gaJpZM4KhVwU
.

@tushargupta51

This comment has been minimized.

Copy link
Contributor

tushargupta51 commented Nov 10, 2016

@mohanskumar Did you find the cause of the error? What fixed it for you? It might help people running into this issue. I will close the issue.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.
You signed in with another tab or window. Reload to refresh your session. You signed out in another tab or window. Reload to refresh your session.