New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Cmake could not find url for MSVC version #6352

Closed
bit-scientist opened this Issue Apr 18, 2018 · 5 comments

Comments

Projects
None yet
4 participants
@bit-scientist
Copy link

bit-scientist commented Apr 18, 2018

The system cannot find the drive specified.
The system cannot find the drive specified.
INFO: ============================================================
INFO: Summary:
INFO: ============================================================
INFO: MSVC_VERSION               = 14
INFO: WITH_NINJA                 = 1
INFO: CMAKE_GENERATOR            = "Ninja"
INFO: CPU_ONLY                   = 0
INFO: CUDA_ARCH_NAME             = Auto
INFO: CMAKE_CONFIG               = Release
INFO: USE_NCCL                   = 0
INFO: CMAKE_BUILD_SHARED_LIBS    = 0
INFO: PYTHON_VERSION             = 2
INFO: BUILD_PYTHON               = 1
INFO: BUILD_PYTHON_LAYER         = 1
INFO: BUILD_MATLAB               = 0
INFO: PYTHON_EXE                 = "python"
INFO: RUN_TESTS                  = 0
INFO: RUN_LINT                   = 0
INFO: RUN_INSTALL                = 0
INFO: ============================================================
CMake Error at cmake/WindowsDownloadPrebuiltDependencies.cmake:40 (message):
  Could not find url for MSVC version = 1900 and Python version = 3.6.
Call Stack (most recent call first):
  CMakeLists.txt:77 (include)


-- Configuring incomplete, errors occurred!
See also "C:/Users/caffe/build/CMakeFiles/CMakeOutput.log".
ERROR: Configure failed

Steps to reproduce

I am following this and when I run scripts\build_win.cmd I got the above errors.

Tried solutions

I looked all the possible solutions and they are either not solved or not clear to me. My cmake generator is Ninja while most people's generator is some version of Visual Studio.

System configuration

  • Operating system: win 10, 64
  • Compiler: Command line
  • CUDA version (if applicable): none
  • CUDNN version (if applicable): none
  • BLAS: none
  • Python version (if using pycaffe): Not using pycaffe, python 2.7
  • MATLAB version (if using matcaffe):

@willyd willyd added the windows label Apr 18, 2018

@willyd

This comment has been minimized.

Copy link
Contributor

willyd commented Apr 18, 2018

Python 3.6 must be installed on your system and is the version picked up by CMake. The current windows branch does not support Python 3.6 yet.

Since you do not want pycaffe, you must remove the build directory, disable the python build with set BUILD_PYTHON=0 in your terminal and execute the scripts/build_win.cmd script.

Otherwise, make sure CMake finds your Python 2.7 by specifying additional options on the CMake command line, like PYTHON_EXECUTABLE.

@bit-scientist

This comment has been minimized.

Copy link
Author

bit-scientist commented Apr 19, 2018

Thank you mister, after many trials I had deleted them all before I saw you reply and now it's fresh. Would you mind explaining what to do step by step? I think it would be useful for other folks as well. Right now I have Cmake only. For example, I don't know how to remove the build directory or disable python build, I haven't done them before. Or at least, could you refer to any link that explains all these things in detail? Thank you

@brokeback

This comment has been minimized.

Copy link

brokeback commented Apr 23, 2018

add the following line to the cmake section in the build_win.cmd
-DPYTHON_EXECUTABLE:FILEPATH=C:\Users\xyz\Anaconda3\envs\py35\python.exe ^

eg.
:: Configure using cmake and using the caffe-builder dependencies
:: Add -DCUDNN_ROOT=C:/Projects/caffe/cudnn-8.0-windows10-x64-v5.1/cuda ^
:: below to use cuDNN
cmake -G"!CMAKE_GENERATOR!" ^
-DBLAS=Open ^
-DCMAKE_BUILD_TYPE:STRING=%CMAKE_CONFIG% ^
-DBUILD_SHARED_LIBS:BOOL=%CMAKE_BUILD_SHARED_LIBS% ^
-DBUILD_python:BOOL=%BUILD_PYTHON% ^
-DBUILD_python_layer:BOOL=%BUILD_PYTHON_LAYER% ^
-DBUILD_matlab:BOOL=%BUILD_MATLAB% ^
-DCUDNN_ROOT=C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v9.1 ^
-DCPU_ONLY:BOOL=%CPU_ONLY% ^
-DCOPY_PREREQUISITES:BOOL=1 ^
-DINSTALL_PREREQUISITES:BOOL=1 ^
-DUSE_NCCL:BOOL=!USE_NCCL! ^
-DCUDA_ARCH_NAME:STRING=%CUDA_ARCH_NAME% ^
-DPYTHON_EXECUTABLE:FILEPATH=C:\Users\xyz\Anaconda3\envs\py35\python.exe ^
"%~dp0.."

@sungwuk

This comment has been minimized.

Copy link

sungwuk commented Jul 20, 2018

if you don't mind can i ask you something?
I also CMake Error at

CMake Error at cmake/WindowsDownloadPrebuiltDependencies.cmake:40 (message):
Could not find url for MSVC version = 1800 and Python version = 3.5.

Call Stack (most recent call first):
CMakeLists.txt:77 (include)

when I run scripts\build_win.cmd I got the errors.

System configurations

  • OS : window 10

  • CUDA7.5

  • cudnnv5 for cuda7.5

  • python = 3.5.2

@willyd

This comment has been minimized.

Copy link
Contributor

willyd commented Oct 24, 2018

@sungwuk You need VS 2015 or 2017. You have 2013.

You can also try my conda packages. See #6569 (comment).

Closing since both situtations require rebuilding dependencies from source with caffe-builder.

@willyd willyd closed this Oct 24, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment