New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Problem while importing caffe in Python #703

Closed
sayanghosh opened this Issue Jul 15, 2014 · 3 comments

Comments

Projects
None yet
4 participants
@sayanghosh

sayanghosh commented Jul 15, 2014

When I try to import caffe from the terminal in Ubuntu by the command python -c "import caffe", I get the following error :

Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/home/sghosh/mnt/Sayancode/caffe/caffe/distribute/python/caffe/__init__.py", line 1, in <module>
    from .pycaffe import Net, SGDSolver
  File "/home/sghosh/mnt/Sayancode/caffe/caffe/distribute/python/caffe/pycaffe.py", line 10, in <module>
    from ._caffe import Net, SGDSolver
ImportError: /home/sghosh/anaconda/bin/../lib/libm.so.6: version `GLIBC_2.15' not found (required by /usr/lib/x86_64-linux-gnu/libvorbis.so.0)

Could anyone assist here ?

@longjon

This comment has been minimized.

Show comment
Hide comment
@longjon

longjon Jul 15, 2014

Contributor

I've seen this as well; looks like it's a bug in a recent anaconda release. You can work around it by temporarily renaming libm.so and libm.so.6 in your anaconda lib directory.

See https://groups.google.com/a/continuum.io/forum/#!topic/anaconda/-DLG2ZdTkw0.

Contributor

longjon commented Jul 15, 2014

I've seen this as well; looks like it's a bug in a recent anaconda release. You can work around it by temporarily renaming libm.so and libm.so.6 in your anaconda lib directory.

See https://groups.google.com/a/continuum.io/forum/#!topic/anaconda/-DLG2ZdTkw0.

@longjon longjon closed this Jul 15, 2014

@cherler

This comment has been minimized.

Show comment
Hide comment
@cherler

cherler Nov 10, 2014

Now I am confused by this ImportError; is there some wrong ?
@sayanghosh if you have solved this problem ,please let me know ,thank you very much

cherler commented Nov 10, 2014

Now I am confused by this ImportError; is there some wrong ?
@sayanghosh if you have solved this problem ,please let me know ,thank you very much

@dvreed77

This comment has been minimized.

Show comment
Hide comment
@dvreed77

dvreed77 Jan 8, 2015

I am getting this error as well, but can't seem to figure out how to solve it. Doing a locate libm.so.6 I see this:

/home/dreed/anaconda/lib/libm.so.6
/home/dreed/anaconda/pkgs/system-5.8-1/lib/libm.so.6
/lib/x86_64-linux-gnu/libm.so.6

Isn't this correct?

dvreed77 commented Jan 8, 2015

I am getting this error as well, but can't seem to figure out how to solve it. Doing a locate libm.so.6 I see this:

/home/dreed/anaconda/lib/libm.so.6
/home/dreed/anaconda/pkgs/system-5.8-1/lib/libm.so.6
/lib/x86_64-linux-gnu/libm.so.6

Isn't this correct?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment