Podcast feed stopped working in the last beta or two #91

Closed
Bugsbane opened this Issue Dec 28, 2012 · 1 comment

2 participants

@Bugsbane

Hi there,
I had a feed for our podcast which I set up with v 2.0.1, since then I've accepted Joomla's automatic upgrade through to 2.1 beta 1 and now beta 2. Everything seems to work fine (thanks!) with the one exception that I noticed my feed url (kickstartershq.com/index.php?option=com_podcastmanager&format=raw&feedname=1) now seems to go through to a 404 page. It was working fine before (although there's been a couple of small Joomla point releases since then, too). The URL is rewritten to:
http://kickstartershq.com/index.phpcomponent/podcastmanager/?feedname=1&format=raw

which is a bit odd, given that ACEsef is set not to rewrite podcast manager URL's (although maybe this is just Joomla's url rewriting...)

Any ideas?

@mbabker
BabDev member

I don't think this is an issue with my code, but something in the routing somewhere. It's 404'ing because the slash between index.php and component is getting stripped out, for reasons I couldn't begin to troubleshoot (me and the routing system don't get along). I tried the raw, non-SEF URL also and it got re-written to your broken URL. Here's my output from my attempted connection using cURL:

curl -v --url "http://kickstartershq.com/index.php?option=com_podcastmanager&view=feed&format=raw&feedname=1"
` About to connect() to kickstartershq.com port 80 (#0)
Trying 206.126.97.11...
connected
Connected to kickstartershq.com (206.126.97.11) port 80 (#0)

GET /index.php?option=com_podcastmanager&view=feed&format=raw&feedname=1 HTTP/1.1
User-Agent: curl/7.24.0 (x86_64-apple-darwin12.0) libcurl/7.24.0 OpenSSL/0.9.8r zlib/1.2.5
Host: kickstartershq.com
Accept: /

< HTTP/1.1 301 Moved Permanently
< Date: Fri, 28 Dec 2012 22:46:27 GMT
< Server: LiteSpeed
< Connection: close
< Set-Cookie: f94fa850a447863645730efa368cfa09=aaf1d58f23058b55c016faa392d1bd6a; path=/
< Location: http://kickstartershq.com/index.phpcomponent/podcastmanager/feed/1?format=raw
< Content-Type: text/html; charset=utf-8
< Content-Length: 0
< Vary: User-Agent
<
Closing connection #0`

@mbabker mbabker closed this May 18, 2013
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment