Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[Notice] I'm looking for a new maintainer for Ubuntu 16.04, Flatpack and Snap packeges #49

Open
Bajoja opened this issue Apr 3, 2017 · 25 comments

Comments

@Bajoja
Copy link
Owner

commented Apr 3, 2017

After read this this i figure out that our Ubuntu package mainter Alexey ‘Varlesh‘ Varfolomeev is not available anymore, that's why Ubuntu package is late.

If anyone wants to keep it and create a new PPA, let me know.

I also look for someone who wants to keep FlatPack and Snap too. #45

@Bajoja Bajoja changed the title I'm looking for a new maintainer for Ubuntu 16.04, Flatpack and Snap packeges [ Notice] I'm looking for a new maintainer for Ubuntu 16.04, Flatpack and Snap packeges Apr 3, 2017

@Bajoja Bajoja changed the title [ Notice] I'm looking for a new maintainer for Ubuntu 16.04, Flatpack and Snap packeges [Notice] I'm looking for a new maintainer for Ubuntu 16.04, Flatpack and Snap packeges Apr 3, 2017

@ghost

This comment has been minimized.

Copy link

commented Apr 5, 2017

As an idea, have you tried reaching out for the webupd8 guys? It's where I've heard about this fantastic project in the first place. They already have a reputable site and a PPA packaging all sort of software not available in the base ubuntu repositories.

@Bajoja

This comment has been minimized.

Copy link
Owner Author

commented Apr 5, 2017

@hotice, can webupd8 ppa have this?

@hotice

This comment has been minimized.

Copy link

commented Apr 6, 2017

@Bajoja sure. Would you prefer I use the main WebUpd8 PPA (which has multiple packages) or a separate PPA?

@hotice

This comment has been minimized.

Copy link

commented Apr 6, 2017

On a second thought, I'll create a new PPA so I can update KDE Connect as well, without affecting any KDE users that have the main WebUpd8 PPA enabled, since it might break things in KDE.

I'll try to set it up today or tomorrow.

@Bajoja

This comment has been minimized.

Copy link
Owner Author

commented Apr 6, 2017

@hotice, probably create a new PPA will be the better option because conflicts with kdeconnect, unless it not cause conflicts with KDE users.

@hotice

This comment has been minimized.

@Bajoja

This comment has been minimized.

Copy link
Owner Author

commented Apr 7, 2017

@hotice, Thanks I will update the README soon

@niemeyer

This comment has been minimized.

Copy link

commented Apr 7, 2017

This might be a good place to find people interested in the snap package:

https://forum.snapcraft.io/t/kde-connect-indicator-wants-a-snap-package/207

There's also some tooling being put in place that will allow you to effortlessly publish new snaps by simply pushing into your repository.

@LyzardKing

This comment has been minimized.

Copy link

commented Apr 21, 2017

@Bajoja
Hi! I made a snap. At the moment it relies on a few tweaks on the source of kdeconnect
and indicator-kdeconnect.
To be precise, https://github.com/Bajoja/indicator-kdeconnect/blob/master/src/KDEConnectManager.vala#L171 should not be a direct path, but instead use GLib.
It works if I set it to

GLib.Environment.get_system_config_dirs()[0] + "/autostart/kdeconnectd.desktop"},

instead of

"/etc/xdg/autostart/kdeconnectd.desktop"},

@Bajoja

This comment has been minimized.

Copy link
Owner Author

commented Apr 21, 2017

@LyzardKing, Hi, so i will make changes soon, thanks.

@Bajoja

This comment has been minimized.

Copy link
Owner Author

commented Apr 22, 2017

@LyzardKing i made the changes on f896514

@LyzardKing

This comment has been minimized.

Copy link

commented Apr 22, 2017

@Bajoja
I'll try. We need to see if it works persistently.
I'm not experienced in vala, so it was mostly a fix on my system.
As soon as I can I'll upload the snap yaml

@Bajoja

This comment has been minimized.

Copy link
Owner Author

commented Apr 22, 2017

@Bajoja

This comment has been minimized.

Copy link
Owner Author

commented May 1, 2017

@LyzardKing how the work is going?

@LyzardKing

This comment has been minimized.

Copy link

commented May 2, 2017

@Bajoja If I run snapcraft cleanbuild (basically in a clean vm) indicator-kdeconnect works fine, but kdeconnect itself doesn't build because of some libraries that are not updated on xenial. (mostly)
In "normal" ubuntu it builds properly. It might need a few tweaks for permissions still..
If I run it locally in ubuntu mate the get_system_config_dirs()[0] picks up the wrong dir, because it reads XDG_CONFIG_DIRS. In this case it's /etc/xdg/xdg-mate:/etc/xdg, so it reads the first one.
The same goes for the icon in the indicator. That too needs to not be hardcoded but to have a method of some kind.

@Bajoja

This comment has been minimized.

Copy link
Owner Author

commented May 2, 2017

Ok, i will make the function get the right path, at the moment it's better launch a beta for normal Ubuntu and then make changes with people feedback for the others.

@LyzardKing

This comment has been minimized.

Copy link

commented May 2, 2017

https://github.com/LyzardKing/indicator-kdeconnect
@Bajoja This is the repo with the snap yaml.
I don't have time today, but I'll see if I can spin up a vm with ubuntu proper and build it there.
I can't use the cleanbuild because there are some dependencies that are not in the xenial archive.
Maybe @hotice could help me there? What would I have to change if I wanted to build kdeconnect for xenial? (the issue is kdexonnect, not the indicator)

@Bajoja

This comment has been minimized.

Copy link
Owner Author

commented May 4, 2017

@LyzardKing Ok, you are doing a nice work, let see if someone answer your question.

@MrMarukesu

This comment has been minimized.

Copy link

commented Jul 30, 2017

Hey, I'm make a Flatpak manifest for indicator-kdeconnect (https://github.com/MrMarukesu/flatpak-indicator-kdeconnect).
it is running and recive the notifications, but, i can't make the indicator appears in the wingpanel (i don't know if it's appear in others DE), also needs some data files like the kdeconnect icon and a way to execulte the indicator-kdeconnect-settings because flatpak don't run apps that has a diferent application-id from the flatpak manifest.

@falinkv

This comment has been minimized.

Copy link

commented Aug 31, 2017

ubuntu 16.04.3 i386 after restart kdeconnect does not start. If you run the setup utility, then the icon appears and everything seems to work until the next reboot. How to run kdeconnectd without the utility?

@Bajoja

This comment has been minimized.

Copy link
Owner Author

commented Sep 5, 2017

@falinkv it's on your start up applications?

@phd21

This comment has been minimized.

Copy link

commented Oct 31, 2017

Hi Bajoja and Everyone Else,

In addition to (or instead of) creating "Flatpak" and or "Snap" packages, why not create an "AppImage" package? Is creating an AppImage a possibility that would work well too?

I have noticed that I can easily install AppImage software packages for Linux Mint 18.x based on Ubuntu 16.04 and that they usually work well in my Linux Mint 17.3 system based on Ubuntu 14.04 too...

I currently am using Linux Mint KDE 17.3 and Linux Mint KDE 18.2, but Linux Mint is discontinuing (phasing out) their KDE version, so being able to install KDE Connect indictor in Cinnamon, Mate or Xfce will be very helpful.

Best regards to everyone involved in this project,
Phil
phd21

@MrMarukesu

This comment has been minimized.

Copy link

commented Nov 10, 2017

Flatpak is now in Flathub Repository

@Fuseteam

This comment has been minimized.

Copy link

commented Nov 26, 2018

i found kdeconnect in the snapstore but i get this error trying to launch it:
image
i can't seem to find lizardking's repo either

@BloodyIron

This comment has been minimized.

Copy link

commented Dec 1, 2018

So yeah, was about to make yet another ticket for Ubuntu 18.10 for the PPA, so any chance we can get the PPA updated with a release file for Cosmic please? :)

Or some sort of other solution.

I'm mainly looking to use this in XFCE.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
9 participants
You can’t perform that action at this time.