Gemfile may be too strict in ruby-termios version requirement #920
After installing COSMOS 4.3.0 on Linux (Ubuntu 18.10), the demo fails to start due to its Gemfile requiring a version of ruby-termios in the 0.9x range:
gem 'ruby-termios', '~> 0.9' if RbConfig::CONFIG['target_os'] !~ /mswin|mingw|cygwin/i and RUBY_ENGINE=='ruby'
The error message is:
Could not find gem 'ruby-termios (~> 0.9)' in any of the gem sources listed in your Gemfile. Run `bundle install` to install missing gems.
Indeed, the latest version of the ruby-termios Gem (and the one that was installed) is 1.0.2. Changing the version requirement operator in the Gemfile from "~> 0.9" to ">= 0.9" appears to allow normal operation.
I am currently facing that same problem. How can I fix this?
I install cosmos correctly with
Ah, okay, after struggling with this issue for nearly an hour, I just fixed it using the referenced commit.