Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Newer
Older
100644 21 lines (18 sloc) 0.482 kb
18b45d5 @ryanb adding Gemfile, to get specs running just bundle and rake - closes #163
ryanb authored
1 source "http://rubygems.org"
2dc2a57 @ryanb move mongoid/dm gems into Gemfile and load dynamically based on MODEL_AD...
ryanb authored
2
3 case ENV["MODEL_ADAPTER"]
4c5ba09 @ryanb adding model adapter files in proper location with loading behavior
ryanb authored
4 when nil, "active_record"
bcf2756 @ryanb simplifying .rvmrc
ryanb authored
5 gem "sqlite3"
916f97f @ryanb updating Rails gem dev dependency
ryanb authored
6 gem "activerecord", '~> 3.0.9', :require => "active_record"
5ab7dea @kirkconnell use version 1.x of with_model to avoid errors in class comparisons
kirkconnell authored
7 gem "with_model", '~> 0.1.5'
52435e9 @ryanb fixing association conditions when MetaWhere is installed (thanks acmete...
ryanb authored
8 gem "meta_where"
4c5ba09 @ryanb adding model adapter files in proper location with loading behavior
ryanb authored
9 when "data_mapper"
10 gem "dm-core", "~> 1.0.2"
15ca8ad @ryanb improving DataMapper adapter and specs
ryanb authored
11 gem "dm-sqlite-adapter", "~> 1.0.2"
12 gem "dm-migrations", "~> 1.0.2"
2dc2a57 @ryanb move mongoid/dm gems into Gemfile and load dynamically based on MODEL_AD...
ryanb authored
13 when "mongoid"
14 gem "bson_ext", "~> 1.1"
344832d @stellard updated mongoid
stellard authored
15 gem "mongoid", "~> 2.0.0.beta.20"
bbb02f7 @ryanb dynamically detect which model adapter to use given a class
ryanb authored
16 else
17 raise "Unknown model adapter: #{ENV["MODEL_ADAPTER"]}"
2dc2a57 @ryanb move mongoid/dm gems into Gemfile and load dynamically based on MODEL_AD...
ryanb authored
18 end
4c5ba09 @ryanb adding model adapter files in proper location with loading behavior
ryanb authored
19
20 gemspec
Something went wrong with that request. Please try again.