Permalink
Browse files

disable z() if fasd is enabled

loading fasd clobbers z(), and results in a cryptic syntax error
message, since 'z' is already an alias when z.plugin.bash is being
sourced.

this conditional detects this situation and returns early.
  • Loading branch information...
erichs committed May 13, 2012
1 parent 55e77de commit 8051a8520e436dd11e96cbaf04f1957302d526fc
Showing with 5 additions and 0 deletions.
  1. +5 −0 plugins/available/z.plugin.bash
@@ -15,6 +15,11 @@ about-plugin ' z is DEPRECATED, use fasd instead'
# * z -t foo # goes to most recently accessed dir matching foo
# * z -l foo # list all dirs matching foo (by frecency)
+if [ -h $BASH_IT/plugins/enabled/fasd.plugin.bash ]; then
+ printf '%s\n' 'sorry, the z plugin is incompatible with the fasd plugin. you may use either, but not both.'
+ return
+fi
+
z() {
local datafile="$HOME/.z"
if [ "$1" = "--add" ]; then

0 comments on commit 8051a85

Please sign in to comment.