Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

macOS Catalina Crash — Incompatible Library #5385

Closed
aratuk opened this issue Jul 22, 2019 · 4 comments
Closed

macOS Catalina Crash — Incompatible Library #5385

aratuk opened this issue Jul 22, 2019 · 4 comments

Comments

@aratuk
Copy link

@aratuk aratuk commented Jul 22, 2019

Rawtherapee Version: 5.6
Branch: 5.6
Commit: 5a4ed7317
Commit date: 2019-04-20
Compiler: clang 10.0.1.10010046
Processor: generic x86
System: Apple
Bit depth: 64 bits
Gtkmm: V3.24.1
Lensfun: V0.3.95.0

System: macOS Catalina 10.15 Beta (19A512f), Darwin 19.0.0 Darwin Kernel Version 19.0.0; root:xnu-6153.0.59.141.4~1/RELEASE_X86_64 x86_64

RawTherapee crashes every time on open. (What I think is) the relevant portion of the crash log is as follows:

Time Awake Since Boot: 1400 seconds

System Integrity Protection: enabled

Crashed Thread:        0

Exception Type:        EXC_CRASH (SIGABRT)
Exception Codes:       0x0000000000000000, 0x0000000000000000
Exception Note:        EXC_CORPSE_NOTIFY

Termination Reason:    DYLD, [0x3] Wrong version

Application Specific Information:
dyld: launch, loading dependent libraries
DYLD_LIBRARY_PATH=/Applications/RawTherapee.app/Contents/Frameworks

Dyld Error Message:
  Library not loaded: /usr/lib/libexpat.1.dylib
  Referenced from: /System/Library/Frameworks/ImageIO.framework/Versions/A/ImageIO
  Reason: Incompatible library version: ImageIO requires version 7.0.0 or later, but libexpat.1.dylib provides version 1.0.0

Please let me know if I've left out any important info. Apologies if this is already addressed elsewhere; I searched but didn't find anything.

@aratuk

This comment has been minimized.

Copy link
Author

@aratuk aratuk commented Jul 22, 2019

I downloaded a dev build that does not have this issue. So, assuming there aren't reversions that cause the bug to be retained, it will already have been fixed in a future stable build.

Info for build where bug is fixed:

Version: 5.6-73-gf0d32c1da
Branch: dev
Commit: f0d32c1da
Commit date: 2019-06-09
Compiler: clang 11.0.0.11000020
Processor: generic x86
System: Apple
Bit depth: 64 bits
Gtkmm: V3.24.1
Lensfun: V0.3.95.0
Build type: release
Build flags: -std=c++11 -std=c++11 -mtune=generic -Werror=unused-label -mmacosx-version-min=10.9 -flto -Wall -Wuninitialized -Wno-deprecated-declarations -Wno-unused-result -Xpreprocessor -fopenmp /opt/local/lib/libomp.dylib -I/opt/local/include -Werror=unknown-pragmas -O3 -DNDEBUG -ftree-vectorize
Link flags:  -mtune=generic -headerpad_max_install_names -flto
OpenMP support: ON
MMAP support: ON
@Beep6581

This comment has been minimized.

Copy link
Owner

@Beep6581 Beep6581 commented Jul 22, 2019

Ping @Benitoite

@Benitoite

This comment has been minimized.

Copy link
Contributor

@Benitoite Benitoite commented Jul 22, 2019

No problem. You guys are the first to report anything from Catalina.

MacOS 10.15 will introduce a new set of security features which prevent some apps from running without changing the default security settings. At the time 5.6 was released the first Catalina beta had only just been seeded, and there was not enough time for me to figure out app notarization, which has been added to the dev branch already as mentioned by @aratuk

@Beep6581

This comment has been minimized.

Copy link
Owner

@Beep6581 Beep6581 commented Jul 22, 2019

@Benitoite so nothing to do and ok to close?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.