New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

SoundSwitch Freezing randomly. #200

Closed
Laserman49 opened this Issue Jun 15, 2017 · 44 comments

Comments

Projects
None yet
8 participants
@Laserman49

Laserman49 commented Jun 15, 2017

Hello all.
I'm on Windows 10 Creators Update Pro x64 (version 1703) with SoundSwitch version 3.15.0.37396.
When I switch to my different sounds output devices with the combination of Alt+Ctrl+F11, Soundswitch is bugging for me, when I try to access it with right clic next to the clock icon in the taskbar, the menu appear, but it is freezed and the banner is freezed too, i can't do anything else to Ctrl+Shift+Esc and kill soundswitch to reload it, to retrieve access of the right clic menu.

SoundSwitch.zip

@FireEmerald

This comment has been minimized.

Collaborator

FireEmerald commented Jun 16, 2017

Is this problem present since you installed SoundSwitch or only since a few days/weeks?
Did you tried to set another hotkey combination and/or change the notification method?

@Laserman49

This comment has been minimized.

Laserman49 commented Jun 16, 2017

It's only when I installed SoundSwitch, and my installation of Windows is new, less than 1 week, I formated my PC do did it.
With another hotkeys it's the same problem, and with another notification method same problem too.

@Belphemur

This comment has been minimized.

Owner

Belphemur commented Jun 16, 2017

@Laserman49 Can you try with an older version?

https://github.com/Belphemur/SoundSwitch/releases/tag/v3.13.2

@FireEmerald I want to check if the problem is related to VS 2017 compiler.

@Belphemur Belphemur added the Bug label Jun 16, 2017

@Laserman49

This comment has been minimized.

Laserman49 commented Jun 16, 2017

@Laserman49

This comment has been minimized.

Laserman49 commented Jun 17, 2017

@Belphemur

This comment has been minimized.

Owner

Belphemur commented Jun 17, 2017

Okay that helps a lot.

Disable the auto-update the time we resolve this. I want to be sure it's linked to VS 2017.

@Laserman49

This comment has been minimized.

Laserman49 commented Jun 17, 2017

Ok, I will do that. Say me when it's solved please.

@Belphemur

This comment has been minimized.

Owner

Belphemur commented Jun 17, 2017

I'm keeping the issue open until we're sure it's resolved.

Do you mind trying in the future beta version that should resolve the issue as we're not able to reproduce it on our machines ?

@Laserman49

This comment has been minimized.

Laserman49 commented Jun 17, 2017

@Laserman49

This comment has been minimized.

Laserman49 commented Jun 17, 2017

@Laserman49

This comment has been minimized.

Laserman49 commented Jun 20, 2017

No news about this bug ?

@Belphemur

This comment has been minimized.

Owner

Belphemur commented Jun 20, 2017

I'm sorry my main computer is in repair. I'm not able to recompile this for now to give you a beta version easily.

@Laserman49

This comment has been minimized.

Laserman49 commented Jun 20, 2017

@fredgreco

This comment has been minimized.

fredgreco commented Jun 27, 2017

I just want to say I have this bug also (I think). Often when I wake the PC from sleep, if I left click or right click on the Soundswitch icon the menu pops up but freezes. A quit from task manager and restart makes it work fine.

@Laserman49

This comment has been minimized.

Laserman49 commented Jun 27, 2017

Exactly the same problem like me, except that problem is also at the first use of Soundswitch after PC Turned on. If i kill the app with Task Manager, and relaunch it, no problem, it works fine.

@hellonearthis

This comment has been minimized.

hellonearthis commented Jun 28, 2017

I installed the old version which installed the .net framework, then installed the new version and can now change between devices.

@Laserman49

This comment has been minimized.

Laserman49 commented Jul 8, 2017

@fredgreco

This comment has been minimized.

fredgreco commented Jul 8, 2017

I think the newest version solves the bug. Is that correct?

@Laserman49

This comment has been minimized.

Laserman49 commented Jul 8, 2017

@Belphemur

This comment has been minimized.

Owner

Belphemur commented Jul 8, 2017

@Laserman49 Darn, I hoped this version would solve the issue by forcing to upgrade the VC Redis C++ to 2017.

Can you try this little util for me, do a screenshot of it after running it:
https://github.com/Belphemur/AudioEndPointLibrary/releases/download/v4.7.0/AudioTester_x64.zip

@Belphemur

This comment has been minimized.

Owner

Belphemur commented Jul 8, 2017

In fact, use this latest version:

https://github.com/Belphemur/AudioEndPointLibrary/releases/tag/v4.7.1

Also, tell me what happens when you input the letter "s" and push enter.

Does it crash ?

@Belphemur Belphemur reopened this Jul 8, 2017

@Laserman49

This comment has been minimized.

Laserman49 commented Jul 8, 2017

@Belphemur

This comment has been minimized.

Owner

Belphemur commented Jul 8, 2017

@Laserman49 It seems you can't attach file to comment using the email. You need to do it from the web interface.

@Laserman49

This comment has been minimized.

Laserman49 commented Jul 8, 2017

@Laserman49

This comment has been minimized.

Laserman49 commented Jul 8, 2017

@Belphemur

This comment has been minimized.

Owner

Belphemur commented Jul 8, 2017

Okay, no issue with the first one, compiled with VS 2015

Can you try the second one ?

https://github.com/Belphemur/AudioEndPointLibrary/releases/download/v4.7.1/AudioTester_x64.zip

@Laserman49

This comment has been minimized.

Laserman49 commented Jul 8, 2017

Tried, and this the file.
audiotester 2

@Belphemur

This comment has been minimized.

Owner

Belphemur commented Jul 8, 2017

If you do s -> enter

Does it change your audio device ?
Do you get the notification from SoundSwitch in the same time.

From the screenshot, it seems the audio device is changed successfully, I start to think it's a problem with the version of .NET not VC Redist...

@Laserman49

This comment has been minimized.

Laserman49 commented Jul 9, 2017

Yes, it change my audio device when I use s and enter, but it switch with devices that I have not selected in Soundswitch.

@Belphemur

This comment has been minimized.

Owner

Belphemur commented Jul 9, 2017

@Laserman49 That's normal, it's made as a testing tool to see if the problem lies within the underlying component of SoundSwitch or SoundSwitch itself.

For what I gather from your testing, I need to check the .NET wrapper and SoundSwitch code to understand what is causing that freeze you're observing.

@Laserman49

This comment has been minimized.

Laserman49 commented Jul 11, 2017

Do you think you will solve the problem ?

@Belphemur

This comment has been minimized.

Owner

Belphemur commented Jul 11, 2017

@fredgreco

This comment has been minimized.

fredgreco commented Jul 26, 2017

Any progress on the bug that causes a freeze when you right click on the status tray icon? You have to manually stop Soundswitch using Task Manager and then restart to get right click options to work.

@fredgreco

This comment has been minimized.

fredgreco commented Aug 24, 2017

Still experiencing the freezing behavior on right-click. Any progress on that bug?

@Belphemur

This comment has been minimized.

Owner

Belphemur commented Aug 24, 2017

@fredgreco

This comment has been minimized.

fredgreco commented Sep 5, 2017

Any idea when this might be addressed?

@synchronos-t

This comment has been minimized.

synchronos-t commented Oct 1, 2017

I believe I have the same issue as the original poster. SoundSwitch always freezes if I try to use the hotkey to switch audio source (I have changed it to Ctrl+Shift+F12). It doesn't happen if I first open the tray icon menu (either the left-click audio select menu or the right-click settings menu). But it always happen if I use the hotkey first after starting the application.

The tray icon still responds to the menu open clicks (i.e. the left-click or right-click to open the audio select menu or the settings menu), but both menus have an infinite revolving blue wheel (i.e. the "hourglass cursor") and do nothing on further clicks.

I'm using the latest version (3.15.1.15427). Would you like that I provided some other information about my system?

@Belphemur

This comment has been minimized.

Owner

Belphemur commented Oct 2, 2017

@fredgreco

This comment has been minimized.

fredgreco commented Nov 13, 2017

Any word on the bug? Nearly every time I boot up or wake from sleep, the Soundswitch tray menu cannot be clicked with the left or right mouse button. Either just causes it to hang and I have to force quit with Task Manager.

@Simssmith

This comment has been minimized.

Simssmith commented Nov 19, 2017

Unable to switch by using Alt-Ctrl-F11 . It was working just fine few weeks ago. I made no changes beside maybe Windows OS auto update.

@Belphemur

This comment has been minimized.

Owner

Belphemur commented Nov 20, 2017

@Belphemur Belphemur referenced this issue Nov 24, 2017

Closed

Rewrite of the core of SoundSwitch #224

5 of 5 tasks complete
@Belphemur

This comment has been minimized.

Owner

Belphemur commented Nov 26, 2017

@ngalluzzo

This comment has been minimized.

ngalluzzo commented Nov 29, 2017

Still having the same issue in latest beta.

@Belphemur

This comment has been minimized.

Owner

Belphemur commented Nov 29, 2017

@ngalluzzo Do you have the freezing behavior describe here or simple the hotkeys don't respond ?

if it's the second one, please change the hotkeys to another set of keys.

@Belphemur Belphemur changed the title from Hotkeys Alt+Ctrl+F11 bug. to SoundSwitch Freezing randomly. Nov 29, 2017

@Belphemur Belphemur referenced this issue Nov 30, 2017

Merged

Rewrite #226

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment