Skip to content

ERROR: Failed to receive response! #27

Closed
dbtsai opened this Issue Nov 26, 2011 · 3 comments

4 participants

@dbtsai
dbtsai commented Nov 26, 2011

My phone is Samsung Captivate, and since my phone is semi-bricked captivate, I use USB jig to get into recovery mode. Now, I would like to flash the stock ROM back to my phone. I compiled Heimdall from source (the current development version from github) in ubuntu 11.10. When I try to flash the ROM, I get the following error message. However, in Heimdall front-end, the tab of utility shows that Device detected.

Have been spending several hours on it without any clues.

Thanks.

Heimdall v1.3.1, Copyright (c) 2010-2011, Benjamin Dobell, Glass Echidna
http://www.glassechidna.com.au

This software is provided free of charge. Copying and redistribution is
encouraged.

If you appreciate this software and you would like to support future
development please consider donating:
http://www.glassechidna.com.au/donate/

Initialising connection...
Detecting device...
Product: "Gadget Serial"
Serial No: "?"

        length: 18
  device class: 2
           S/N: 0
       VID:PID: 04E8:6601
     bcdDevice: 021B

iMan:iProd:iSer: 1:2:0
nb confs: 1

interface[0].altsetting[0]: num endpoints = 1
Class.SubClass.Protocol: 02.02.01
endpoint[0].address: 83
max packet size: 0010
polling interval: 09

interface[1].altsetting[0]: num endpoints = 2
Class.SubClass.Protocol: 0A.00.00
endpoint[0].address: 81
max packet size: 0200
polling interval: 00
endpoint[1].address: 02
max packet size: 0200
polling interval: 00
Claiming interface...
Setting up interface...

Checking if protocol is initialised...
Protocol is not initialised.
Initialising protocol...
Handshaking with Loke...
ERROR: Failed to receive response!

@MrAwesome

Did you ever resolve this issue? I'm experiencing the same problem.

@Benjamin-Dobell
Owner

Please try the Heimdall 1.4 release candidate to ensure this is fixed. If not, you can let me know if the problem still persists by re-opening the issue.

@d-max
d-max commented Oct 15, 2013

I have solved this issue by rebooting device into download mode again.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.