Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Incorrect npm-shrinkwrap.json has been pushed #125

Closed
goremikin opened this issue Apr 15, 2020 · 2 comments
Closed

Incorrect npm-shrinkwrap.json has been pushed #125

goremikin opened this issue Apr 15, 2020 · 2 comments

Comments

@goremikin
Copy link

@goremikin goremikin commented Apr 15, 2020

Description

Starting with version 6.0.1 npm-shrinkwrap.json file has been added, which causes a lot of extraneous packages to be installed (which eventually are part of dev-dependencies, like jest).

Setup configuration

  • ESLint version: 6.8.0
  • eslint-plugin-html version: 6.0.1
@BenoitZugmeyer
Copy link
Owner

@BenoitZugmeyer BenoitZugmeyer commented Apr 15, 2020

Thank you for pointing this out. This is because of a NPM change: npm-shrinkwrap.json files cannot be ignored anymore. I wonder why they accepted such a breaking change without announcing it further. Anyway... I'll fix this soon.

Further details: this change have been released in npm-packlist@1.4.5 and npm-cli 6.12.1 (update to npm-packlist@1.4.6 directly)

@BenoitZugmeyer
Copy link
Owner

@BenoitZugmeyer BenoitZugmeyer commented Apr 15, 2020

Should be fixed and published in 6.0.2! Let me know if it works for you :) Thanks again.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
2 participants