Skip to content

Error running new install of ultra repel #9

Closed
ticviking opened this Issue Jun 5, 2012 · 3 comments

4 participants

@ticviking

I installed using 'npm install -g ultra-repl' on os X 10.6.8

on my first attempt to run I get
'$ ultra-repl
[TypeError: Object.defineProperty called on non-object]'

@xemoka
xemoka commented Jun 8, 2012

Same problem here on windows xp resulting from `C:>ultra-repl' or from running ultra-repl.cmd

If I attempt to load it through a require (new to node, but I think this is correct) it spits out these errors:

> var UltraREPL = require('<path to user global npm dir>\\node_modules\\ultra-repl');

[TypeError: Object.defineProperty called on non-object]
TypeError: Cannot read property '_cache' of undefined
    at Object.<anonymous> (C:\Documents and Settings\jrobinson\Application Data\npm\node_modules\ultra-repl\lib\ScopedModule.js:58:13)
    at Object.<anonymous> (C:\Documents and Settings\jrobinson\Application Data\npm\node_modules\ultra-repl\lib\ScopedModule.js:187:24)
    at ScopedModule.run (C:\Documents and Settings\jrobinson\Application Data\npm\node_modules\ultra-repl\lib\ScopedModule.js:188:9)
    at ScopedModule._compile (C:\Documents and Settings\jrobinson\Application Data\npm\node_modules\ultra-repl\lib\ScopedModule.js:252:28)
    at Object..js (module.js:464:10)
    at ScopedModule.load (module.js:353:31)
    at Function._load (C:\Documents and Settings\jrobinson\Application Data\npm\node_modules\ultra-repl\lib\ScopedModule.js:160:19)
    at ScopedModule.require (C:\Documents and Settings\jrobinson\Application Data\npm\node_modules\ultra-repl\lib\ScopedModule.js:226:25)
    at require (C:\Documents and Settings\jrobinson\Application Data\npm\node_modules\ultra-repl\lib\ScopedModule.js:232:19)
    at Object.<anonymous> (C:\Documents and Settings\jrobinson\Application Data\npm\node_modules\ultra-repl\lib\Context.js:4:20)
@boxxxie
boxxxie commented Nov 1, 2012

i'm here to add another related report. ubuntu 12.10

$ sudo npm install -g ultra-repl
npm http GET https://registry.npmjs.org/ultra-repl
npm http 304 https://registry.npmjs.org/ultra-repl
npm http GET https://registry.npmjs.org/esprima
npm http GET https://registry.npmjs.org/repl-rainbow
npm http 304 https://registry.npmjs.org/repl-rainbow
npm http 304 https://registry.npmjs.org/esprima
/usr/local/bin/ultra-repl -> /usr/local/lib/node_modules/ultra-repl/bin/ultra-repl.js
ultra-repl@0.8.6 /usr/local/lib/node_modules/ultra-repl
├── repl-rainbow@0.1.1
└── esprima@1.0.1

$ ultra-repl 
/usr/local/bin/ultra-repl: line 1: syntax error near unexpected token `('
/usr/local/bin/ultra-repl: line 1: `var UltraREPL = require('../');'
@Benvie
Owner
Benvie commented Nov 27, 2012

fixed

@Benvie Benvie closed this Nov 27, 2012
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.