Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Upgrade spring data integration to support Spring Boot 1.5.x #406

Closed
anthofo opened this issue Apr 6, 2017 · 2 comments

Comments

@anthofo
Copy link

commented Apr 6, 2017

The EntityViewRepositoryFactoryBean is no longer compatible with spring after upgrading to Spring Boot 1.5.2, because of a default constructor no longer available in the extended TransactionalRepositoryFactoryBeanSupport. The app will crash at startup

@beikov beikov self-assigned this Apr 6, 2017

@beikov beikov added this to the 1.2.0 milestone Apr 6, 2017

@beikov

This comment has been minimized.

Copy link
Member

commented Apr 6, 2017

Sorry you are having trouble. I will look into this. Too bad spring data isn't designed in a way so that other libraries can provide extensions :/

@anthofo

This comment has been minimized.

Copy link
Author

commented Apr 6, 2017

I hope they will improve this in a next release, extending the spring repositories factories is not an easy thing

@beikov beikov assigned Mobe91 and unassigned beikov Apr 10, 2017

Mobe91 added a commit to Mobe91/blaze-persistence that referenced this issue Apr 11, 2017

@beikov beikov closed this in fa7fafa Apr 13, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.