New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

dramatiq should work with python >= 3.4. #7

Closed
jssuzanne opened this Issue Nov 9, 2017 · 7 comments

Comments

2 participants
@jssuzanne
Contributor

jssuzanne commented Nov 9, 2017

Hi,

Actually dramatiq works only with python 3.6 and 3.7a. the linux distribution haven't got theses versions of python. Why don't you keep the capability to use use Python 3.4 and highter

@Bogdanp Bogdanp added the enhancement label Nov 10, 2017

@jssuzanne

This comment has been minimized.

Contributor

jssuzanne commented Nov 15, 2017

I have started, the implementation in the branch.

For python 3.5, it is easy I have juste replaced print(f"{}") by print("%s" % ...) .
Python 3.4 is harder, yield from does not work with pip install, I removed it in setup.py. the return self._replace(**attributes, options=options) is forbidden, I replaced it. I waiting travis, but some test seem faild.

I don't know if the fix will be easy.

Do you want a PR for Python3.5 alone or you would like to wait both.

@Bogdanp

This comment has been minimized.

Owner

Bogdanp commented Nov 16, 2017

Yeah, let's do it with 3.5 first. Don't forget to add yourself to the contributors file (people often do :P)!

@Bogdanp

This comment has been minimized.

Owner

Bogdanp commented Nov 17, 2017

The 3.4 branch is blocked by this CPython issue: https://bugs.python.org/msg306427

@Bogdanp

This comment has been minimized.

Owner

Bogdanp commented Nov 17, 2017

Since it sounds like the issue is not going to be fixed in 3.4, I'm not going to exert any more effort into supporting that version.

@Bogdanp Bogdanp closed this Nov 17, 2017

@jssuzanne

This comment has been minimized.

Contributor

jssuzanne commented Nov 17, 2017

You are right, python 3.5 is a good step, enough for now

@Bogdanp

This comment has been minimized.

Owner

Bogdanp commented Nov 17, 2017

Yup! I forgot to mention: 0.13.1 is released with support for 3.5 :D

@jssuzanne

This comment has been minimized.

Contributor

jssuzanne commented Nov 17, 2017

I saw it ;)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment