Skip to content
f9670ad backers: drop no-longer-backers
2 cancelled , 1 successful , and 1 failing checks

Test 3.5

Cancelled

ran Jul 2, 2019 in 8 minutes

f9670ad by @Bogdanp

master

Test 3.5

Cancelled

Details

### CANCELLED Test 3.5 06:12:42Z

Pulling image: gcr.io/github-actions-images/action-runner:latest
latest: Pulling from github-actions-images/action-runner
169185f82c45: Pulling fs layer
0ccde4b6b241: Pulling fs layer
d0372f57daa2: Pulling fs layer
165911d108d6: Pulling fs layer
54996bce1de5: Pulling fs layer
0ccde4b6b241: Download complete
d0372f57daa2: Download complete
54996bce1de5: Verifying Checksum
54996bce1de5: Download complete
165911d108d6: Verifying Checksum
165911d108d6: Download complete
169185f82c45: Pull complete
0ccde4b6b241: Pull complete
d0372f57daa2: Pull complete
165911d108d6: Pull complete
54996bce1de5: Pull complete
Digest: sha256:c9bb432ec5ec08ee08b040a9fccacebbbf8a91444dac4721600cf5dca9dae57e
Status: Image is up to date for gcr.io/github-actions-images/action-runner:latest
e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855: Pulling from gct-12-ba4zwhw9r2zhduezw8mftgj/e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855/54611d6d4bfd75917b11fde8af74a6edfa3ac803ff32dc8d0e8d46f4e5c2ab70
743f2d6c1f65: Pulling fs layer
977e13fc7449: Pulling fs layer
8c12ba145e05: Pulling fs layer
562ee13e1ce1: Pulling fs layer
56123bf89135: Pulling fs layer
35999c631617: Pulling fs layer
562ee13e1ce1: Waiting
56123bf89135: Waiting
35999c631617: Waiting
977e13fc7449: Verifying Checksum
977e13fc7449: Download complete
743f2d6c1f65: Verifying Checksum
743f2d6c1f65: Download complete
562ee13e1ce1: Verifying Checksum
562ee13e1ce1: Download complete
56123bf89135: Verifying Checksum
56123bf89135: Download complete
8c12ba145e05: Verifying Checksum
8c12ba145e05: Download complete
35999c631617: Verifying Checksum
35999c631617: Download complete
743f2d6c1f65: Pull complete
977e13fc7449: Pull complete
8c12ba145e05: Pull complete
562ee13e1ce1: Pull complete
56123bf89135: Pull complete
35999c631617: Pull complete
Digest: sha256:cc30e0e9182247ad8c3875ac7eb9fa8d111245ba496d27fc3b82bbe8b5568b39
Status: Downloaded newer image for gcr.io/gct-12-ba4zwhw9r2zhduezw8mftgj/e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855/54611d6d4bfd75917b11fde8af74a6edfa3ac803ff32dc8d0e8d46f4e5c2ab70:e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855
Step 1/2 : FROM python:3.5-slim
3.5-slim: Pulling from library/python
fc7181108d40: Already exists
01f3b6f74410: Already exists
9c9c9b85a5ad: Pulling fs layer
481feefa8801: Pulling fs layer
8f3990e5cd21: Pulling fs layer
481feefa8801: Verifying Checksum
481feefa8801: Download complete
8f3990e5cd21: Verifying Checksum
8f3990e5cd21: Download complete
9c9c9b85a5ad: Verifying Checksum
9c9c9b85a5ad: Download complete
9c9c9b85a5ad: Pull complete
481feefa8801: Pull complete
8f3990e5cd21: Pull complete
Digest: sha256:ab1b60d287e51b2a729557a588de99399150d59a85d1d15ce81caf4136ee7ace
Status: Downloaded newer image for python:3.5-slim
 ---> 9c2c09d68451
Step 2/2 : RUN apt-get update -y   && apt-get install --no-install-recommends -y memcached rabbitmq-server redis-server
 ---> Running in 0421a3beb99d
Get:1 http://security.debian.org/debian-security stretch/updates InRelease [94.3 kB]
Ign:2 http://deb.debian.org/debian stretch InRelease
Get:3 http://deb.debian.org/debian stretch-updates InRelease [90.3 kB]
Get:4 http://deb.debian.org/debian stretch Release [118 kB]
Get:5 http://deb.debian.org/debian stretch Release.gpg [2434 B]
Get:6 http://security.debian.org/debian-security stretch/updates/main amd64 Packages [499 kB]
Get:7 http://deb.debian.org/debian stretch-updates/main amd64 Packages [27.2 kB]
Get:8 http://deb.debian.org/debian stretch/main amd64 Packages [7082 kB]
Fetched 7913 kB in 8s (964 kB/s)
Reading package lists...
Reading package lists...
Building dependency tree...
Reading state information...
The following additional packages will be installed:
  cron erlang-asn1 erlang-base erlang-corba erlang-crypto erlang-diameter
  erlang-edoc erlang-eldap erlang-erl-docgen erlang-eunit erlang-ic
  erlang-inets erlang-mnesia erlang-nox erlang-odbc erlang-os-mon
  erlang-parsetools erlang-percept erlang-public-key erlang-runtime-tools
  erlang-snmp erlang-ssh erlang-ssl erlang-syntax-tools erlang-tools
  erlang-xmerl libevent-2.0-5 libffi6 libjemalloc1 libltdl7 libncurses5
  libodbc1 libperl5.24 libpopt0 libprocps6 libpython-stdlib
  libpython2.7-minimal libpython2.7-stdlib libsasl2-2 libsasl2-modules-db
  libssl1.0.2 logrotate mime-support perl perl-modules-5.24 procps python
  python-minimal python2.7 python2.7-minimal redis-tools
Suggested packages:
  anacron checksecurity erlang erlang-manpages erlang-doc xsltproc fop
  erlang-ic-java libmyodbc odbc-postgresql tdsodbc unixodbc-bin
  libcache-memcached-perl libmemcached libanyevent-perl libyaml-perl
  libterm-readkey-perl perl-doc libterm-readline-gnu-perl
  | libterm-readline-perl-perl make python-doc python-tk python2.7-doc
  binutils binfmt-support ruby-redis
Recommended packages:
  exim4 | postfix | mail-transport-agent libsctp1 libgpm2 libsasl2-modules
  bsd-mailx | mailx bzip2 file xz-utils rename psmisc
The following NEW packages will be installed:
  cron erlang-asn1 erlang-base erlang-corba erlang-crypto erlang-diameter
  erlang-edoc erlang-eldap erlang-erl-docgen erlang-eunit erlang-ic
  erlang-inets erlang-mnesia erlang-nox erlang-odbc erlang-os-mon
  erlang-parsetools erlang-percept erlang-public-key erlang-runtime-tools
  erlang-snmp erlang-ssh erlang-ssl erlang-syntax-tools erlang-tools
  erlang-xmerl libevent-2.0-5 libffi6 libjemalloc1 libltdl7 libncurses5
  libodbc1 libperl5.24 libpopt0 libprocps6 libpython-stdlib
  libpython2.7-minimal libpython2.7-stdlib libsasl2-2 libsasl2-modules-db
  libssl1.0.2 logrotate memcached mime-support perl perl-modules-5.24 procps
  python python-minimal python2.7 python2.7-minimal rabbitmq-server
  redis-server redis-tools
0 upgraded, 54 newly installed, 0 to remove and 1 not upgraded.
Need to get 39.9 MB of archives.
After this operation, 109 MB of additional disk space will be used.
Get:1 http://deb.debian.org/debian stretch/main amd64 cron amd64 3.0pl1-128+deb9u1 [95.4 kB]
Get:2 http://deb.debian.org/debian stretch/main amd64 perl-modules-5.24 all 5.24.1-3+deb9u5 [2722 kB]
Get:3 http://deb.debian.org/debian stretch/main amd64 libperl5.24 amd64 5.24.1-3+deb9u5 [3501 kB]
Get:4 http://deb.debian.org/debian stretch/main amd64 perl amd64 5.24.1-3+deb9u5 [219 kB]
Get:5 http://deb.debian.org/debian stretch/main amd64 libpython2.7-minimal amd64 2.7.13-2+deb9u3 [389 kB]
Get:6 http://deb.debian.org/debian stretch/main amd64 python2.7-minimal amd64 2.7.13-2+deb9u3 [1382 kB]
Get:7 http://deb.debian.org/debian stretch/main amd64 python-minimal amd64 2.7.13-2 [40.5 kB]
Get:8 http://deb.debian.org/debian stretch/main amd64 mime-support all 3.60 [36.7 kB]
Get:9 http://deb.debian.org/debian stretch/main amd64 libffi6 amd64 3.2.1-6 [20.4 kB]
Get:10 http://deb.debian.org/debian stretch/main amd64 libpython2.7-stdlib amd64 2.7.13-2+deb9u3 [1897 kB]
Get:11 http://deb.debian.org/debian stretch/main amd64 python2.7 amd64 2.7.13-2+deb9u3 [285 kB]
Get:12 http://deb.debian.org/debian stretch/main amd64 libpython-stdlib amd64 2.7.13-2 [20.0 kB]
Get:13 http://deb.debian.org/debian stretch/main amd64 python amd64 2.7.13-2 [154 kB]
Get:14 http://deb.debian.org/debian stretch/main amd64 libpopt0 amd64 1.16-10+b2 [49.4 kB]
Get:15 http://deb.debian.org/debian stretch/main amd64 libprocps6 amd64 2:3.3.12-3+deb9u1 [58.5 kB]
Get:16 http://deb.debian.org/debian stretch/main amd64 libssl1.0.2 amd64 1.0.2r-1~deb9u1 [1302 kB]
Get:17 http://deb.debian.org/debian stretch/main amd64 logrotate amd64 3.11.0-0.1 [58.7 kB]
Get:18 http://deb.debian.org/debian stretch/main amd64 libncurses5 amd64 6.0+20161126-1+deb9u2 [93.4 kB]
Get:19 http://deb.debian.org/debian stretch/main amd64 procps amd64 2:3.3.12-3+deb9u1 [250 kB]
Get:20 http://deb.debian.org/debian stretch/main amd64 libevent-2.0-5 amd64 2.0.21-stable-3 [152 kB]
Get:21 http://deb.debian.org/debian stretch/main amd64 libsasl2-modules-db amd64 2.1.27~101-g0780600+dfsg-3 [68.2 kB]
Get:22 http://deb.debian.org/debian stretch/main amd64 libsasl2-2 amd64 2.1.27~101-g0780600+dfsg-3 [105 kB]
Get:23 http://deb.debian.org/debian stretch/main amd64 erlang-base amd64 1:19.2.1+dfsg-2+deb9u2 [7173 kB]
Get:24 http://deb.debian.org/debian stretch/main amd64 erlang-asn1 amd64 1:19.2.1+dfsg-2+deb9u2 [740 kB]
Get:25 http://deb.debian.org/debian stretch/main amd64 erlang-mnesia amd64 1:19.2.1+dfsg-2+deb9u2 [748 kB]
Get:26 http://deb.debian.org/debian stretch/main amd64 erlang-runtime-tools amd64 1:19.2.1+dfsg-2+deb9u2 [208 kB]
Get:27 http://deb.debian.org/debian stretch/main amd64 erlang-crypto amd64 1:19.2.1+dfsg-2+deb9u2 [125 kB]
Get:28 http://deb.debian.org/debian stretch/main amd64 erlang-public-key amd64 1:19.2.1+dfsg-2+deb9u2 [559 kB]
Get:29 http://deb.debian.org/debian stretch/main amd64 erlang-ssl amd64 1:19.2.1+dfsg-2+deb9u2 [752 kB]
Get:30 http://deb.debian.org/debian stretch/main amd64 erlang-inets amd64 1:19.2.1+dfsg-2+deb9u2 [743 kB]
Get:31 http://deb.debian.org/debian stretch/main amd64 erlang-corba amd64 1:19.2.1+dfsg-2+deb9u2 [2260 kB]
Get:32 http://deb.debian.org/debian stretch/main amd64 erlang-syntax-tools amd64 1:19.2.1+dfsg-2+deb9u2 [375 kB]
Get:33 http://deb.debian.org/debian stretch/main amd64 erlang-diameter amd64 1:19.2.1+dfsg-2+deb9u2 [679 kB]
Get:34 http://deb.debian.org/debian stretch/main amd64 erlang-xmerl amd64 1:19.2.1+dfsg-2+deb9u2 [986 kB]
Get:35 http://deb.debian.org/debian stretch/main amd64 erlang-edoc amd64 1:19.2.1+dfsg-2+deb9u2 [326 kB]
Get:36 http://deb.debian.org/debian stretch/main amd64 erlang-eldap amd64 1:19.2.1+dfsg-2+deb9u2 [131 kB]
Get:37 http://deb.debian.org/debian stretch/main amd64 erlang-erl-docgen amd64 1:19.2.1+dfsg-2+deb9u2 [167 kB]
Get:38 http://deb.debian.org/debian stretch/main amd64 erlang-eunit amd64 1:19.2.1+dfsg-2+deb9u2 [165 kB]
Get:39 http://deb.debian.org/debian stretch/main amd64 erlang-ic amd64 1:19.2.1+dfsg-2+deb9u2 [847 kB]
Get:40 http://deb.debian.org/debian stretch/main amd64 libltdl7 amd64 2.4.6-2 [389 kB]
Get:41 http://deb.debian.org/debian stretch/main amd64 libodbc1 amd64 2.3.4-1 [214 kB]
Get:42 http://deb.debian.org/debian stretch/main amd64 erlang-odbc amd64 1:19.2.1+dfsg-2+deb9u2 [77.9 kB]
Get:43 http://deb.debian.org/debian stretch/main amd64 erlang-snmp amd64 1:19.2.1+dfsg-2+deb9u2 [1555 kB]
Get:44 http://deb.debian.org/debian stretch/main amd64 erlang-os-mon amd64 1:19.2.1+dfsg-2+deb9u2 [120 kB]
Get:45 http://deb.debian.org/debian stretch/main amd64 erlang-parsetools amd64 1:19.2.1+dfsg-2+deb9u2 [184 kB]
Get:46 http://deb.debian.org/debian stretch/main amd64 erlang-percept amd64 1:19.2.1+dfsg-2+deb9u2 [164 kB]
Get:47 http://deb.debian.org/debian stretch/main amd64 erlang-ssh amd64 1:19.2.1+dfsg-2+deb9u2 [478 kB]
Get:48 http://deb.debian.org/debian stretch/main amd64 erlang-tools amd64 1:19.2.1+dfsg-2+deb9u2 [529 kB]
Get:49 http://deb.debian.org/debian stretch/main amd64 erlang-nox all 1:19.2.1+dfsg-2+deb9u2 [35.6 kB]
Get:50 http://deb.debian.org/debian stretch/main amd64 memcached amd64 1.4.33-1+deb9u1 [115 kB]
Get:51 http://deb.debian.org/debian stretch/main amd64 libjemalloc1 amd64 3.6.0-9.1 [89.8 kB]
Get:52 http://deb.debian.org/debian stretch/main amd64 redis-tools amd64 3:3.2.6-3+deb9u2 [463 kB]
Get:53 http://deb.debian.org/debian stretch/main amd64 redis-server amd64 3:3.2.6-3+deb9u2 [413 kB]
Get:54 http://deb.debian.org/debian stretch/main amd64 rabbitmq-server all 3.6.6-1 [5234 kB]
debconf: delaying package configuration, since apt-utils is not installed
Fetched 39.9 MB in 2s (16.6 MB/s)
Selecting previously unselected package cron.
(Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 6704 files and directories currently installed.)
Preparing to unpack .../00-cron_3.0pl1-128+deb9u1_amd64.deb ...
Unpacking cron (3.0pl1-128+deb9u1) ...
Selecting previously unselected package perl-modules-5.24.
Preparing to unpack .../01-perl-modules-5.24_5.24.1-3+deb9u5_all.deb ...
Unpacking perl-modules-5.24 (5.24.1-3+deb9u5) ...
Selecting previously unselected package libperl5.24:amd64.
Preparing to unpack .../02-libperl5.24_5.24.1-3+deb9u5_amd64.deb ...
Unpacking libperl5.24:amd64 (5.24.1-3+deb9u5) ...
Selecting previously unselected package perl.
Preparing to unpack .../03-perl_5.24.1-3+deb9u5_amd64.deb ...
Unpacking perl (5.24.1-3+deb9u5) ...
Selecting previously unselected package libpython2.7-minimal:amd64.
Preparing to unpack .../04-libpython2.7-minimal_2.7.13-2+deb9u3_amd64.deb ...
Unpacking libpython2.7-minimal:amd64 (2.7.13-2+deb9u3) ...
Selecting previously unselected package python2.7-minimal.
Preparing to unpack .../05-python2.7-minimal_2.7.13-2+deb9u3_amd64.deb ...
Unpacking python2.7-minimal (2.7.13-2+deb9u3) ...
Selecting previously unselected package python-minimal.
Preparing to unpack .../06-python-minimal_2.7.13-2_amd64.deb ...
Unpacking python-minimal (2.7.13-2) ...
Selecting previously unselected package mime-support.
Preparing to unpack .../07-mime-support_3.60_all.deb ...
Unpacking mime-support (3.60) ...
Selecting previously unselected package libffi6:amd64.
Preparing to unpack .../08-libffi6_3.2.1-6_amd64.deb ...
Unpacking libffi6:amd64 (3.2.1-6) ...
Selecting previously unselected package libpython2.7-stdlib:amd64.
Preparing to unpack .../09-libpython2.7-stdlib_2.7.13-2+deb9u3_amd64.deb ...
Unpacking libpython2.7-stdlib:amd64 (2.7.13-2+deb9u3) ...
Selecting previously unselected package python2.7.
Preparing to unpack .../10-python2.7_2.7.13-2+deb9u3_amd64.deb ...
Unpacking python2.7 (2.7.13-2+deb9u3) ...
Selecting previously unselected package libpython-stdlib:amd64.
Preparing to unpack .../11-libpython-stdlib_2.7.13-2_amd64.deb ...
Unpacking libpython-stdlib:amd64 (2.7.13-2) ...
Setting up libpython2.7-minimal:amd64 (2.7.13-2+deb9u3) ...
Setting up python2.7-minimal (2.7.13-2+deb9u3) ...
Linking and byte-compiling packages for runtime python2.7...
Setting up python-minimal (2.7.13-2) ...
Selecting previously unselected package python.
(Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 9336 files and directories currently installed.)
Preparing to unpack .../00-python_2.7.13-2_amd64.deb ...
Unpacking python (2.7.13-2) ...
Selecting previously unselected package libpopt0:amd64.
Preparing to unpack .../01-libpopt0_1.16-10+b2_amd64.deb ...
Unpacking libpopt0:amd64 (1.16-10+b2) ...
Selecting previously unselected package libprocps6:amd64.
Preparing to unpack .../02-libprocps6_2%3a3.3.12-3+deb9u1_amd64.deb ...
Unpacking libprocps6:amd64 (2:3.3.12-3+deb9u1) ...
Selecting previously unselected package libssl1.0.2:amd64.
Preparing to unpack .../03-libssl1.0.2_1.0.2r-1~deb9u1_amd64.deb ...
Unpacking libssl1.0.2:amd64 (1.0.2r-1~deb9u1) ...
Selecting previously unselected package logrotate.
Preparing to unpack .../04-logrotate_3.11.0-0.1_amd64.deb ...
Unpacking logrotate (3.11.0-0.1) ...
Selecting previously unselected package libncurses5:amd64.
Preparing to unpack .../05-libncurses5_6.0+20161126-1+deb9u2_amd64.deb ...
Unpacking libncurses5:amd64 (6.0+20161126-1+deb9u2) ...
Selecting previously unselected package procps.
Preparing to unpack .../06-procps_2%3a3.3.12-3+deb9u1_amd64.deb ...
Unpacking procps (2:3.3.12-3+deb9u1) ...
Selecting previously unselected package libevent-2.0-5:amd64.
Preparing to unpack .../07-libevent-2.0-5_2.0.21-stable-3_amd64.deb ...
Unpacking libevent-2.0-5:amd64 (2.0.21-stable-3) ...
Selecting previously unselected package libsasl2-modules-db:amd64.
Preparing to unpack .../08-libsasl2-modules-db_2.1.27~101-g0780600+dfsg-3_amd64.deb ...
Unpacking libsasl2-modules-db:amd64 (2.1.27~101-g0780600+dfsg-3) ...
Selecting previously unselected package libsasl2-2:amd64.
Preparing to unpack .../09-libsasl2-2_2.1.27~101-g0780600+dfsg-3_amd64.deb ...
Unpacking libsasl2-2:amd64 (2.1.27~101-g0780600+dfsg-3) ...
Selecting previously unselected package erlang-base.
Preparing to unpack .../10-erlang-base_1%3a19.2.1+dfsg-2+deb9u2_amd64.deb ...
Unpacking erlang-base (1:19.2.1+dfsg-2+deb9u2) ...
Selecting previously unselected package erlang-asn1.
Preparing to unpack .../11-erlang-asn1_1%3a19.2.1+dfsg-2+deb9u2_amd64.deb ...
Unpacking erlang-asn1 (1:19.2.1+dfsg-2+deb9u2) ...
Selecting previously unselected package erlang-mnesia.
Preparing to unpack .../12-erlang-mnesia_1%3a19.2.1+dfsg-2+deb9u2_amd64.deb ...
Unpacking erlang-mnesia (1:19.2.1+dfsg-2+deb9u2) ...
Selecting previously unselected package erlang-runtime-tools.
Preparing to unpack .../13-erlang-runtime-tools_1%3a19.2.1+dfsg-2+deb9u2_amd64.deb ...
Unpacking erlang-runtime-tools (1:19.2.1+dfsg-2+deb9u2) ...
Selecting previously unselected package erlang-crypto.
Preparing to unpack .../14-erlang-crypto_1%3a19.2.1+dfsg-2+deb9u2_amd64.deb ...
Unpacking erlang-crypto (1:19.2.1+dfsg-2+deb9u2) ...
Selecting previously unselected package erlang-public-key.
Preparing to unpack .../15-erlang-public-key_1%3a19.2.1+dfsg-2+deb9u2_amd64.deb ...
Unpacking erlang-public-key (1:19.2.1+dfsg-2+deb9u2) ...
Selecting previously unselected package erlang-ssl.
Preparing to unpack .../16-erlang-ssl_1%3a19.2.1+dfsg-2+deb9u2_amd64.deb ...
Unpacking erlang-ssl (1:19.2.1+dfsg-2+deb9u2) ...
Selecting previously unselected package erlang-inets.
Preparing to unpack .../17-erlang-inets_1%3a19.2.1+dfsg-2+deb9u2_amd64.deb ...
Unpacking erlang-inets (1:19.2.1+dfsg-2+deb9u2) ...
Selecting previously unselected package erlang-corba.
Preparing to unpack .../18-erlang-corba_1%3a19.2.1+dfsg-2+deb9u2_amd64.deb ...
Unpacking erlang-corba (1:19.2.1+dfsg-2+deb9u2) ...
Selecting previously unselected package erlang-syntax-tools.
Preparing to unpack .../19-erlang-syntax-tools_1%3a19.2.1+dfsg-2+deb9u2_amd64.deb ...
Unpacking erlang-syntax-tools (1:19.2.1+dfsg-2+deb9u2) ...
Selecting previously unselected package erlang-diameter.
Preparing to unpack .../20-erlang-diameter_1%3a19.2.1+dfsg-2+deb9u2_amd64.deb ...
Unpacking erlang-diameter (1:19.2.1+dfsg-2+deb9u2) ...
Selecting previously unselected package erlang-xmerl.
Preparing to unpack .../21-erlang-xmerl_1%3a19.2.1+dfsg-2+deb9u2_amd64.deb ...
Unpacking erlang-xmerl (1:19.2.1+dfsg-2+deb9u2) ...
Selecting previously unselected package erlang-edoc.
Preparing to unpack .../22-erlang-edoc_1%3a19.2.1+dfsg-2+deb9u2_amd64.deb ...
Unpacking erlang-edoc (1:19.2.1+dfsg-2+deb9u2) ...
Selecting previously unselected package erlang-eldap.
Preparing to unpack .../23-erlang-eldap_1%3a19.2.1+dfsg-2+deb9u2_amd64.deb ...
Unpacking erlang-eldap (1:19.2.1+dfsg-2+deb9u2) ...
Selecting previously unselected package erlang-erl-docgen.
Preparing to unpack .../24-erlang-erl-docgen_1%3a19.2.1+dfsg-2+deb9u2_amd64.deb ...
Unpacking erlang-erl-docgen (1:19.2.1+dfsg-2+deb9u2) ...
Selecting previously unselected package erlang-eunit.
Preparing to unpack .../25-erlang-eunit_1%3a19.2.1+dfsg-2+deb9u2_amd64.deb ...
Unpacking erlang-eunit (1:19.2.1+dfsg-2+deb9u2) ...
Selecting previously unselected package erlang-ic.
Preparing to unpack .../26-erlang-ic_1%3a19.2.1+dfsg-2+deb9u2_amd64.deb ...
Unpacking erlang-ic (1:19.2.1+dfsg-2+deb9u2) ...
Selecting previously unselected package libltdl7:amd64.
Preparing to unpack .../27-libltdl7_2.4.6-2_amd64.deb ...
Unpacking libltdl7:amd64 (2.4.6-2) ...
Selecting previously unselected package libodbc1:amd64.
Preparing to unpack .../28-libodbc1_2.3.4-1_amd64.deb ...
Unpacking libodbc1:amd64 (2.3.4-1) ...
Selecting previously unselected package erlang-odbc.
Preparing to unpack .../29-erlang-odbc_1%3a19.2.1+dfsg-2+deb9u2_amd64.deb ...
Unpacking erlang-odbc (1:19.2.1+dfsg-2+deb9u2) ...
Selecting previously unselected package erlang-snmp.
Preparing to unpack .../30-erlang-snmp_1%3a19.2.1+dfsg-2+deb9u2_amd64.deb ...
Unpacking erlang-snmp (1:19.2.1+dfsg-2+deb9u2) ...
Selecting previously unselected package erlang-os-mon.
Preparing to unpack .../31-erlang-os-mon_1%3a19.2.1+dfsg-2+deb9u2_amd64.deb ...
Unpacking erlang-os-mon (1:19.2.1+dfsg-2+deb9u2) ...
Selecting previously unselected package erlang-parsetools.
Preparing to unpack .../32-erlang-parsetools_1%3a19.2.1+dfsg-2+deb9u2_amd64.deb ...
Unpacking erlang-parsetools (1:19.2.1+dfsg-2+deb9u2) ...
Selecting previously unselected package erlang-percept.
Preparing to unpack .../33-erlang-percept_1%3a19.2.1+dfsg-2+deb9u2_amd64.deb ...
Unpacking erlang-percept (1:19.2.1+dfsg-2+deb9u2) ...
Selecting previously unselected package erlang-ssh.
Preparing to unpack .../34-erlang-ssh_1%3a19.2.1+dfsg-2+deb9u2_amd64.deb ...
Unpacking erlang-ssh (1:19.2.1+dfsg-2+deb9u2) ...
Selecting previously unselected package erlang-tools.
Preparing to unpack .../35-erlang-tools_1%3a19.2.1+dfsg-2+deb9u2_amd64.deb ...
Unpacking erlang-tools (1:19.2.1+dfsg-2+deb9u2) ...
Selecting previously unselected package erlang-nox.
Preparing to unpack .../36-erlang-nox_1%3a19.2.1+dfsg-2+deb9u2_all.deb ...
Unpacking erlang-nox (1:19.2.1+dfsg-2+deb9u2) ...
Selecting previously unselected package memcached.
Preparing to unpack .../37-memcached_1.4.33-1+deb9u1_amd64.deb ...
Unpacking memcached (1.4.33-1+deb9u1) ...
Selecting previously unselected package libjemalloc1.
Preparing to unpack .../38-libjemalloc1_3.6.0-9.1_amd64.deb ...
Unpacking libjemalloc1 (3.6.0-9.1) ...
Selecting previously unselected package redis-tools.
Preparing to unpack .../39-redis-tools_3%3a3.2.6-3+deb9u2_amd64.deb ...
Unpacking redis-tools (3:3.2.6-3+deb9u2) ...
Selecting previously unselected package redis-server.
Preparing to unpack .../40-redis-server_3%3a3.2.6-3+deb9u2_amd64.deb ...
Unpacking redis-server (3:3.2.6-3+deb9u2) ...
Selecting previously unselected package rabbitmq-server.
Preparing to unpack .../41-rabbitmq-server_3.6.6-1_all.deb ...
Unpacking rabbitmq-server (3.6.6-1) ...
Setting up libncurses5:amd64 (6.0+20161126-1+deb9u2) ...
Setting up perl-modules-5.24 (5.24.1-3+deb9u5) ...
Setting up libperl5.24:amd64 (5.24.1-3+deb9u5) ...
Setting up libpopt0:amd64 (1.16-10+b2) ...
Setting up mime-support (3.60) ...
Setting up libjemalloc1 (3.6.0-9.1) ...
Setting up libsasl2-modules-db:amd64 (2.1.27~101-g0780600+dfsg-3) ...
Setting up libsasl2-2:amd64 (2.1.27~101-g0780600+dfsg-3) ...
Setting up libprocps6:amd64 (2:3.3.12-3+deb9u1) ...
Setting up procps (2:3.3.12-3+deb9u1) ...
update-alternatives: using /usr/bin/w.procps to provide /usr/bin/w (w) in auto mode
update-alternatives: warning: skip creation of /usr/share/man/man1/w.1.gz because associated file /usr/share/man/man1/w.procps.1.gz (of link group w) doesn't exist
Setting up perl (5.24.1-3+deb9u5) ...
update-alternatives: using /usr/bin/prename to provide /usr/bin/rename (rename) in auto mode
update-alternatives: warning: skip creation of /usr/share/man/man1/rename.1.gz because associated file /usr/share/man/man1/prename.1.gz (of link group rename) doesn't exist
Setting up libssl1.0.2:amd64 (1.0.2r-1~deb9u1) ...
debconf: unable to initialize frontend: Dialog
debconf: (TERM is not set, so the dialog frontend is not usable.)
debconf: falling back to frontend: Readline
Processing triggers for libc-bin (2.24-11+deb9u4) ...
Setting up libltdl7:amd64 (2.4.6-2) ...
Setting up libffi6:amd64 (3.2.1-6) ...
Setting up libevent-2.0-5:amd64 (2.0.21-stable-3) ...
Setting up cron (3.0pl1-128+deb9u1) ...
Adding group `crontab' (GID 101) ...
Done.
update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
invoke-rc.d: could not determine current runlevel
invoke-rc.d: policy-rc.d denied execution of start.
Setting up logrotate (3.11.0-0.1) ...
Setting up libpython2.7-stdlib:amd64 (2.7.13-2+deb9u3) ...
Setting up redis-tools (3:3.2.6-3+deb9u2) ...
Setting up libodbc1:amd64 (2.3.4-1) ...
Setting up erlang-base (1:19.2.1+dfsg-2+deb9u2) ...
Searching for services which depend on erlang and should be started...none found.
Setting up erlang-ic (1:19.2.1+dfsg-2+deb9u2) ...
Setting up memcached (1.4.33-1+deb9u1) ...
invoke-rc.d: could not determine current runlevel
invoke-rc.d: policy-rc.d denied execution of start.
Setting up python2.7 (2.7.13-2+deb9u3) ...
Setting up erlang-xmerl (1:19.2.1+dfsg-2+deb9u2) ...
Setting up erlang-crypto (1:19.2.1+dfsg-2+deb9u2) ...
Setting up erlang-asn1 (1:19.2.1+dfsg-2+deb9u2) ...
Setting up libpython-stdlib:amd64 (2.7.13-2) ...
Setting up erlang-mnesia (1:19.2.1+dfsg-2+deb9u2) ...
Setting up erlang-eunit (1:19.2.1+dfsg-2+deb9u2) ...
Setting up erlang-runtime-tools (1:19.2.1+dfsg-2+deb9u2) ...
Setting up erlang-syntax-tools (1:19.2.1+dfsg-2+deb9u2) ...
Setting up erlang-odbc (1:19.2.1+dfsg-2+deb9u2) ...
Setting up redis-server (3:3.2.6-3+deb9u2) ...
invoke-rc.d: could not determine current runlevel
invoke-rc.d: policy-rc.d denied execution of start.
Setting up python (2.7.13-2) ...
Setting up erlang-parsetools (1:19.2.1+dfsg-2+deb9u2) ...
Setting up erlang-public-key (1:19.2.1+dfsg-2+deb9u2) ...
Setting up erlang-snmp (1:19.2.1+dfsg-2+deb9u2) ...
Setting up erlang-ssl (1:19.2.1+dfsg-2+deb9u2) ...
Setting up erlang-inets (1:19.2.1+dfsg-2+deb9u2) ...
Setting up erlang-tools (1:19.2.1+dfsg-2+deb9u2) ...
Setting up erlang-percept (1:19.2.1+dfsg-2+deb9u2) ...
Setting up erlang-diameter (1:19.2.1+dfsg-2+deb9u2) ...
Setting up erlang-ssh (1:19.2.1+dfsg-2+deb9u2) ...
Setting up erlang-os-mon (1:19.2.1+dfsg-2+deb9u2) ...
Setting up erlang-eldap (1:19.2.1+dfsg-2+deb9u2) ...
Setting up erlang-edoc (1:19.2.1+dfsg-2+deb9u2) ...
Setting up erlang-corba (1:19.2.1+dfsg-2+deb9u2) ...
Setting up erlang-erl-docgen (1:19.2.1+dfsg-2+deb9u2) ...
Setting up erlang-nox (1:19.2.1+dfsg-2+deb9u2) ...
Setting up rabbitmq-server (3.6.6-1) ...
Adding group `rabbitmq' (GID 105) ...
Done.
Adding system user `rabbitmq' (UID 104) ...
Adding new user `rabbitmq' (UID 104) with group `rabbitmq' ...
Not creating home directory `/var/lib/rabbitmq'.
invoke-rc.d: could not determine current runlevel
invoke-rc.d: policy-rc.d denied execution of start.
Processing triggers for libc-bin (2.24-11+deb9u4) ...
 ---> 5164744ec7b4
Successfully built 5164744ec7b4
Successfully tagged gcr.io/gct-12-ba4zwhw9r2zhduezw8mftgj/e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855/54611d6d4bfd75917b11fde8af74a6edfa3ac803ff32dc8d0e8d46f4e5c2ab70:e3b0c44298fc1c149afbf4c8996fb92427ae41e4649b934ca495991b7852b855
Already have image (with digest): gcr.io/github-actions-images/action-runner:latest
Starting RabbitMQ Messaging Server: rabbitmq-serverStarting redis-server: Starting memcached: memcached.
redis-server.
Collecting tox
  Using cached https://files.pythonhosted.org/packages/3f/21/66868fc9074e366d0dc6952c53c918230e772fd662e69b331bac7a67fcbe/tox-3.13.2-py2.py3-none-any.whl
Collecting packaging>=14 (from tox)
  Using cached https://files.pythonhosted.org/packages/91/32/58bc30e646e55eab8b21abf89e353f59c0cc02c417e42929f4a9546e1b1d/packaging-19.0-py2.py3-none-any.whl
Collecting pluggy<1,>=0.12.0 (from tox)
  Using cached https://files.pythonhosted.org/packages/06/ee/de89e0582276e3551df3110088bf20844de2b0e7df2748406876cc78e021/pluggy-0.12.0-py2.py3-none-any.whl
Collecting importlib-metadata<1,>=0.12 (from tox)
  Using cached https://files.pythonhosted.org/packages/bd/23/dce4879ec58acf3959580bfe769926ed8198727250c5e395e6785c764a02/importlib_metadata-0.18-py2.py3-none-any.whl
Collecting toml>=0.9.4 (from tox)
  Using cached https://files.pythonhosted.org/packages/a2/12/ced7105d2de62fa7c8fb5fce92cc4ce66b57c95fb875e9318dba7f8c5db0/toml-0.10.0-py2.py3-none-any.whl
Collecting py<2,>=1.4.17 (from tox)
  Using cached https://files.pythonhosted.org/packages/76/bc/394ad449851729244a97857ee14d7cba61ddb268dce3db538ba2f2ba1f0f/py-1.8.0-py2.py3-none-any.whl
Collecting virtualenv>=14.0.0 (from tox)
  Using cached https://files.pythonhosted.org/packages/c4/9a/a3f62ac5122a65dec34ad4b5ed8d802633dae4bc06a0fc62e55fe3e96fe1/virtualenv-16.6.1-py2.py3-none-any.whl
Collecting six<2,>=1.0.0 (from tox)
  Using cached https://files.pythonhosted.org/packages/73/fb/00a976f728d0d1fecfe898238ce23f502a721c0ac0ecfedb80e0d88c64e9/six-1.12.0-py2.py3-none-any.whl
Collecting filelock<4,>=3.0.0 (from tox)
  Using cached https://files.pythonhosted.org/packages/93/83/71a2ee6158bb9f39a90c0dea1637f81d5eef866e188e1971a1b1ab01a35a/filelock-3.0.12-py3-none-any.whl
Collecting pyparsing>=2.0.2 (from packaging>=14->tox)
  Using cached https://files.pythonhosted.org/packages/dd/d9/3ec19e966301a6e25769976999bd7bbe552016f0d32b577dc9d63d2e0c49/pyparsing-2.4.0-py2.py3-none-any.whl
Collecting zipp>=0.5 (from importlib-metadata<1,>=0.12->tox)
  Using cached https://files.pythonhosted.org/packages/a0/0f/9bf71d438d2e9d5fd0e4569ea4d1a2b6f5a524c234c6d221b494298bb4d1/zipp-0.5.1-py2.py3-none-any.whl
Installing collected packages: six, pyparsing, packaging, zipp, importlib-metadata, pluggy, toml, py, virtualenv, filelock, tox
Successfully installed filelock-3.0.12 importlib-metadata-0.18 packaging-19.0 pluggy-0.12.0 py-1.8.0 pyparsing-2.4.0 six-1.12.0 toml-0.10.0 tox-3.13.2 virtualenv-16.6.1 zipp-0.5.1
.
/tmp/testpy35 /github/workspace
GLOB sdist-make: /tmp/testpy35/setup.py
py35 create: /tmp/testpy35/.tox/py35
py35 installdeps: flake8, flake8-bugbear, flake8-quotes
py35 inst: /tmp/testpy35/.tox/.tmp/package/1/dramatiq-1.6.0.zip
py35 installed: alabaster==0.7.12,argh==0.26.2,atomicwrites==1.3.0,attrs==19.1.0,Babel==2.7.0,bleach==3.1.0,bumpversion==0.5.3,certifi==2019.6.16,chardet==3.0.4,coverage==4.5.3,docutils==0.14,dramatiq==1.6.0,entrypoints==0.3,filelock==3.0.12,flake8==3.7.7,flake8-bugbear==19.3.0,flake8-quotes==2.0.1,gevent==1.4.0,greenlet==0.4.15,hiredis==1.0.0,idna==2.8,imagesize==1.1.0,importlib-metadata==0.18,isort==4.3.21,Jinja2==2.10.1,MarkupSafe==1.1.1,mccabe==0.6.1,more-itertools==7.1.0,packaging==19.0,pathlib2==2.3.4,pathtools==0.1.2,pika==1.0.1,pkginfo==1.5.0.1,pluggy==0.12.0,pockets==0.7.2,prometheus-client==0.2.0,py==1.8.0,py-cpuinfo==5.0.0,pycodestyle==2.5.0,pyflakes==2.1.1,pygal==2.4.0,pygaljs==1.0.1,Pygments==2.4.2,pylibmc==1.6.0,pyparsing==2.4.0,pytest==3.10.1,pytest-benchmark==3.2.2,pytest-cov==2.7.1,pytz==2019.1,PyYAML==5.1.1,readme-renderer==24.0,redis==3.2.1,requests==2.22.0,requests-toolbelt==0.9.1,six==1.12.0,snowballstemmer==1.9.0,Sphinx==1.7.9,sphinxcontrib-napoleon==0.7,sphinxcontrib-websupport==1.1.2,toml==0.10.0,tox==3.13.2,tqdm==4.32.2,twine==1.13.0,urllib3==1.25.3,virtualenv==16.6.1,watchdog==0.8.3,watchdog-gevent==0.1.0,webencodings==0.5.1,zipp==0.5.1
py35 run-test-pre: PYTHONHASHSEED='1312394864'
py35 run-test: commands[0] | py.test --benchmark-skip
============================= test session starts ==============================
platform linux -- Python 3.5.7, pytest-3.10.1, py-1.8.0, pluggy-0.12.0
benchmark: 3.2.2 (defaults: timer=time.perf_counter disable_gc=False min_rounds=5 min_time=0.000005 max_time=1.0 calibration_precision=10 warmup=False warmup_iterations=100000)
rootdir: /tmp/testpy35, inifile: setup.cfg
plugins: benchmark-3.2.2, cov-2.7.1
collected 203 items

tests/test_actors.py .............................                       [ 14%]
tests/test_barrier.py ...s..s..                                          [ 18%]
tests/test_broker.py ......                                              [ 21%]
tests/test_bucket_rate_limiter.py ...                                    [ 23%]
tests/test_callbacks.py ...                                              [ 24%]
tests/test_cli.py ...                                                    [ 26%]
tests/test_common.py .........                                           [ 30%]
tests/test_composition.py ..............................                 [ 45%]
tests/test_concurrent_rate_limiter.py .........                          [ 49%]
tests/test_encoders.py ..                                                [ 50%]
tests/test_generic_actors.py .....                                       [ 53%]
tests/test_pidfile.py ...                                                [ 54%]
tests/test_rabbitmq.py .......................                           [ 66%]
tests/test_redis.py .................                                    [ 74%]
tests/test_results.py ................                                   [ 82%]
tests/test_stub_broker.py ......                                         [ 85%]
tests/test_watch.py ..                                                   [ 86%]
tests/test_window_rate_limiter.py 
Action `Test 3.5' cancelled because action `Test 3.7' failed
You can’t perform that action at this time.