Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Remove "typing-inspect<0.4" dependency #35

Closed
akhait opened this issue Nov 18, 2019 · 1 comment
Closed

Remove "typing-inspect<0.4" dependency #35

akhait opened this issue Nov 18, 2019 · 1 comment

Comments

@akhait
Copy link

@akhait akhait commented Nov 18, 2019

Hi,

I was wondering, is it really necessary to have typing-inspect version older that 0.4 installed to use Molten? After I removed this requirement from setup.py, I was still able to run at least few example scripts from this repo with typing-inspect-0.5 installed. Is there any reason why someone should use older typing-inspect version?

Thanks in advance.

@androiddrew
Copy link

@androiddrew androiddrew commented Nov 22, 2019

@akhait Looks like Molten's last change to setup.py was back in Feb and the typing-inspect=0.5 release was in earlier October. This just means that dependencies are getting a little stale on the this project. Maybe you can submit a PR and let the Travis CI prove out at that typing-inspect=0.5 doesn't have any breaking changes.

@Bogdanp Bogdanp closed this as completed in 805a767 Feb 6, 2020
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Development

No branches or pull requests

2 participants