Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Toggle mode is not working correctly #3024

Open
iruldi opened this issue May 23, 2019 · 8 comments

Comments

Projects
None yet
5 participants
@iruldi
Copy link

commented May 23, 2019

Issuehunt badges

Current behavior

The toggle mode is not working correctly or something as changed and I can tell what.
Before you just had to click on the text to toggle to the edit mode but now when I'm clicking several times it's not working and then after lots of clicks works.

Expected behavior

When clicking into the text toggle to edit mode directly.

Steps to reproduce

  1. Have a md text
  2. Click on it to be in edit mode

Environment

  • Version : OSX
  • OS Version and name : Mojave v10.14.3
IssueHunt Summary

Sponsors (Total: $30.00)

Become a sponsor now!

Or submit a pull request to get the deposits!

Tips

@ZeroX-DG

This comment has been minimized.

Copy link
Member

commented May 23, 2019

The bug is you can only toggle edit mode when you click at the small space between the text and the left edge of the frame. Thank you for reporting.

@Atomy9

This comment has been minimized.

Copy link

commented May 23, 2019

For those who need a quick workaround, go into Preferences > Interface > Switch to preview > When editor blurred, edit on double click.

@IssueHuntBot

This comment has been minimized.

Copy link

commented May 23, 2019

@BoostIO has funded $30.00 to this issue.


@MiloTodt

This comment has been minimized.

Copy link
Contributor

commented May 23, 2019

This was changed in a PR I submitted here: #2952

I think this new behavior should be the expected behavior. If you're clicking/selecting text I'd imagine you'd expect to be able to copy/paste it as opposed to have the preview pane slam closed.

Right now clicking on anything that isn't the <body> of the page allows you to interact with it normally and as expected. This is important for things like links, videos, buttons etc.

I do not think this should be considered a bug as this behavior fixes a large number of usecases with the only adjustment needed on the user side is clicking on the side of the preview instead of the middle.

Clicking in between elements still works fine to close the pane as demonstrated in the PR.

Right now, when you click on text... you will have clicked on text and Boostnote will behave in the same way every other program does when doing so.

@ZeroX-DG

This comment has been minimized.

Copy link
Member

commented May 27, 2019

@MiloTodt You're right, I think I'll mark this as improvement request because it confusing the user.

@MiloTodt

This comment has been minimized.

Copy link
Contributor

commented May 27, 2019

What would an appropriate improvement be here? My view is that the behavior currently present is the correct one as it follows most expected program behavior for the action.

@ZeroX-DG

This comment has been minimized.

Copy link
Member

commented May 28, 2019

Maybe when you holding down ctrl key you can get the old behavior because many users are used to the old behavior I guess?

@iruldi

This comment has been minimized.

Copy link
Author

commented May 29, 2019

Ok I understand.
I think the best behaviour right now is that edit on double click should be the default mode.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.