New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

gates not recognizing gaseous fluid levels #4133

Closed
jburkej1 opened this Issue Apr 20, 2018 · 4 comments

Comments

Projects
None yet
2 participants
@jburkej1

jburkej1 commented Apr 20, 2018

I am trying to use gates to turn on a wire when the gaseous fuel in a tank reaches 25%. Regardless of the trigger I use the gate powers the wire unless the tank is full. My guess is I am not using the gate correctly or not using the right trigger. If this is a known issue I apologize for re-posting it. BC .15 had the same behavior.

MC 1.12.2, forge 14.23.1.2599, BC 7.99.16
BuildCraft version: 7.99.16
Forge version: 14.23.1.2599
Link to crash report or log:
Singleplayer or multiplayer:
2018-04-19_20 06 30
2018-04-19_20 06 55
2018-04-19_20 07 06

Steps to reproduce:
Additional information:

@AlexIIL

This comment has been minimized.

Member

AlexIIL commented Apr 20, 2018

I think this might be due to the fluid trigger only reading from a single tank block rather than the whole stack. Can you try with just a single tank block? (Also, can you try with a gate with at least one trigger parameter and add a fluid filter to the first parameter slot?)

Note that neither case are grounds to disregard this issue.

@jburkej1

This comment has been minimized.

jburkej1 commented Apr 20, 2018

it seams to work ok with non gaseous. I will try it with a single block and also a standard BC tank and not the diamond.

@jburkej1

This comment has been minimized.

jburkej1 commented Apr 20, 2018

Does seem to be related to multiblock tanks. when I tested a basic gate and an Iron And gate with and without the hot fuel parameter it worked fine. when I add the 2nd block it powered the wire regardless of what less than full condition I set. I am going to confirm that gates work with the non gaseous fluids tomorrow.
thank you.

@jburkej1

This comment has been minimized.

jburkej1 commented Apr 20, 2018

it seems that gates work as I guess they are supposed to with non gaseous liquids in multi block tanks. I hope that helps figure out whats going on with the gates.

@AlexIIL AlexIIL closed this in #4192 Jun 9, 2018

AlexIIL added a commit that referenced this issue Jun 9, 2018

Merge pull request #4192 from rosebeats/8.0.x
Changed getTankProperties to test for fluid on top as well as the bottom tank.

This fixes #4133.

@AlexIIL AlexIIL reopened this Jun 9, 2018

@AlexIIL AlexIIL closed this Sep 16, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment