Navigation Menu

Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Server crashes when player join after BC update #4399

Closed
Roodypoo0123 opened this issue Apr 21, 2019 · 7 comments
Closed

Server crashes when player join after BC update #4399

Roodypoo0123 opened this issue Apr 21, 2019 · 7 comments
Assignees
Labels
priority: high status: fixed/implemented in dev We've fixed this internally, however the fix hasn't been released publicly yet. type: bug Something isn't behaving as expected, from a developer perspective. (Except crashes are always bugs) version: 1.12.2

Comments

@Roodypoo0123
Copy link

BuildCraft version: 7.99.24
Forge version: 1.12.2-14.23.5.2836
Link to crash report or log: https://cdn.discordapp.com/attachments/309218760814886922/569575670267772958/Crash-report__logs.zip
Singleplayer or multiplayer: Multiplayer
Steps to reproduce: Start server, join the game.
Additional information: The world loads fine and crashes when the player join. Save state includes lots of engines active, fluids/items in transit, all kind of pipes. I am a lone player on my own server, I cannot test if the issues occurs with someone else.

@AlexIIL AlexIIL added priority: high type: bug Something isn't behaving as expected, from a developer perspective. (Except crashes are always bugs) version: 1.12.2 labels Apr 21, 2019
@AlexIIL AlexIIL self-assigned this Apr 21, 2019
@Ragnaraven
Copy link

Ragnaraven commented Apr 21, 2019

BuildCraft version: 7.99.24
Forge version: 1.12.2-14.23.5.2836
Link to crash report or log:
crash-2019-04-21_16.50.31-server.txt
Singleplayer or multiplayer: Multiplayer
Steps to reproduce: Start server, join the game.
INITIAL steps to reproduce: Place quarry, wait for frame to finish. I don't know how long it took to crash but it was less than 5m.

I can reproduce this, although I have other mods installed and I can't get into my world to remove anything to test it. I am gonna try a few things and see if I can come back with more helpful info. Here's the log I have currently.

Edit: rolled back to 7.99.23 and my world is okay. Is there anything I can do to attempt to help?

@AlexIIL
Copy link
Member

AlexIIL commented Apr 21, 2019

Nope, the release 7.99.24 is critically broken server-side and I'll release 7.99.24.1 as a hotfix ASAP.

@AlexIIL AlexIIL added the status: fixed/implemented in dev We've fixed this internally, however the fix hasn't been released publicly yet. label Apr 21, 2019
@AlexIIL
Copy link
Member

AlexIIL commented Apr 21, 2019

Ok, 7.99.24.1 is building now and should be out on the website and curseforge shortly.

@AlexIIL
Copy link
Member

AlexIIL commented Apr 21, 2019

It's fully uploaded an approved on curse - can you retry with it?

@Ragnaraven
Copy link

It appears to be working for me. Thanks for the speedy fix.

@Roodypoo0123
Copy link
Author

I can join the server normally with 24.1.

@AlexIIL
Copy link
Member

AlexIIL commented Apr 21, 2019

Ok! Thanks for testing :)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
priority: high status: fixed/implemented in dev We've fixed this internally, however the fix hasn't been released publicly yet. type: bug Something isn't behaving as expected, from a developer perspective. (Except crashes are always bugs) version: 1.12.2
Projects
None yet
Development

No branches or pull requests

3 participants