Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Buildcraft 1.12.2 crashes while loading #4432

Open
BigMacintoshM8 opened this issue Jun 22, 2019 · 9 comments
Open

Buildcraft 1.12.2 crashes while loading #4432

BigMacintoshM8 opened this issue Jun 22, 2019 · 9 comments

Comments

@BigMacintoshM8
Copy link

@BigMacintoshM8 BigMacintoshM8 commented Jun 22, 2019

BuildCraft version: 7.99.24.1
Forge version: 14.23.5.2768
Link to crash report or log: https://pastebin.com/js0dCi12
Singleplayer or multiplayer: Singleplayer
Steps to reproduce: Install recomended version of Forge for 1.12.2, put latest version of Buildcraft in /mods, run minecraft with forge and Buildcraft.
Additional information: I've downloaded and tried various versions of forge and buildcraft for 1.12.2 but nothing works

Basically, I'm trying to play Minecraft only with Buildcraft but everytime Forge starts loading the mod it always crashes while loading Buildcraft Builders and that's it. I thought Forge could be the problem, but I tried removing Buildcraft and it worked again, same when installing other mods besides Buildcraft. Also tried many other versions of the mod and Forge but it always crashed while loading Buildcraft Builders

Also tried to reinstall Minecraft and Java but didn't work.

@AlexIIL
Copy link
Member

@AlexIIL AlexIIL commented Jun 22, 2019

Unfortunately the log you've given doesn't have any useful information - does it generate a crash report or something similar?

@BigMacintoshM8
Copy link
Author

@BigMacintoshM8 BigMacintoshM8 commented Jun 22, 2019

I can't find any crash report or maybe i don't know where is it, I've tried searching for this problem but it always ends being other mods that are not compatible with Buildcraft.

@zacharyhenry
Copy link

@zacharyhenry zacharyhenry commented Jun 30, 2019

are u using twitch launcher

@SpartanSamuel
Copy link

@SpartanSamuel SpartanSamuel commented Jul 2, 2019

I think I have the same if not a similar issue. See this error for further info. I've tried this with both 7.99.24 and 7.99.24.1 and can't get Minecraft to load all the mods and get to the menu. Relevant crash log is here. I am using the Twitch launcher.

@BigMacintoshM8
Copy link
Author

@BigMacintoshM8 BigMacintoshM8 commented Jul 2, 2019

Hey guys! Just to let you know that my problem was that I was using a Mini OS (apparently this OS aren't compatible with the mod) so I changed it to a normal Windows and it worked just fine.

@AlexIIL
Copy link
Member

@AlexIIL AlexIIL commented Jul 2, 2019

@SpartanSamuel that's a different issue, but fortunately it's much easier to fix than this one: buildcraft-all-7.99.24.jar includes absolutely everything, so you should be able to delete buildcraft-compat-7.99.24.jar and buildcraft-core-7.99.24.jar to make it work.

@BigMacintoshM8 That's odd, but at least it gives some context for what might be causing the issue. (However I'm not really sure how to debug an issue like that - it might be related to differences between how you've setup your mini OS and your windows environment?)

However I think you've uploaded the wrong log file as the original one says that it's running windows 10, not any other variant? (Or do I not understand what Mini OS is?)

@BigMacintoshM8
Copy link
Author

@BigMacintoshM8 BigMacintoshM8 commented Jul 2, 2019

A Mini OS is a much lighter and faster version of Windows but idk why does this causes that problem.

I did change the OS from Windows 10 Mini to Windows 7 mini and the same error happened again, so the next time I changed it to a normal version of Windows 10 and it worked.

AlexIIL added a commit that referenced this issue Jul 9, 2019
@FariZTheKiller
Copy link

@FariZTheKiller FariZTheKiller commented Jul 20, 2019

The same happened to me i'm using windows 10 and multimc launcher. I don't know whats the issue.

@AlexIIL
Copy link
Member

@AlexIIL AlexIIL commented Jul 20, 2019

@FariZTheKiller Can you upload a crash report to https://gist.github.com/ and paste a link back here? (Alternatively can you try updating to the test version of buildcraft 7.99.24.2-pre2 as that has a few fixes that might help solve this).

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
5 participants