Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[SOLVED] BuildCraft Lib crash #4513

Closed
ADT1710 opened this issue Dec 12, 2019 · 6 comments
Closed

[SOLVED] BuildCraft Lib crash #4513

ADT1710 opened this issue Dec 12, 2019 · 6 comments

Comments

@ADT1710
Copy link

@ADT1710 ADT1710 commented Dec 12, 2019

Hello, I'm doing a mod pack for my Minecraft 1.12.2, and when I opened the game it inicialized to charge the mods, but when it arrive in BuildCraft Lib this message appears:

"net.minecraftforge.fml.common.LoaderExceptionModCrash: Caught exception from BuildCraft Lib (buildcraftlib)
Caused by: java.lang.NoSuchFieldError: logger"

Thanks for help!

Crash Report or Log: https://gist.github.com/ADT1710/f35da4032ae9cdd4daeb2f87c772f948

@ADT1710 ADT1710 added the auto: crash label Dec 12, 2019
AlexIIL added a commit that referenced this issue Dec 12, 2019
* Add try-catch code to provide more information in the case of issues like #4513 (where another mod is shipping an old BC API).
* Only load the guide if a mod has requested it. (Note that BC core *always* requests it, so this won't change much)
* Only register the oil biomes if they are enabled, rather than always registering them.
@AlexIIL

This comment has been minimized.

Copy link
Member

@AlexIIL AlexIIL commented Dec 12, 2019

One of your mods includes the old (1.7.10) buildcraft API - to find out which one Can you upload the full log? (Or re-run with 7.99.24.5-pre.1 from the tests page, which includes that information in the crash report).

@AEnterprise

This comment has been minimized.

Copy link
Member

@AEnterprise AEnterprise commented Dec 12, 2019

looking at the mods list, it looks to me like you got most mods from non official sources. Other websites that (often breaking the mods copyright licence) copy mod files, rename them and claim they are for a specific minecraft version (in this case 1.12.2).

Sometimes this is actually that mod for that version, but sometimes that's just an old mod they renamed and slapped on their site. in some extreme cases it's not even a mod malicious code

@ADT1710

This comment has been minimized.

Copy link
Author

@ADT1710 ADT1710 commented Dec 12, 2019

@AlexIIL this is the link of the full log generated when I tried the 7.99.24.5-pre.1, the same error again
https://gist.github.com/ADT1710/055a606f74355b6b8b873252b972ca0c
Thanks for the attention

Thanks @AEnterprise for the advice

@AlexIIL

This comment has been minimized.

Copy link
Member

@AlexIIL AlexIIL commented Dec 12, 2019

Unfortunately that's a log from before - using 7.99.24.4, rather than 7.99.24.5-pre.1.

However it does say that you're trying to use universal-electricity-4.0.0.1-dev.jar, which is for 1.7.10 and not 1.12.2 - so you should remove that.

@ADT1710

This comment has been minimized.

Copy link
Author

@ADT1710 ADT1710 commented Dec 12, 2019

@AlexIIL I removed the universal-electricity-4.0.0.1-dev.jar and now is working normally, in the site was saying it was for the 1.12.2 but is what the @AEnterprise says. Sorry for my mistake and thanks for all!

@ADT1710 ADT1710 closed this Dec 12, 2019
@ADT1710 ADT1710 changed the title BuildCraft Lib crash [SOLVED] BuildCraft Lib crash Dec 12, 2019
@AEnterprise

This comment has been minimized.

Copy link
Member

@AEnterprise AEnterprise commented Dec 12, 2019

@ADT1710 don't worry about it, those sites are just designed to trick users ;)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.