Skip to content

Failed to set drm inerface version #291

Closed
Simz opened this Issue Nov 19, 2012 · 7 comments

4 participants

@Simz
Simz commented Nov 19, 2012

Xorg 1.13
bumblebee/optirun raise this error

xorg.conf.nouveau

Section "ServerLayout"
Identifier "Layout0"
Screen "Screen0"
Option "AutoAddDevices" "false"
Option "AutoAddGPU" "false"
EndSection

Section "Device"
Identifier "Device0"
Driver "nouveau"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
EndSection

4529.115 [drm] nouveau interface version: 1.0.0
4529.146 Loading sub module "dri"
4529.146 LoadModule: "dri"
4529.146 Module "dri" already built-in
4529.146 NOUVEAU(0): Loaded DRI module
4529.146 NOUVEAU(0): [drm] failed to set drm interface version.
4529.146 NOUVEAU(0): [drm] error opening the drm
4529.146 NOUVEAU(0): 818:
4529.146 UnloadModule: "nouveau"
4529.146 Screen(s) found, but none have a usable configuration.

http://pastebin.com/RWc1kHLL

@Lekensteyn
Bumblebee-Project member

Read your kernel logs.

@Simz
Simz commented Nov 19, 2012

everything seems ok !
http://pastebin.com/WwfkMm3t

Any idea ?

@Lekensteyn
Bumblebee-Project member

This looks problematic:

Nov 19 12:32:56 localhost kernel: [   11.365114] No connectors reported connected with modes
Nov 19 12:32:56 localhost kernel: [   11.365118] [drm] Cannot find any crtc or sizes - going 1024x768

Can you retry with the blob? Try fiddling with your BIOS settings for graphics cad (optimus/discrete/integrated mode).

@Simz
Simz commented Nov 19, 2012

i've no problem booting with discrete or integrated selected in the bios...

@Simz
Simz commented Nov 21, 2012

I've tried my setup with the proprietary plob and everything is working.
i guess this is a nouveau/xorg bug.
Thank you !

@Simz Simz closed this Nov 21, 2012
@starks
Bumblebee-Project member
starks commented Dec 5, 2012

[79188.308978] [DEBUG]XORG [drm] nouveau interface version: 1.1.0
[79188.308989] [DEBUG]XORG Loading sub module "dri"
[79188.308999] [DEBUG]XORG LoadModule: "dri"
[79188.309010] [DEBUG]XORG Module "dri" already built-in
[79188.309022] [DEBUG]XORG NOUVEAU(0): Loaded DRI module
[79188.309044] [ERROR]XORG NOUVEAU(0): [drm] failed to set drm interface version.
[79188.309058] [ERROR]XORG NOUVEAU(0): [drm] error opening the drm

Confirming. This only occurs with nouveau.

@starks starks reopened this Dec 5, 2012
@ArchangeGabriel
Bumblebee-Project member

Not a Bumblebee error then.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.