Alt+tab between optirun program and normal program causes screen to blank- Arch linux #539

Closed
BYAHHHH opened this Issue Feb 13, 2014 · 4 comments

Projects

None yet

3 participants

@BYAHHHH

Background:

I ran a full system upgrade in arch linux during the first week of February and it has since caused an interesting, reproducible, bug. Essentially what happens is that whenever I run a program using optirun, switching between windows (like when using alt+tab or when creating a new window, say by using alt+F2 to bring up the application finder) my laptop's screen completely blanks out. The only way to get the screen to turn back on is to jump into another TTY and jump back and then everything appears as it should and what one would expect had the screen not shut off. I've been trying to tease out the root cause of the issue for a few days now and have not had much luck. I could use some guidance as to what I can do on my end to help rectify this problem.

I do not believe that this is relevant given my tests, but I am using openbox as a window manager as well as slim.

I am willing to provide any requested output.

The output listed below is what I find after trying the alt+tab and the jump between TTYs.

dmesg | tail -n 20
[ 1710.244907] [drm] Module unloaded
[ 1710.246438] bbswitch: disabling discrete graphics
[ 1710.246448] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20130725/nsarguments-95)
[ 1710.259408] pci 0000:01:00.0: Refused to change power state, currently in D0
[ 3374.100892] bbswitch: enabling discrete graphics
[ 3374.598664] vgaarb: device changed decodes: PCI:0000:01:00.0,olddecodes=none,decodes=none:owns=none
[ 3374.598803] [drm] Initialized nvidia-drm 0.0.0 20130102 for 0000:01:00.0 on minor 1
[ 3374.598809] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  331.38  Wed Jan  8 19:32:30 PST 2014
[ 3374.666275] nvidia 0000:01:00.0: irq 47 for MSI/MSI-X
[ 3374.672471] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20130725/nsarguments-95)
[ 3374.672546] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20130725/nsarguments-95)
[ 3374.672573] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20130725/nsarguments-95)
[ 3374.672607] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20130725/nsarguments-95)
[ 3374.672633] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20130725/nsarguments-95)
[ 3374.672667] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20130725/nsarguments-95)
[ 3374.672697] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20130725/nsarguments-95)
[ 3374.672721] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20130725/nsarguments-95)
[ 3374.822858] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20130725/nsarguments-95)
[ 3374.822898] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20130725/nsarguments-95)
[ 3374.839264] ACPI Warning: \_SB_.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20130725/nsarguments-95)
@amonakov

When was the previous update? Are you using primus as the default "bridge" in optirun, and if yes, does the problem still appear with PRIMUS_UPLOAD=1 optirun ...? Provide your /var/log/Xorg.0.log.

@BYAHHHH

The previous update was sometime mid-December. I can find the exact date if needed.

I do not remember exactly how I set up optirun. Is there a way to determine which bridge I am using?

I tried the command you provided and the issue still persists.

Here's Xorg.0.log:

[     6.231] 
X.Org X Server 1.15.0
Release Date: 2013-12-27
[     6.231] X Protocol Version 11, Revision 0
[     6.231] Build Operating System: Linux 3.12.5-1-ARCH x86_64 
[     6.231] Current Operating System: Linux lox 3.12.9-2-ARCH #1 SMP PREEMPT Fri Jan 31 10:22:54 CET 2014 x86_64
[     6.231] Kernel command line: BOOT_IMAGE=/vmlinuz-linux root=UUID=f13fadab-6e54-4864-a049-f8e8852772bd rw quiet
[     6.231] Build Date: 09 January 2014  08:47:24AM
[     6.231]  
[     6.231] Current version of pixman: 0.32.4
[     6.231]    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
[     6.231] Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[     6.231] (==) Log file: "/var/log/Xorg.0.log", Time: Fri Feb 14 09:39:17 2014
[     6.233] (==) Using config directory: "/etc/X11/xorg.conf.d"
[     6.233] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[     6.234] (==) No Layout section.  Using the first Screen section.
[     6.234] (==) No screen section available. Using defaults.
[     6.234] (**) |-->Screen "Default Screen Section" (0)
[     6.234] (**) |   |-->Monitor "<default monitor>"
[     6.235] (==) No device specified for screen "Default Screen Section".
    Using the first device section listed.
[     6.235] (**) |   |-->Device "Intel Graphics"
[     6.235] (==) No monitor specified for screen "Default Screen Section".
    Using a default monitor configuration.
[     6.235] (==) Automatically adding devices
[     6.235] (==) Automatically enabling devices
[     6.235] (==) Automatically adding GPU devices
[     6.237] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[     6.237]    Entry deleted from font path.
[     6.239] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[     6.239]    Entry deleted from font path.
[     6.239]    (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[     6.239] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[     6.239]    Entry deleted from font path.
[     6.239]    (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[     6.239] (==) FontPath set to:
    /usr/share/fonts/misc/,
    /usr/share/fonts/TTF/,
    /usr/share/fonts/Type1/
[     6.239] (==) ModulePath set to "/usr/lib/xorg/modules"
[     6.239] (II) The server relies on udev to provide the list of input devices.
    If no devices become available, reconfigure udev or disable AutoAddDevices.
[     6.239] (II) Loader magic: 0x804c80
[     6.239] (II) Module ABI versions:
[     6.239]    X.Org ANSI C Emulation: 0.4
[     6.239]    X.Org Video Driver: 15.0
[     6.239]    X.Org XInput driver : 20.0
[     6.239]    X.Org Server Extension : 8.0
[     6.239] (II) xfree86: Adding drm device (/dev/dri/card0)
[     6.240] (--) PCI:*(0:0:2:0) 8086:0416:1462:10ea rev 6, Mem @ 0xf7400000/4194304, 0xb0000000/268435456, I/O @ 0x0000f000/64
[     6.240] (--) PCI: (0:1:0:0) 10de:119f:1462:10ea rev 161, Mem @ 0xf6000000/16777216, 0xc0000000/268435456, 0xd0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/524288
[     6.240] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[     6.240] Initializing built-in extension Generic Event Extension
[     6.241] Initializing built-in extension SHAPE
[     6.241] Initializing built-in extension MIT-SHM
[     6.241] Initializing built-in extension XInputExtension
[     6.241] Initializing built-in extension XTEST
[     6.241] Initializing built-in extension BIG-REQUESTS
[     6.241] Initializing built-in extension SYNC
[     6.241] Initializing built-in extension XKEYBOARD
[     6.241] Initializing built-in extension XC-MISC
[     6.241] Initializing built-in extension SECURITY
[     6.241] Initializing built-in extension XINERAMA
[     6.241] Initializing built-in extension XFIXES
[     6.241] Initializing built-in extension RENDER
[     6.241] Initializing built-in extension RANDR
[     6.241] Initializing built-in extension COMPOSITE
[     6.241] Initializing built-in extension DAMAGE
[     6.241] Initializing built-in extension MIT-SCREEN-SAVER
[     6.241] Initializing built-in extension DOUBLE-BUFFER
[     6.241] Initializing built-in extension RECORD
[     6.241] Initializing built-in extension DPMS
[     6.241] Initializing built-in extension Present
[     6.241] Initializing built-in extension DRI3
[     6.241] Initializing built-in extension X-Resource
[     6.241] Initializing built-in extension XVideo
[     6.241] Initializing built-in extension XVideo-MotionCompensation
[     6.241] Initializing built-in extension XFree86-VidModeExtension
[     6.241] Initializing built-in extension XFree86-DGA
[     6.241] Initializing built-in extension XFree86-DRI
[     6.241] Initializing built-in extension DRI2
[     6.241] (II) "glx" will be loaded by default.
[     6.241] (II) LoadModule: "dri2"
[     6.241] (II) Module "dri2" already built-in
[     6.241] (II) LoadModule: "glamoregl"
[     6.243] (II) Loading /usr/lib/xorg/modules/libglamoregl.so
[     6.256] (II) Module glamoregl: vendor="X.Org Foundation"
[     6.256]    compiled for 1.15.0, module version = 0.6.0
[     6.256]    ABI class: X.Org ANSI C Emulation, version 0.4
[     6.256] (II) LoadModule: "glx"
[     6.256] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[     6.259] (II) Module glx: vendor="X.Org Foundation"
[     6.259]    compiled for 1.15.0, module version = 1.0.0
[     6.259]    ABI class: X.Org Server Extension, version 8.0
[     6.259] (==) AIGLX enabled
[     6.259] Loading extension GLX
[     6.259] (II) LoadModule: "intel"
[     6.259] (II) Loading /usr/lib/xorg/modules/drivers/intel_drv.so
[     6.262] (II) Module intel: vendor="X.Org Foundation"
[     6.262]    compiled for 1.15.0, module version = 2.99.910
[     6.262]    Module class: X.Org Video Driver
[     6.262]    ABI class: X.Org Video Driver, version 15.0
[     6.262] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
    i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
    915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
    Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
    GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[     6.263] (II) intel: Driver for Intel(R) HD Graphics: 2000-5000
[     6.263] (II) intel: Driver for Intel(R) Iris(TM) Graphics: 5100
[     6.263] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics: 5200
[     6.263] (++) using VT number 7

[     6.270] (--) intel(0): Integrated Graphics Chipset: Intel(R) HD Graphics 4600
[     6.270] (--) intel(0): CPU: x86-64, sse2, sse3, ssse3, sse4.1, sse4.2, avx, avx2
[     6.270] (II) intel(0): Creating default Display subsection in Screen section
    "Default Screen Section" for depth/fbbpp 24/32
[     6.270] (==) intel(0): Depth 24, (--) framebuffer bpp 32
[     6.270] (==) intel(0): RGB weight 888
[     6.270] (==) intel(0): Default visual is TrueColor
[     6.270] (**) intel(0): Option "TearFree" "True"
[     6.270] (**) intel(0): Framebuffer tiled
[     6.270] (**) intel(0): Pixmaps tiled
[     6.270] (**) intel(0): "Tear free" enabled
[     6.270] (**) intel(0): Forcing per-crtc-pixmaps? no
[     6.270] (II) intel(0): Output eDP1 has no monitor section
[     6.316] (--) intel(0): found backlight control interface acpi_video0 (type 'firmware')
[     6.316] (II) intel(0): Output VGA1 has no monitor section
[     6.317] (II) intel(0): Output VIRTUAL1 has no monitor section
[     6.317] (--) intel(0): Output eDP1 using initial mode 1920x1080 on pipe 0
[     6.317] (==) intel(0): DPI set to (96, 96)
[     6.317] (II) Loading sub module "dri2"
[     6.317] (II) LoadModule: "dri2"
[     6.317] (II) Module "dri2" already built-in
[     6.317] (==) Depth 24 pixmap format is 32 bpp
[     6.320] (II) intel(0): SNA initialized with Haswell (gen7.5, gt2) backend
[     6.320] (==) intel(0): Backing store enabled
[     6.320] (==) intel(0): Silken mouse enabled
[     6.321] (II) intel(0): HW Cursor enabled
[     6.321] (II) intel(0): RandR 1.2 enabled, ignore the following RandR disabled message.
[     6.322] (==) intel(0): DPMS enabled
[     6.322] (II) intel(0): [DRI2] Setup complete
[     6.322] (II) intel(0): [DRI2]   DRI driver: i965
[     6.322] (II) intel(0): [DRI2]   VDPAU driver: i965
[     6.322] (II) intel(0): direct rendering: DRI2 Enabled
[     6.322] (==) intel(0): hotplug detection: "enabled"
[     6.322] (--) RandR disabled
[     6.341] (II) AIGLX: enabled GLX_MESA_copy_sub_buffer
[     6.341] (II) AIGLX: enabled GLX_ARB_create_context
[     6.341] (II) AIGLX: enabled GLX_ARB_create_context_profile
[     6.341] (II) AIGLX: enabled GLX_EXT_create_context_es2_profile
[     6.341] (II) AIGLX: enabled GLX_INTEL_swap_event
[     6.341] (II) AIGLX: enabled GLX_SGI_swap_control and GLX_MESA_swap_control
[     6.341] (II) AIGLX: enabled GLX_EXT_framebuffer_sRGB
[     6.341] (II) AIGLX: enabled GLX_ARB_fbconfig_float
[     6.341] (II) AIGLX: GLX_EXT_texture_from_pixmap backed by buffer objects
[     6.342] (II) AIGLX: Loaded and initialized i965
[     6.342] (II) GLX: Initialized DRI2 GL provider for screen 0
[     6.345] (II) intel(0): switch to mode 1920x1080@60.0 on eDP1 using pipe 0, position (0, 0), rotation normal, reflection none
[     6.370] (II) intel(0): Setting screen physical size to 508 x 285
[     6.417] (II) config/udev: Adding input device Power Button (/dev/input/event6)
[     6.417] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[     6.417] (II) LoadModule: "evdev"
[     6.417] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[     6.418] (II) Module evdev: vendor="X.Org Foundation"
[     6.418]    compiled for 1.15.0, module version = 2.8.2
[     6.418]    Module class: X.Org XInput Driver
[     6.418]    ABI class: X.Org XInput driver, version 20.0
[     6.418] (II) Using input driver 'evdev' for 'Power Button'
[     6.418] (**) Power Button: always reports core events
[     6.418] (**) evdev: Power Button: Device: "/dev/input/event6"
[     6.418] (--) evdev: Power Button: Vendor 0 Product 0x1
[     6.418] (--) evdev: Power Button: Found keys
[     6.418] (II) evdev: Power Button: Configuring as keyboard
[     6.418] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input7/event6"
[     6.418] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[     6.418] (**) Option "xkb_rules" "evdev"
[     6.418] (**) Option "xkb_model" "pc104"
[     6.418] (**) Option "xkb_layout" "us"
[     6.433] (II) config/udev: Adding input device Video Bus (/dev/input/event15)
[     6.433] (**) Video Bus: Applying InputClass "evdev keyboard catchall"
[     6.433] (II) Using input driver 'evdev' for 'Video Bus'
[     6.433] (**) Video Bus: always reports core events
[     6.433] (**) evdev: Video Bus: Device: "/dev/input/event15"
[     6.433] (--) evdev: Video Bus: Vendor 0 Product 0x6
[     6.433] (--) evdev: Video Bus: Found keys
[     6.433] (II) evdev: Video Bus: Configuring as keyboard
[     6.433] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/device:00/PNP0A08:00/LNXVIDEO:01/input/input16/event15"
[     6.433] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD, id 7)
[     6.433] (**) Option "xkb_rules" "evdev"
[     6.433] (**) Option "xkb_model" "pc104"
[     6.433] (**) Option "xkb_layout" "us"
[     6.433] (II) config/udev: Adding input device Lid Switch (/dev/input/event4)
[     6.433] (II) No input driver specified, ignoring this device.
[     6.433] (II) This device may have been added with another device file.
[     6.434] (II) config/udev: Adding input device Video Bus (/dev/input/event14)
[     6.434] (**) Video Bus: Applying InputClass "evdev keyboard catchall"
[     6.434] (II) Using input driver 'evdev' for 'Video Bus'
[     6.434] (**) Video Bus: always reports core events
[     6.434] (**) evdev: Video Bus: Device: "/dev/input/event14"
[     6.434] (--) evdev: Video Bus: Vendor 0 Product 0x6
[     6.434] (--) evdev: Video Bus: Found keys
[     6.434] (II) evdev: Video Bus: Configuring as keyboard
[     6.434] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/device:00/PNP0A08:00/device:48/LNXVIDEO:00/input/input15/event14"
[     6.434] (II) XINPUT: Adding extended input device "Video Bus" (type: KEYBOARD, id 8)
[     6.434] (**) Option "xkb_rules" "evdev"
[     6.434] (**) Option "xkb_model" "pc104"
[     6.434] (**) Option "xkb_layout" "us"
[     6.434] (II) config/udev: Adding input device Power Button (/dev/input/event5)
[     6.434] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[     6.434] (II) Using input driver 'evdev' for 'Power Button'
[     6.434] (**) Power Button: always reports core events
[     6.434] (**) evdev: Power Button: Device: "/dev/input/event5"
[     6.434] (--) evdev: Power Button: Vendor 0 Product 0x1
[     6.434] (--) evdev: Power Button: Found keys
[     6.434] (II) evdev: Power Button: Configuring as keyboard
[     6.434] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/device:00/PNP0C0C:00/input/input6/event5"
[     6.434] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 9)
[     6.434] (**) Option "xkb_rules" "evdev"
[     6.434] (**) Option "xkb_model" "pc104"
[     6.434] (**) Option "xkb_layout" "us"
[     6.434] (II) config/udev: Adding drm device (/dev/dri/card0)
[     6.434] (II) config/udev: Adding input device Microsoft Microsoft® Nano Transceiver v2.0 (/dev/input/event1)
[     6.434] (**) Microsoft Microsoft® Nano Transceiver v2.0: Applying InputClass "evdev keyboard catchall"
[     6.434] (II) Using input driver 'evdev' for 'Microsoft Microsoft® Nano Transceiver v2.0'
[     6.434] (**) Microsoft Microsoft® Nano Transceiver v2.0: always reports core events
[     6.434] (**) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Device: "/dev/input/event1"
[     6.434] (--) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Vendor 0x45e Product 0x745
[     6.434] (--) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Found keys
[     6.434] (II) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Configuring as keyboard
[     6.434] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:14.0/usb3/3-1/3-1:1.0/input/input2/event1"
[     6.434] (II) XINPUT: Adding extended input device "Microsoft Microsoft® Nano Transceiver v2.0" (type: KEYBOARD, id 10)
[     6.434] (**) Option "xkb_rules" "evdev"
[     6.434] (**) Option "xkb_model" "pc104"
[     6.434] (**) Option "xkb_layout" "us"
[     6.435] (II) config/udev: Adding input device Microsoft Microsoft® Nano Transceiver v2.0 (/dev/input/event2)
[     6.435] (**) Microsoft Microsoft® Nano Transceiver v2.0: Applying InputClass "evdev pointer catchall"
[     6.435] (**) Microsoft Microsoft® Nano Transceiver v2.0: Applying InputClass "evdev keyboard catchall"
[     6.435] (II) Using input driver 'evdev' for 'Microsoft Microsoft® Nano Transceiver v2.0'
[     6.435] (**) Microsoft Microsoft® Nano Transceiver v2.0: always reports core events
[     6.435] (**) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Device: "/dev/input/event2"
[     6.435] (--) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Vendor 0x45e Product 0x745
[     6.435] (--) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Found 9 mouse buttons
[     6.435] (--) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Found scroll wheel(s)
[     6.435] (--) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Found relative axes
[     6.435] (--) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Found x and y relative axes
[     6.435] (--) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Found absolute axes
[     6.435] (II) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Forcing absolute x/y axes to exist.
[     6.435] (--) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Found keys
[     6.435] (II) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Configuring as mouse
[     6.435] (II) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Configuring as keyboard
[     6.435] (II) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Adding scrollwheel support
[     6.435] (**) evdev: Microsoft Microsoft® Nano Transceiver v2.0: YAxisMapping: buttons 4 and 5
[     6.435] (**) evdev: Microsoft Microsoft® Nano Transceiver v2.0: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[     6.435] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:14.0/usb3/3-1/3-1:1.1/input/input3/event2"
[     6.435] (II) XINPUT: Adding extended input device "Microsoft Microsoft® Nano Transceiver v2.0" (type: KEYBOARD, id 11)
[     6.435] (**) Option "xkb_rules" "evdev"
[     6.435] (**) Option "xkb_model" "pc104"
[     6.435] (**) Option "xkb_layout" "us"
[     6.435] (II) evdev: Microsoft Microsoft® Nano Transceiver v2.0: initialized for relative axes.
[     6.435] (WW) evdev: Microsoft Microsoft® Nano Transceiver v2.0: ignoring absolute axes.
[     6.435] (**) Microsoft Microsoft® Nano Transceiver v2.0: (accel) keeping acceleration scheme 1
[     6.435] (**) Microsoft Microsoft® Nano Transceiver v2.0: (accel) acceleration profile 0
[     6.435] (**) Microsoft Microsoft® Nano Transceiver v2.0: (accel) acceleration factor: 2.000
[     6.435] (**) Microsoft Microsoft® Nano Transceiver v2.0: (accel) acceleration threshold: 4
[     6.435] (II) config/udev: Adding input device Microsoft Microsoft® Nano Transceiver v2.0 (/dev/input/mouse0)
[     6.435] (II) No input driver specified, ignoring this device.
[     6.435] (II) This device may have been added with another device file.
[     6.435] (II) config/udev: Adding input device Microsoft Microsoft® Nano Transceiver v2.0 (/dev/input/event3)
[     6.435] (**) Microsoft Microsoft® Nano Transceiver v2.0: Applying InputClass "evdev keyboard catchall"
[     6.435] (II) Using input driver 'evdev' for 'Microsoft Microsoft® Nano Transceiver v2.0'
[     6.435] (**) Microsoft Microsoft® Nano Transceiver v2.0: always reports core events
[     6.435] (**) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Device: "/dev/input/event3"
[     6.435] (II) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Using mtdev for this device
[     6.435] (--) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Vendor 0x45e Product 0x745
[     6.435] (--) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Found 1 mouse buttons
[     6.435] (--) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Found scroll wheel(s)
[     6.435] (--) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Found relative axes
[     6.435] (--) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Found absolute axes
[     6.435] (--) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Found absolute multitouch axes
[     6.435] (--) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Found x and y absolute axes
[     6.435] (--) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Found keys
[     6.435] (II) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Forcing relative x/y axes to exist.
[     6.435] (II) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Configuring as mouse
[     6.435] (II) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Configuring as keyboard
[     6.435] (II) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Adding scrollwheel support
[     6.435] (**) evdev: Microsoft Microsoft® Nano Transceiver v2.0: YAxisMapping: buttons 4 and 5
[     6.435] (**) evdev: Microsoft Microsoft® Nano Transceiver v2.0: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[     6.435] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:14.0/usb3/3-1/3-1:1.2/input/input4/event3"
[     6.435] (II) XINPUT: Adding extended input device "Microsoft Microsoft® Nano Transceiver v2.0" (type: KEYBOARD, id 12)
[     6.435] (**) Option "xkb_rules" "evdev"
[     6.435] (**) Option "xkb_model" "pc104"
[     6.435] (**) Option "xkb_layout" "us"
[     6.436] (II) evdev: Microsoft Microsoft® Nano Transceiver v2.0: initialized for relative axes.
[     6.436] (WW) evdev: Microsoft Microsoft® Nano Transceiver v2.0: ignoring absolute axes.
[     6.436] (**) Microsoft Microsoft® Nano Transceiver v2.0: (accel) keeping acceleration scheme 1
[     6.436] (**) Microsoft Microsoft® Nano Transceiver v2.0: (accel) acceleration profile 0
[     6.436] (**) Microsoft Microsoft® Nano Transceiver v2.0: (accel) acceleration factor: 2.000
[     6.436] (**) Microsoft Microsoft® Nano Transceiver v2.0: (accel) acceleration threshold: 4
[     6.436] (II) config/udev: Adding input device Microsoft Microsoft® Nano Transceiver v2.0 (/dev/input/js0)
[     6.436] (II) No input driver specified, ignoring this device.
[     6.436] (II) This device may have been added with another device file.
[     6.436] (II) config/udev: Adding input device HDA Intel PCH Mic (/dev/input/event11)
[     6.436] (II) No input driver specified, ignoring this device.
[     6.436] (II) This device may have been added with another device file.
[     6.436] (II) config/udev: Adding input device HDA Intel PCH Line (/dev/input/event10)
[     6.436] (II) No input driver specified, ignoring this device.
[     6.436] (II) This device may have been added with another device file.
[     6.436] (II) config/udev: Adding input device HDA Intel PCH Line Out (/dev/input/event9)
[     6.436] (II) No input driver specified, ignoring this device.
[     6.436] (II) This device may have been added with another device file.
[     6.436] (II) config/udev: Adding input device HDA Intel PCH Headphone (/dev/input/event8)
[     6.436] (II) No input driver specified, ignoring this device.
[     6.436] (II) This device may have been added with another device file.
[     6.436] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event0)
[     6.436] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
[     6.436] (II) Using input driver 'evdev' for 'AT Translated Set 2 keyboard'
[     6.436] (**) AT Translated Set 2 keyboard: always reports core events
[     6.436] (**) evdev: AT Translated Set 2 keyboard: Device: "/dev/input/event0"
[     6.436] (--) evdev: AT Translated Set 2 keyboard: Vendor 0x1 Product 0x1
[     6.436] (--) evdev: AT Translated Set 2 keyboard: Found keys
[     6.436] (II) evdev: AT Translated Set 2 keyboard: Configuring as keyboard
[     6.436] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio0/input/input0/event0"
[     6.436] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD, id 13)
[     6.436] (**) Option "xkb_rules" "evdev"
[     6.436] (**) Option "xkb_model" "pc104"
[     6.436] (**) Option "xkb_layout" "us"
[     6.437] (II) config/udev: Adding input device ETPS/2 Elantech Touchpad (/dev/input/event13)
[     6.437] (**) ETPS/2 Elantech Touchpad: Applying InputClass "evdev touchpad catchall"
[     6.437] (**) ETPS/2 Elantech Touchpad: Applying InputClass "touchpad catchall"
[     6.437] (**) ETPS/2 Elantech Touchpad: Applying InputClass "Default clickpad buttons"
[     6.437] (II) LoadModule: "synaptics"
[     6.437] (II) Loading /usr/lib/xorg/modules/input/synaptics_drv.so
[     6.438] (II) Module synaptics: vendor="X.Org Foundation"
[     6.438]    compiled for 1.15.0, module version = 1.7.3
[     6.438]    Module class: X.Org XInput Driver
[     6.438]    ABI class: X.Org XInput driver, version 20.0
[     6.438] (II) Using input driver 'synaptics' for 'ETPS/2 Elantech Touchpad'
[     6.438] (**) ETPS/2 Elantech Touchpad: always reports core events
[     6.438] (**) Option "Device" "/dev/input/event13"
[     6.543] (--) synaptics: ETPS/2 Elantech Touchpad: x-axis range 0 - 2772 (res 0)
[     6.543] (--) synaptics: ETPS/2 Elantech Touchpad: y-axis range 0 - 1320 (res 0)
[     6.543] (--) synaptics: ETPS/2 Elantech Touchpad: pressure range 0 - 255
[     6.543] (--) synaptics: ETPS/2 Elantech Touchpad: finger width range 0 - 15
[     6.543] (--) synaptics: ETPS/2 Elantech Touchpad: buttons: left right double triple
[     6.543] (--) synaptics: ETPS/2 Elantech Touchpad: Vendor 0x2 Product 0xe
[     6.543] (**) Option "TapButton1" "1"
[     6.543] (**) Option "TapButton2" "2"
[     6.543] (**) Option "TapButton3" "3"
[     6.543] (--) synaptics: ETPS/2 Elantech Touchpad: touchpad found
[     6.543] (**) ETPS/2 Elantech Touchpad: always reports core events
[     6.596] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio1/input/input9/event13"
[     6.596] (II) XINPUT: Adding extended input device "ETPS/2 Elantech Touchpad" (type: TOUCHPAD, id 14)
[     6.596] (**) synaptics: ETPS/2 Elantech Touchpad: (accel) MinSpeed is now constant deceleration 2.5
[     6.596] (**) synaptics: ETPS/2 Elantech Touchpad: (accel) MaxSpeed is now 1.75
[     6.596] (**) synaptics: ETPS/2 Elantech Touchpad: (accel) AccelFactor is now 0.065
[     6.597] (**) ETPS/2 Elantech Touchpad: (accel) keeping acceleration scheme 1
[     6.597] (**) ETPS/2 Elantech Touchpad: (accel) acceleration profile 1
[     6.597] (**) ETPS/2 Elantech Touchpad: (accel) acceleration factor: 2.000
[     6.597] (**) ETPS/2 Elantech Touchpad: (accel) acceleration threshold: 4
[     6.597] (--) synaptics: ETPS/2 Elantech Touchpad: touchpad found
[     6.597] (II) config/udev: Adding input device ETPS/2 Elantech Touchpad (/dev/input/mouse1)
[     6.597] (**) ETPS/2 Elantech Touchpad: Ignoring device from InputClass "touchpad ignore duplicates"
[     6.597] (II) config/udev: Adding input device PC Speaker (/dev/input/event7)
[     6.597] (II) No input driver specified, ignoring this device.
[     6.597] (II) This device may have been added with another device file.
[     6.597] (II) config/udev: Adding input device MSI WMI hotkeys (/dev/input/event12)
[     6.597] (**) MSI WMI hotkeys: Applying InputClass "evdev keyboard catchall"
[     6.597] (II) Using input driver 'evdev' for 'MSI WMI hotkeys'
[     6.597] (**) MSI WMI hotkeys: always reports core events
[     6.597] (**) evdev: MSI WMI hotkeys: Device: "/dev/input/event12"
[     6.597] (--) evdev: MSI WMI hotkeys: Vendor 0 Product 0
[     6.597] (--) evdev: MSI WMI hotkeys: Found keys
[     6.597] (II) evdev: MSI WMI hotkeys: Configuring as keyboard
[     6.597] (**) Option "config_info" "udev:/sys/devices/virtual/input/input14/event12"
[     6.597] (II) XINPUT: Adding extended input device "MSI WMI hotkeys" (type: KEYBOARD, id 15)
[     6.597] (**) Option "xkb_rules" "evdev"
[     6.597] (**) Option "xkb_model" "pc104"
[     6.597] (**) Option "xkb_layout" "us"
[    14.516] (II) AIGLX: Suspending AIGLX clients for VT switch
[    49.045] (II) AIGLX: Resuming AIGLX clients after VT switch
[    49.045] (II) intel(0): switch to mode 1920x1080@60.0 on eDP1 using pipe 0, position (0, 0), rotation normal, reflection none
[    49.064] (II) intel(0): EDID vendor "CMO", prod id 5920
[    49.064] (II) intel(0): Printing DDC gathered Modelines:
[    49.064] (II) intel(0): Modeline "1920x1080"x0.0  138.70  1920 1968 2000 2080  1080 1083 1088 1111 -hsync -vsync (66.7 kHz eP)
[    49.065] (II) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Using mtdev for this device
[    49.065] (--) synaptics: ETPS/2 Elantech Touchpad: touchpad found
[   183.532] removing GPU device /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0/drm/card1 /dev/dri/card1
[   183.532] (II) config/udev: Adding drm device (/dev/dri/card1)
[   183.532] (II) xfree86: Adding drm device (/dev/dri/card1)
[   183.532] (II) LoadModule: "modesetting"
[   183.533] (WW) Warning, couldn't open module modesetting
[   183.533] (II) UnloadModule: "modesetting"
[   183.533] (II) Unloading modesetting
[   183.533] (EE) Failed to load module "modesetting" (module does not exist, 0)
[   183.533] xf86: found device 1
[   193.759] (II) intel(0): switch to mode 1920x1080@60.0 on eDP1 using pipe 0, position (0, 0), rotation normal, reflection none
[   197.635] (II) intel(0): switch to mode 1920x1080@60.0 on eDP1 using pipe 0, position (0, 0), rotation normal, reflection none
[   201.359] (EE) intel(0): sna_mode_redisplay: page flipping failed, disabling CRTC:3 (pipe=0)
[   205.526] (II) AIGLX: Suspending AIGLX clients for VT switch
[   206.168] (II) AIGLX: Resuming AIGLX clients after VT switch
[   206.168] (II) intel(0): switch to mode 1920x1080@60.0 on eDP1 using pipe 0, position (0, 0), rotation normal, reflection none
[   206.185] (II) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Using mtdev for this device
[   206.185] (--) synaptics: ETPS/2 Elantech Touchpad: touchpad found
[   211.450] (EE) intel(0): sna_mode_redisplay: page flipping failed, disabling CRTC:3 (pipe=0)
[   212.480] removing GPU device /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0/drm/card1 /dev/dri/card1
[   213.030] (II) AIGLX: Suspending AIGLX clients for VT switch
[   232.720] (II) AIGLX: Resuming AIGLX clients after VT switch
[   232.720] (II) intel(0): switch to mode 1920x1080@60.0 on eDP1 using pipe 0, position (0, 0), rotation normal, reflection none
[   232.738] (II) evdev: Microsoft Microsoft® Nano Transceiver v2.0: Using mtdev for this device
[   232.738] (--) synaptics: ETPS/2 Elantech Touchpad: touchpad found
@amonakov

Is there a way to determine which bridge I am using?

optirun --debug ... should tell you that.

It seems you have manually enabled i965 TearFree. If you comment that out, does the issue still persist?

This looks like a bug in Xorg i965 driver, please report it to them according to https://01.org/linuxgraphics/documentation/how-report-bugs (update to recent driver first).

@ArchangeGabriel
Bumblebee-Project member

No answer, closing.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment