High zoom optics broken on all LMGs #159

Closed
captainblaffer opened this Issue Sep 20, 2015 · 21 comments

Projects

None yet

10 participants

@captainblaffer

CBA3 Version: v200150817-fixed

Mods:
@CBA_A3

Description:

Most high zoom optics can not be used on any LMGs.
List:

  • LMG_Zafir_F
  • LMG_Mk200_F
  • MMG_02_sand_F

When attempting to equip the scope in VA or via script, it won't appear.
Broken Scopes include:

  • AMS
  • DMS (optic_DMS)
  • Kahila
  • LRPS
  • MOS

Steps to reproduce:

Start Virtual Arsenal
Equip any lmg from list above
Equip any of the optics above

Where did the issue occur?

"Multiplayer", "Editor"

RPT log file:
n/a

@captainblaffer

Any word on this from the devs???

@dixon13
Contributor
dixon13 commented Oct 9, 2015

Intended behavior. Reference: CBA_A3/addons/jr/jr_classes.hpp Line 88

@captainblaffer

These attachments work fine in default A3. Why should they be disabled? this is really annoying. Especially because one can't simply remove CBA from their modset, many other mods depend on it.

@robalo robalo was assigned by ViperMaul Oct 9, 2015
@dixon13
Contributor
dixon13 commented Oct 9, 2015

The above link that I posted has a comment on that same line that states, "// attachments that would not work well on machine guns". I'm guessing this is intentional for realism. IRL doesn't make sense to stick a high zoom optic on a LMG. The LMG's aren't made for sniping but rather suppression. IRL the gun would probably shake the scope off or shake the attachment so much that it would come loose and make it not accurate anymore. Also, the optic itself could just break or crack from the shaking of the gun.

@robalo
Contributor
robalo commented Oct 9, 2015

This was intended in JR and brought into CBA. Yes I see the point about not changing vanilla behavior. At the same time also think this is a vanilla bug because those big scopes look silly the way they clip through the weapon models when you reload, which you'd not even be able to do in real life since they'd make it impossible to open the belt feed cover. I am curious about what others think about this.

@MikeMatrix
Contributor

I personally would just leave it like this. I feel like this is just a vanilla bug that never got fixed.

@jonpas
Contributor
jonpas commented Oct 9, 2015

I agree with what @robalo and @MikeMatrix said.

@captainblaffer

"This was intended in JR and brought into CBA"
When running just ASDG_JR 0.16, which is the latest version afaik, I am able to put all scopes on all LMGs.

"because those big scopes look silly the way they clip through the weapon models when you reload"
Partly true there is a visual glitch with some weapons. But on the navid it looks fine. See video:
https://www.youtube.com/watch?v=WCOuZOl1ZQ8&feature=youtu.be

If you want to use realism as an argument, that's your decision. But please don't include such a big change in CBA, which is a requirement for many other mods, I can't just disable CBA if I don't like it.

This 'feature' also breaks many existing missions which feature scopes on LMGs. Even bigger mods like ACE don't break existing missions.
It would be really appreciated to keep this functionality the same as in arma 3, by allowing scopes on LMGs.

@jokoho48
Member
jokoho48 commented Oct 9, 2015

i think that this is a BI fault(or normaly you cant attach a highzoom optic to a MG)

@MikeMatrix
Contributor

Well the consideration that should be made is, should CBA even Fix issues like those? It's more of a general project guideline question.

@jokoho48
Member
jokoho48 commented Oct 9, 2015

i think that is not fixable if i remeber right this is model based(not fixable)

@PabstMirror
Contributor

Could put this in optionals (unsigned) and let people use if they desire.

class CfgPatches
{
    class cba_jr_mgSniper
    {
        units[] = {};
        weapons[] = {};
        requiredVersion = 1;
        requiredAddons[] = {"cba_jr", "asdg_jointrails", "asdg_jointmuzzles"};
    };
};

class asdg_OpticRail1913_short;
class asdg_OpticRail1913_short_MG: asdg_OpticRail1913_short {
    delete compatibleItems;
};

The door on the Zafir/Negev clips through the scope when reloading.

image

@MikeMatrix
Contributor

class cba_jr_mgSniper

I love that class name :shipit:

@Calvin-McG

As captainblaffer says, CBA is a requirement for too many mods. Forcing a debatable realism change on what is effectively anyone using mods in any significant amount is not the place of CBA.

This sort of change is a small patch, for what might not even be a problem for many users. And in the course of patching what may not even be an issue for some people those that actually want this functionality are left hanging.

Of course there are some very good realism arguments that have been made above, but those that want more realism can't make decisions on behalf of those that don't.

An obvious solution would be to make this a separate mini-module that players and people in charge of community mod repos can decide on themselves.

@MikeMatrix
Contributor

@Calvin-McG I think the opinion so far was pretty uniform that CBA doesn't do realism changes. What was to be considered though, is if this was a bug introduced by BI, and should something like that be fixed by something like CBA.
What @PabstMirror proposed is essentially what you just proposed as well. Introducing it as an optional component might be the most desireable solution to this, because the more I think about it, the more it makes sense for CBA not to modify behavior, only to complement behavior or supply functionality for modmakers.

@Calvin-McG

@MikeMatrix So far though the argument around it being a bug seems to be limited to the fact that it's realism is questionable, and that there are clipping issues. Just because it's not realistic doesn't mean it's a bug, and all that disabling things with clipping issues will do is remove any feature that didn't get animated quite perfectly.

@MikeMatrix
Contributor

@Calvin-McG The argument being that the clipping issue exists, which is indicative that BI did not intent for this optic to be supported on that weapon.

@Calvin-McG

@MikeMatrix That's a pretty weak argument to justify a change like this. By the same argument BI also did not intend buildings, doors, rocks, and the V step to be present in the game.

@MikeMatrix
Contributor

@Calvin-McG idk how you get to that conclusion, because that would mean that BI would have accidentally left configuration on buildings, doors, rocks and the V step (why is that even in this list?) to be the way so they would be on the map, even though it wasn't their intention.

The Optic clearly has that issue, as it either was accidentally misconfigured and that allows it to be used on top of the AR, or it hasn't been animated properly, which makes it clip through the weapon. I think considering we're speaking of adding high magnification optics on top of automatic rifles, the first option is the more likely one.

With that conclusion in mind, the question remains, if CBA should patch something like that or not.
My standpoint at this moment is, that if we were to provide a patch like that, it should be as an optional change, as CBA is a library mod, and as such shouldn't alter behavior unless it is to provide functionality to enable other mods to do what they do.

@dixon13
Contributor
dixon13 commented Oct 10, 2015

Why make an optional pbo for the patch when ACE3 can just put it in their mod? Like @Calvin-McG said before, this mod is for functionality and not realism. If it's for realism, then hand it off to ACE and let them deal with it.

@Imperum
Imperum commented Jan 15, 2016

This is something that comes out of the base game, in my opinion a "support" mod should not force these kind of changes. If the devs find it something they desire, make it optional for the players that don't like it so they can atleast use CBA without any changes. Or move it to ACE as suggested by others. As so many other mods depend on this mod, it should not make such big game-changing features. Maybe give it its own module/separate part and keep the basegame features.

I wan't to use this mod, but this very little change keeps me from enjoying the game as before. I just love my adjustable zoom scopes. Hope that something will be done with this "issue".

@ViperMaul ViperMaul added this to the 2.2.1 milestone Jan 16, 2016
@ViperMaul ViperMaul added the bug label Jan 16, 2016
@Killswitch00 Killswitch00 pushed a commit that closed this issue Jan 23, 2016
@robalo robalo JR: Do not blacklist long scopes on the short mg rails anymore, move …
…that to optional pbo instead. Fixes #159.
4578320
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment