Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

xname and yname doesn't work #710

Closed
williams13 opened this issue Sep 26, 2014 · 2 comments
Closed

xname and yname doesn't work #710

williams13 opened this issue Sep 26, 2014 · 2 comments
Assignees
Milestone

Comments

@williams13
Copy link
Contributor

@williams13 williams13 commented Sep 26, 2014

If the template is set to priority 1 for xname and yname, the x-axis and y-axis don't show up on the screen. See test script below:

import vcs, cdms2
cdmsfile = cdms2.open( 'clt.nc' )
data = cdmsfile('clt')
x=vcs.init()
g=x.createboxfill('new')
t=x.createtemplate('new')
t.xname.priority = 1
t.yname.priority = 1
t.data.priority =0 # don't show the data so that you can see that there's not x or y axis text
t.legend.priority =0 # don't show the legend either
x.plot(data, g, t)

@doutriaux1
Copy link
Contributor

@doutriaux1 doutriaux1 commented Nov 11, 2014

@williams13 this seems to work for me see attached, please reopen if that doesnt work for you.
ok

@doutriaux1 doutriaux1 closed this Nov 11, 2014
@williams13
Copy link
Contributor Author

@williams13 williams13 commented Nov 11, 2014

Yes, you fixed this for v2.0.0 the xname and yname show up on the plot with the template.

Thanks,

From: Charles Doutriaux <notifications@github.commailto:notifications@github.com>
Reply-To: UV-CDAT/uvcdat <reply@reply.github.commailto:reply@reply.github.com>
Date: Monday, November 10, 2014 4:28 PM
To: UV-CDAT/uvcdat <uvcdat@noreply.github.commailto:uvcdat@noreply.github.com>
Cc: Dean Williams <williams13@llnl.govmailto:williams13@llnl.gov>
Subject: Re: [uvcdat] xname and yname doesn't work (#710)

@williams13https://github.com/williams13 this seems to work for me see attached, please reopen if that doesnt work for you.
[ok]https://cloud.githubusercontent.com/assets/2781425/4986364/a20a9abc-6939-11e4-9857-4d6551bb64be.png


Reply to this email directly or view it on GitHubhttps://github.com//issues/710#issuecomment-62482030.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
2 participants