Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

ubuntu animations aren't saved #799

Closed
potter2 opened this issue Oct 14, 2014 · 25 comments
Closed

ubuntu animations aren't saved #799

potter2 opened this issue Oct 14, 2014 · 25 comments
Milestone

Comments

@potter2
Copy link

@potter2 potter2 commented Oct 14, 2014

The MAC 10.9 saves the animation in .uvcdat but the Ubuntu version does not save an amimation

@potter2
Copy link
Author

@potter2 potter2 commented Oct 14, 2014

This DOES work in CENTOS.. so it is just UBUNTU.

@doutriaux1
Copy link
Contributor

@doutriaux1 doutriaux1 commented Oct 14, 2014

VCS or dv3d animations

@aashish24
Copy link
Contributor

@aashish24 aashish24 commented Oct 14, 2014

cal it vcs 2D or vcs 3D -:).

@potter2
Copy link
Author

@potter2 potter2 commented Oct 14, 2014

I thought you were only releasing the animation in DV3D. That is the only one I tried. Is the 2D installed?
In any case in the .uvcdat directory, Tom creates a directory and puts the animation in it (the directories are called animation-0 animation-1 etc. )
The Ubuntu version makes a directory but it is empty. Mac and CENTOS work fine.

Jerry

Gerald (Jerry) Potter
NASA Goddard Space Flight Center
E-mail gerald.potter@nasa.gov
Office 28:S241
Phone 707.315.8314
Analysis and Data Consultant
Department GSFC:606.2

From: Charles <notifications@github.commailto:notifications@github.com>
Reply-To: UV-CDAT/uvcdat <reply@reply.github.commailto:reply@reply.github.com>
Date: Tuesday, October 14, 2014 at 7:18 AM
To: UV-CDAT/uvcdat <uvcdat@noreply.github.commailto:uvcdat@noreply.github.com>
Cc: Gerald Potter <gerald.potter@nasa.govmailto:gerald.potter@nasa.gov>
Subject: Re: [uvcdat] ubuntu animations aren't saved (#799)

VCS or dv3d animations


Reply to this email directly or view it on GitHubhttps://github.com//issues/799#issuecomment-59051903.

@doutriaux1
Copy link
Contributor

@doutriaux1 doutriaux1 commented Oct 14, 2014

just tested with @potter2 confirmed this on ubunutu. Also on CentOS (FULL) build I get:
File "/usr/local/uvcdat/2.0.0/lib/python2.7/threading.py", line 810, in __bootstrap_inner
self.run()
File "/usr/local/uvcdat/2.0.0/lib/python2.7/threading.py", line 763, in run
self.__target(_self.__args, *_self.__kwargs)
File "/usr/local/uvcdat/2.0.0/lib/python2.7/site-packages/DV3D/DV3DPlot.py", line 40, in saveAnimation
writer = vtk.vtkFFMPEGWriter()
AttributeError: 'module' object has no attribute 'vtkFFMPEGWriter'

@aashish24 @dlonie looks like the FULL build does not include ffmpeg

@doutriaux1 doutriaux1 added this to the 2.1 milestone Oct 14, 2014
@aashish24
Copy link
Contributor

@aashish24 aashish24 commented Oct 14, 2014

@doutriaux1 I believe you might be right. Also, on ubuntu, I believe there is an issue with python threading.. could you be seeing that?

@dlonie can you push a fix for full build asap?

@potter2
Copy link
Author

@potter2 potter2 commented Oct 14, 2014

When is this going to happen? I know there will be interest in the Ubuntu build

@allisonvacanti
Copy link
Contributor

@allisonvacanti allisonvacanti commented Oct 14, 2014

@potter2 I should have something tomorrow afternoon at the latest.

@aashish24
Copy link
Contributor

@aashish24 aashish24 commented Oct 14, 2014

@potter2 what @dlonie is going to fix is the ffmpeg not found in full build. The other reason for animation not working on ubutntu needs to be investigated by @ThomasMaxwell.

@potter2
Copy link
Author

@potter2 potter2 commented Oct 14, 2014

Actually Tom says the full build may be the problem in Ubuntu.

Gerald (Jerry) Potter
NASA Goddard Space Flight Center
E-mail gerald.potter@nasa.gov
Office 28:S241
Phone 707.315.8314
Analysis and Data Consultant
Department GSFC:606.2

From: Aashish Chaudhary <notifications@github.commailto:notifications@github.com>
Reply-To: UV-CDAT/uvcdat <reply@reply.github.commailto:reply@reply.github.com>
Date: Tuesday, October 14, 2014 at 11:58 AM
To: UV-CDAT/uvcdat <uvcdat@noreply.github.commailto:uvcdat@noreply.github.com>
Cc: Gerald Potter <gerald.potter@nasa.govmailto:gerald.potter@nasa.gov>
Subject: Re: [uvcdat] ubuntu animations aren't saved (#799)

@potter2https://github.com/potter2 what @dloniehttps://github.com/dlonie is going to fix is the ffmpeg not found in full build. The other reason for animation not working on ubutntu needs to be investigated by @ThomasMaxwellhttps://github.com/ThomasMaxwell.


Reply to this email directly or view it on GitHubhttps://github.com//issues/799#issuecomment-59097706.

@ThomasMaxwell
Copy link
Contributor

@ThomasMaxwell ThomasMaxwell commented Oct 14, 2014

Are the 2.0 binaries being distributed for the Linux platforms full builds?

@doutriaux1
Copy link
Contributor

@doutriaux1 doutriaux1 commented Oct 14, 2014

we have 2 kinds. FULL and default. I will try the default but I suspect the ffmpeg was the issue. Will confirm soon.

@aashish24
Copy link
Contributor

@aashish24 aashish24 commented Oct 14, 2014

So @potter2 tried default on CENTOS and full on Ubuntu?

@doutriaux1
Copy link
Contributor

@doutriaux1 doutriaux1 commented Oct 14, 2014

tests with me were FULL on CentOS and Ubuntu

@potter2
Copy link
Author

@potter2 potter2 commented Oct 14, 2014

Yes , CENTOS works and saves the animations.

Gerald (Jerry) Potter
NASA Goddard Space Flight Center
E-mail gerald.potter@nasa.gov
Office 28:S241
Phone 707.315.8314
Analysis and Data Consultant
Department GSFC:606.2

From: Aashish Chaudhary <notifications@github.commailto:notifications@github.com>
Reply-To: UV-CDAT/uvcdat <reply@reply.github.commailto:reply@reply.github.com>
Date: Tuesday, October 14, 2014 at 12:38 PM
To: UV-CDAT/uvcdat <uvcdat@noreply.github.commailto:uvcdat@noreply.github.com>
Cc: Gerald Potter <gerald.potter@nasa.govmailto:gerald.potter@nasa.gov>
Subject: Re: [uvcdat] ubuntu animations aren't saved (#799)

So @potter2https://github.com/potter2 tried default on CENTOS and full on Ubuntu?


Reply to this email directly or view it on GitHubhttps://github.com//issues/799#issuecomment-59103514.

@potter2
Copy link
Author

@potter2 potter2 commented Oct 14, 2014

I was using the binaries so I don’t know if the Ubuntu was full or not.

Gerald (Jerry) Potter
NASA Goddard Space Flight Center
E-mail gerald.potter@nasa.gov
Office 28:S241
Phone 707.315.8314
Analysis and Data Consultant
Department GSFC:606.2

From: Aashish Chaudhary <notifications@github.commailto:notifications@github.com>
Reply-To: UV-CDAT/uvcdat <reply@reply.github.commailto:reply@reply.github.com>
Date: Tuesday, October 14, 2014 at 12:38 PM
To: UV-CDAT/uvcdat <uvcdat@noreply.github.commailto:uvcdat@noreply.github.com>
Cc: Gerald Potter <gerald.potter@nasa.govmailto:gerald.potter@nasa.gov>
Subject: Re: [uvcdat] ubuntu animations aren't saved (#799)

So @potter2https://github.com/potter2 tried default on CENTOS and full on Ubuntu?


Reply to this email directly or view it on GitHubhttps://github.com//issues/799#issuecomment-59103514.

@doutriaux1
Copy link
Contributor

@doutriaux1 doutriaux1 commented Oct 14, 2014

since you were using the binaries I built, and I was using the FULL, it must have been the non full one. Which confirms our suspicions that it is related to FULL build.

@aashish24
Copy link
Contributor

@aashish24 aashish24 commented Oct 15, 2014

So binary for CENTOS is not build in ALL More?

@allisonvacanti
Copy link
Contributor

@allisonvacanti allisonvacanti commented Oct 15, 2014

Does a FULL build mean the same as CDAT_BUILD_MODE=ALL? I don't see anything in the CMake files about a FULL build.

@allisonvacanti
Copy link
Contributor

@allisonvacanti allisonvacanti commented Oct 15, 2014

#808 will enable FFMPEG.

@doutriaux1
Copy link
Contributor

@doutriaux1 doutriaux1 commented Oct 15, 2014

@dlonie yes it is the same

@doutriaux1
Copy link
Contributor

@doutriaux1 doutriaux1 commented Oct 15, 2014

@aashish24 we have both binaries for CentOS

@doutriaux1 doutriaux1 closed this Oct 15, 2014
@aashish24
Copy link
Contributor

@aashish24 aashish24 commented Oct 15, 2014

@doutriaux1 are you going to upload new binaries? If yes then are you going to use master or something else?

@aashish24 aashish24 reopened this Oct 15, 2014
@aashish24
Copy link
Contributor

@aashish24 aashish24 commented Oct 15, 2014

Let's keep it open till then

@doutriaux1
Copy link
Contributor

@doutriaux1 doutriaux1 commented Oct 15, 2014

@aashish24 I am not preparing any new binaries, we can't upload binaries for each bug fix! It is fixed, will be in 2.1 issue closed for now.

@doutriaux1 doutriaux1 closed this Oct 15, 2014
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
5 participants