Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

x264 fixes #1592

Merged
merged 6 commits into from Oct 7, 2015
Merged

x264 fixes #1592

merged 6 commits into from Oct 7, 2015

Conversation

@chaosphere2112
Copy link
Contributor

@chaosphere2112 chaosphere2112 commented Oct 6, 2015

Fixes a few bugs...
#1586

@doutriaux1's issue with expanding x264 on a newer CMake
@dnadeau4's issue with building x264 on his VM

set(X264_TIME 2245)
set(X264_ADDENDUM "-stable")
set(X264_ADDENDUM "")
set(X264_URL ${LLNL_URL})
set(X264_GZ x264-snapshot-${X264_DATE}-${X264_TIME}${X264_ADDENDUM}.tar.gz)
set(X264_MD5 43095e5d2ca331eec7f0fbed856e5bab)
Copy link
Contributor

@doutriaux1 doutriaux1 Oct 7, 2015

no new md5?

@doutriaux1
Copy link
Contributor

@doutriaux1 doutriaux1 commented Oct 7, 2015

@chaosphere2112 yep that's what I was suspecting you probably need to update the md5

dnadeau4
Copy link
Contributor

dnadeau4 commented on b1b9f90 Oct 7, 2015

I think that _DEPS needs to be lowercase _deps.

@chaosphere2112
Copy link
Contributor Author

@chaosphere2112 chaosphere2112 commented Oct 7, 2015

@doutriaux1 @dnadeau4 Sorry about that, just wanted to push the PR out before I went home for the day. Fixed both of those issues.

@@ -1 +1 @@
set(X264_DEPS "")
set(X264_deps ${pkgconfig_pkg})
Copy link
Contributor

@aashish24 aashish24 Oct 7, 2015

So X264_deps just depends on pkgconfig? Are there any other system specific libraries we need to document?

Copy link
Contributor Author

@chaosphere2112 chaosphere2112 Oct 7, 2015

Nope; in fact, it technically doesn't even depend on pkgconfig. It has a soft dependency on yasm, but that's already sort of a dependency for us (as part of the original x264 PR I did some stuff to make our build handle not having yasm installed).

Copy link
Contributor Author

@chaosphere2112 chaosphere2112 Oct 7, 2015

The reason it's "dependent" on pkgconfig is because it fixes a weird parallelism issue that @dnadeau4 was having (where the linker got confused as libx264 and pkgconfig built at the same time).

Copy link
Contributor

@aashish24 aashish24 Oct 7, 2015

thanks @chaosphere2112.care to add a note in the deps file so that someone know it next time?

@aashish24
Copy link
Contributor

@aashish24 aashish24 commented Oct 7, 2015

No problem @chaosphere2112 thanks for addressing our suggestions. Once cdash is happy, I will give it +2

@chaosphere2112
Copy link
Contributor Author

@chaosphere2112 chaosphere2112 commented Oct 7, 2015

@doutriaux1 Those have been stuck in queue an awfully long time... any idea on the status?

@doutriaux1
Copy link
Contributor

@doutriaux1 doutriaux1 commented Oct 7, 2015

I killed the server, I need to restart it.

doutriaux1 added a commit that referenced this issue Oct 7, 2015
@doutriaux1 doutriaux1 merged commit b5f07e8 into master Oct 7, 2015
3 of 9 checks passed
@doutriaux1 doutriaux1 deleted the x264_fixes branch Oct 7, 2015
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Linked issues

Successfully merging this pull request may close these issues.

None yet

4 participants