New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

mac python 3 seems broken #184

Closed
doutriaux1 opened this Issue Oct 25, 2017 · 3 comments

Comments

Projects
None yet
2 participants
@doutriaux1
Member

doutriaux1 commented Oct 25, 2017

see: #183

The original circleci was requesting emsf/esmpy which would somehow force python back down to 27.

I can reproduce the issue on my mac

@doutriaux1 doutriaux1 added this to the 3.0 milestone Oct 25, 2017

@dnadeau4

This comment has been minimized.

Contributor

dnadeau4 commented Oct 25, 2017

I look at it and I don't understand. It is taking esmf from my channel on the MAC and Linux for Python3.

conda install -n py3 -c nadeau1 esmf esmpy
my esmf is no longer working?
  - esmf -> mpich
  - esmf -> netcdf-fortran 4.4.*
  - esmpy -> esmf ==7.1.0.dev34 -> mpich
  - esmpy -> esmf ==7.1.0.dev34 -> netcdf-fortran 4.4.*
@doutriaux1

This comment has been minimized.

Member

doutriaux1 commented Oct 26, 2017

look at the line above

# Create Python 3 environment
cmd="conda create -n py3 -c uvcdat/label/nightly -c conda-forge -c uvcdat libcf distarray cdtime libcdms cdat_info numpy esmf esmpy libdrs_f pyopenssl nose requests flake8 myproxyclient"

you were bringing in esmf/esmpy and that was forcing to downgrade python to version 2

@dnadeau4

This comment has been minimized.

Contributor

dnadeau4 commented Nov 15, 2017

@dnadeau4 dnadeau4 closed this Nov 15, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment