Skip to content

Supported PHP Versions

Andy Theuninck edited this page May 6, 2016 · 4 revisions

CORE currently supports PHP version 5.5. Earlier versions may still work outside of specific tools or features but such versions are considered unsupported.

What does "unsupported" mean?

Unsupported means issues stemming from using an older version of PHP will not be fixed upstream. Advice on potential workarounds may be offered but in most cases upgrading to a modern version of PHP is a better path.

What's most likely to break?

Currently anything less than PHP 5.3 will fail catastrophically for lack of namespace support. Starting in version 2.1 CORE may include libraries from composer that require PHP 5.5 or higher. These libraries are still largely optional; the system won't fail without them but some more obscure features won't work correctly. Short array syntax is one of the biggest compatibility problems so using at least PHP 5.4 may be sufficient to smooth over some problems.

Is PHP 7 supported?

Probably. If you're upgrading an existing system make sure you've fully converted configurations to use mysqli or PDO.

What if my system doesn't include a supported version?

One option is to upgrade your system. Among the major players:

  • Ubuntu 14.04 LTS includes PHP 5.5.9
  • Ubuntu 16.04 LTS includes PHP 7.0.4
  • Debian 8 (Jessie) includes PHP 5.6.20
  • RHEL & CentOS 7 only provide PHP 5.4; 3rd party repos may be required

3rd party repos with newer versions are often an option for other, older mainstream distro releases.

Alternately, you can build PHP from source. A config56.nice script is included in the scripts directory. This requires installing a compiler toolchain and the relevant -dev or -devel packages. If you're comfortable with the standard ./configure, make, make install process it's not a particularly difficult from-scratch build.

Why not support earlier versions?

PHP 5.5 is the oldest version that's actively supported by the PHP project itself. While there are some distros that backport security fixes, there are also now LTS oriented releases that include PHP 5.5 or higher. The larger PHP community is moving on - for example, the minimum for Drupal, Symfony, and Laravel is all now 5.5.9 - and that includes the ecosystem of library packages. There's never a perfect time to change a requirement, but PHP 5.5 has been out long enough that it's not that much of a hurdle. For any remotely popular system the solution is probably just a google query away.

Clone this wiki locally
You can’t perform that action at this time.