Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Newer
Older
100644 28 lines (15 sloc) 0.976 kB
1f7739f @monken moar code
monken authored
1 =head1 GETTING STARTED
2
67ba536 @richardjharris Explain how to install project dependencies in README.
richardjharris authored
3 Install Dist::Zilla using your preferred CPAN client:
4
5 $ cpanm Dist::Zilla
6
7 Install the project dependencies:
8
06c39b0 @oalders Updates install instructions in README
oalders authored
9 $ dzil listdeps --missing | cpanm
67ba536 @richardjharris Explain how to install project dependencies in README.
richardjharris authored
10
b528f27 @monken cleaned up readme
monken authored
11 Start server on port 5001 (which you want to make authentication work)
0061207 @monken tmtt
monken authored
12
b528f27 @monken cleaned up readme
monken authored
13 $ plackup -p 5001 -r
c342194 @monken made api url configurable
monken authored
14
f78c6c3 @monken fixed api links
monken authored
15 The backend defaults to C<api.metacpan.org>. Running a local API server is optional and not required to hack on the front-end.
11d281d @monken fixed startup docs
monken authored
16 The address to the API user can be changed in the metacpan_web.conf file.
17 Ideally you would create a new file called C<metacpan_web_local.conf> that contains
c342194 @monken made api url configurable
monken authored
18
6d30e26 @monken fixed api and secure_api url (need to include uri scheme)
monken authored
19 api http://127.0.0.1:5000
20 api_secure http://127.0.0.1:5000
c342194 @monken made api url configurable
monken authored
21
11d281d @monken fixed startup docs
monken authored
22 which will be loaded on top of the existing config file.
23
c7e3685 @wchristian explain why the plackup server throws warnings on older perls
wchristian authored
24
25 =head1 COMPATIBILITY NOTES
26
27 On Win32 (and possibly also on other platforms) when using Perl < 5.12, the server started with plackup will generate warnings relating to date parsing. These are caused by Plack due to a bug in the gmtime implementation and can be removed by upgrading to Perl 5.12.
Something went wrong with that request. Please try again.