Skip to content

Looking up Template toolkit is returned information from another dist #468

Closed
neilb opened this Issue Feb 12, 2012 · 4 comments

4 participants

@neilb
neilb commented Feb 12, 2012

Looking up Template results in information CGI-Application-Structured-Tools-0.015

For example, if you look at https://metacpan.org/module/Template, you'll see information not about the Template toolkit, even though doing a search for "Template" on metacpan gives a link to the Template I expected to see.

And if you look at https://api.metacpan.org/module/Template, that information is clearly from the wrong dist.

@rwstauner
MetaCPAN member

This is new... I'm quite certain "Template" used to work correctly.

https://metacpan.org/source/VANAMBURG/CGI-Application-Structured-Tools-0.015/lib/CGI/Application/Structured/Tools/templates/config-dev.pl
has this pod which must be tripping up the parser/indexer:

=head1 NAME

Template development config file for CGI::Application::Structured apps.

* Modify dsn, user and password for your database.
* run script/create_dbic_schema.pl from your project root to generate
  DBIC schema.  (Rerun after every change to database).

=cut
@dpetrov
dpetrov commented Feb 25, 2012

Actually it seems to be working right now

@rwstauner
MetaCPAN member

@dpetrov: @monken ran the authorized script recently and that probably fixed it

@monken
MetaCPAN member
monken commented Feb 28, 2012

Yep, the authorized bit is now set after each upload. This should resolve this issue once and for all :)

@monken monken closed this Feb 28, 2012
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.