Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Code fix for Joomla 3.0 to get it working in 3.0 #2

Open
designlink opened this Issue · 2 comments

2 participants

designlink Ken Adam
designlink

I'm not sure if I'm posting in the right place for this, but wanted to post it in case it helps anyone, including anyone coding this for Joomla 3.0:

I successfully installed it on Joomla 2.5 and it works great. So I decided to try it out on a Joomla 3.0 site that I didn't care if it broke, just to see if it happenned to work. It didn't, which wasn't surprising. I know there are a lot of changes in Joomla that should be done correctly before using an extension in 3.0, but I really needed this to work in 3.0 right now and I don't care if it screws anything else up or doesn't work flawlessly. With that said, take everything I did to fix it to get it working in 3.0 with a grain of salt...

Here are the errors I got and what I did about them:

1)

Warning: require_once(/xxxxxxx/modules/mod_anythingsliderDShelper.php) [function.require-once]: failed to open stream: No such file or directory in /xxxxxxx/modules/mod_anythingslider/mod_anythingslider.php on line 29

Fatal error: require_once() [function.require]: Failed opening required '/xxxxxxxxxx/modules/mod_anythingsliderDShelper.php' (include_path='.:/opt/php53/lib/php') in /xxxxxxxxx/modules/mod_anythingslider/mod_anythingslider.php on line 29

In the file modules/mod_anythingslider/helper.php, add:

    if(!defined('DS')){
            define('DS',DIRECTORY_SEPARATOR);
    }

above

    // include the helper file
    require_once(dirname(__FILE__).DS.'helper.php');

This is a change in Joomla 3.0.

2)

Fatal error: Call to undefined method JDate::toMySQL() in /xxxxxxxxxx/modules/mod_anythingslider/helper.php on line 44

In the file modules/mod_anythingslider/helper.php on line 44, change:

    $now = $date->toMySQL(); 

    to

    $now = $date->toSQL(); 

"toMySQL" is depreciated in Jooml 3.0 to "toSQL"

And some of the features apparently stopped working, such as the "expand" in the backend of Joomla, which in my case was causing it not to work correctly in Chrome (works in all other browsers). I went through and made a few of the very small changes in Joomla 3.0 such as code description changes, and somewhere one of them worked and made all of the backend functionality work again. I didn't take notes on what I did unfortunately.

Hope that helps anyone at all, I'm glad to se it working in Joomla 3.0, it's such an awesome creation and I love the way it works in Joomla! So thanks to all who have helped build it!

Ken Adam
Owner

Thanks for reporting - I've only recently set up my first Joomla! 3 site and had not yet tried this mod on it.
I'll investigate the issues and get an update out as soon as I can.
If you'd like to send me your modified files, I'll compare them with the orignal to see what else you changed.
Updates:
DS - Seems this has been deprecated for a while and then removed as PHP now handles the separators correctly, I had missed that.
toMySQL - likewise

Ken Adam
Owner

I tested the interim version 1.4.2a (DS and toMySQL fixes) with Joomla! 3.0.3 using Chrome
[Version 25.0.1364.172 m] and the back end accordian expands as expected.
Updated to [Version 26.0.1410.43 m] and is still working.
I'd appreciate any more information about the problem you found

Ken Adam Akadamia was assigned
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.