Permalink
Browse files

HydroDesktop 1.7.3

  • Loading branch information...
jacobean
jacobean committed Nov 25, 2014
1 parent 3cdeb67 commit 62cab4cb2fd1263ef2d8d7a748c252a5342013bc
@@ -10,8 +10,8 @@
;; define some version parameters
;; from http://stackoverflow.com/questions/357803/automated-build-version-number-with-wix-inno-setup-and-vs2008
;; or maybe http://agiletracksoftware.com/blog.html?id=4
#define AppName "HydroDesktop 1.7.2"
#define SrcApp "HydroDesktop_1_7_2.exe"
#define AppName "HydroDesktop 1.7.3"
#define SrcApp "HydroDesktop_1_7_3.exe"
#define FileVerStr GetFileVersion(SrcApp)
;#define StripBuild(str VerStr) Copy(VerStr, 1, RPos(".", VerStr)-1)
#define StripBuild(VerStr) Copy(VerStr, 1, RPos(".", VerStr)-1)
@@ -37,7 +37,7 @@
; NOTE: The value of AppId uniquely identifies this application.
; Do not use the same AppId value in installers for other applications.
; (To generate a new GUID, click Tools | Generate GUID inside the IDE.)
AppID={{DED92382-70DE-4917-9956-431324047ABD}
AppID={{52A4C3C0-3B01-4455-B3DF-CE7BCADCB714}
PrivilegesRequired=poweruser
MinVersion=,5.01
@@ -111,7 +111,7 @@ Source: "..\Binaries\HydroDesktop_1_6_dev.exe.config"; DestDir: "{app}"; DestNam
;Plugins
Source: "..\Binaries\Plugins\*"; DestDir: "{commonappdata}\{#SrcApp}\Extensions\Packages"; Flags: recursesubdirs ignoreversion;
Source: "..\Source\packages\DotSpatial.Plugins.ExtensionManager.1.1.1\*"; DestDir: "{commonappdata}\{#SrcApp}\Extensions\Packages\DotSpatial.Plugins.ExtensionManager.1.1.1"; Flags: recursesubdirs ignoreversion;
Source: "..\Source\packages\DotSpatial.Plugins.ExtensionManager.1.1.4\*"; DestDir: "{commonappdata}\{#SrcApp}\Extensions\Packages\DotSpatial.Plugins.ExtensionManager.1.1.4"; Flags: recursesubdirs ignoreversion;
Source: "..\Source\packages\DotSpatial.Plugins.MenuBar.1.0.1200\*"; DestDir: "{commonappdata}\{#SrcApp}\Extensions\Packages\DotSpatial.Plugins.MenuBar.1.0.1200"; Flags: recursesubdirs ignoreversion;
Source: "..\Source\packages\DotSpatial.Plugins.Ribbon.1.4.38\*"; DestDir: "{commonappdata}\{#SrcApp}\Extensions\Packages\DotSpatial.Plugins.Ribbon.1.4.38"; Flags: recursesubdirs ignoreversion;
Source: "..\Source\packages\DotSpatial.Plugins.WebMap.1.1.0.0\*"; DestDir: "{commonappdata}\{#SrcApp}\Extensions\Packages\DotSpatial.Plugins.WebMap.1.1.0.0"; Flags: recursesubdirs ignoreversion;
@@ -151,6 +151,7 @@ Type: filesandordirs; Name: "{commonappdata}\{#SrcApp}"
[Dirs]
Name: {app}; Permissions: everyone-modify; Flags: uninsalwaysuninstall
Name: {app}\Maps; Permissions: everyone-modify; Flags: uninsalwaysuninstall
Name: {commonappdata}\{#SrcApp}; Permissions: everyone-full; Flags: uninsalwaysuninstall
; not yet capable of moving stuff outside of the HD folder reliably
;Name: {userdocs}\HydroDesktop\default; Permissions: everyone-modify
@@ -91,8 +91,7 @@
<Private>False</Private>
</Reference>
<Reference Include="DotSpatial.Plugins.ExtensionManager">
<HintPath>..\..\packages\DotSpatial.Plugins.ExtensionManager.1.1.1\lib\net40-Client\DotSpatial.Plugins.ExtensionManager.dll</HintPath>
<Private>False</Private>
<HintPath>..\..\packages\DotSpatial.Plugins.ExtensionManager.1.1.4\lib\net40-Client\DotSpatial.Plugins.ExtensionManager.dll</HintPath>
</Reference>
<Reference Include="DotSpatial.Projections">
<HintPath>..\..\packages\DotSpatial.Projections.1.6.1\lib\net40-Client\DotSpatial.Projections.dll</HintPath>
@@ -120,7 +119,7 @@
</Reference>
<Reference Include="NuGet.Core, Version=2.0.0.0, Culture=neutral, processorArchitecture=MSIL">
<SpecificVersion>False</SpecificVersion>
<HintPath>..\..\packages\DotSpatial.Plugins.ExtensionManager.1.1.1\lib\net40-Client\NuGet.Core.dll</HintPath>
<HintPath>..\..\packages\DotSpatial.Plugins.ExtensionManager.1.1.4\lib\net40-Client\NuGet.Core.dll</HintPath>
</Reference>
<Reference Include="System" />
<Reference Include="System.ComponentModel.Composition" />
@@ -131,7 +130,7 @@
<Reference Include="System.Data" />
<Reference Include="System.Xml" />
<Reference Include="Updater">
<HintPath>..\..\packages\DotSpatial.Plugins.ExtensionManager.1.1.1\lib\net40-Client\Updater.exe</HintPath>
<HintPath>..\..\packages\DotSpatial.Plugins.ExtensionManager.1.1.4\lib\net40-Client\Updater.exe</HintPath>
</Reference>
</ItemGroup>
<ItemGroup>
@@ -6,7 +6,7 @@
<package id="DotSpatial.Extensions" version="1.6.1" targetFramework="net40-Client" />
<package id="DotSpatial.Modeling.Forms" version="1.6.1" targetFramework="net40-Client" />
<package id="DotSpatial.Mono" version="1.6.1" targetFramework="net40-Client" />
<package id="DotSpatial.Plugins.ExtensionManager" version="1.1.1" targetFramework="net40-Client" />
<package id="DotSpatial.Plugins.ExtensionManager" version="1.1.4" targetFramework="net40-Client" />
<package id="DotSpatial.Projections" version="1.6.1" targetFramework="net40-Client" />
<package id="DotSpatial.Projections.Forms" version="1.6.1" targetFramework="net40-Client" />
<package id="DotSpatial.Serialization" version="1.6.1" targetFramework="net40-Client" />
@@ -94,7 +94,7 @@
<Private>False</Private>
</Reference>
<Reference Include="DotSpatial.Plugins.ExtensionManager">
<HintPath>..\..\packages\DotSpatial.Plugins.ExtensionManager.1.1.1\lib\net40-Client\DotSpatial.Plugins.ExtensionManager.dll</HintPath>
<HintPath>..\..\packages\DotSpatial.Plugins.ExtensionManager.1.1.4\lib\net40-Client\DotSpatial.Plugins.ExtensionManager.dll</HintPath>
</Reference>
<Reference Include="DotSpatial.Plugins.MenuBar, Version=0.11.9.6, Culture=neutral, processorArchitecture=MSIL">
<SpecificVersion>False</SpecificVersion>
@@ -130,7 +130,7 @@
</Reference>
<Reference Include="NuGet.Core, Version=2.0.0.0, Culture=neutral, processorArchitecture=MSIL">
<SpecificVersion>False</SpecificVersion>
<HintPath>..\..\packages\DotSpatial.Plugins.ExtensionManager.1.1.1\lib\net40-Client\NuGet.Core.dll</HintPath>
<HintPath>..\..\packages\DotSpatial.Plugins.ExtensionManager.1.1.4\lib\net40-Client\NuGet.Core.dll</HintPath>
</Reference>
<Reference Include="System" />
<Reference Include="System.Core" />
@@ -143,7 +143,7 @@
<Reference Include="System.Data" />
<Reference Include="System.Xml" />
<Reference Include="Updater">
<HintPath>..\..\packages\DotSpatial.Plugins.ExtensionManager.1.1.1\lib\net40-Client\Updater.exe</HintPath>
<HintPath>..\..\packages\DotSpatial.Plugins.ExtensionManager.1.1.4\lib\net40-Client\Updater.exe</HintPath>
</Reference>
</ItemGroup>
<ItemGroup>
@@ -6,7 +6,7 @@
<package id="DotSpatial.Extensions" version="1.6.1" targetFramework="net40-Client" />
<package id="DotSpatial.Modeling.Forms" version="1.6.1" targetFramework="net40-Client" />
<package id="DotSpatial.Mono" version="1.6.1" targetFramework="net40-Client" />
<package id="DotSpatial.Plugins.ExtensionManager" version="1.1.1" targetFramework="net40-Client" />
<package id="DotSpatial.Plugins.ExtensionManager" version="1.1.4" targetFramework="net40-Client" />
<package id="DotSpatial.Plugins.MenuBar" version="1.0.1200" targetFramework="net40-Client" />
<package id="DotSpatial.Plugins.WebMap" version="1.1.0.0" targetFramework="net40-Client" />
<package id="DotSpatial.Projections" version="1.6.1" targetFramework="net40-Client" />

0 comments on commit 62cab4c

Please sign in to comment.