New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Can we lower the Cython dependency? #3

Closed
bochecha opened this Issue Sep 29, 2013 · 1 comment

Comments

Projects
None yet
1 participant
@bochecha
Member

bochecha commented Sep 29, 2013

Now that we are based on libcangjie2, which is written in C, we might not need Cython >= 0.17 any more.

We should try building pycangjie with an older Cython (for example, on Ubuntu 12.04 which has 0.14 if I recall correctly), and if that works, lower the minimum version in the configure.ac.

Chwing pushed a commit to Chwing/pycangjie that referenced this issue Oct 2, 2013

jeremy-fouriaux
Downgrade version requirement of cython to 0.14
Cython default version on Ubuntu 12.04 is 0.14, in order to support this
version we needed to remove const attribute on signature in _code.pyx
and _code.pyd, because it was not supported.

This fixes issue Cangjians#3
@bochecha

This comment has been minimized.

Show comment
Hide comment
@bochecha

bochecha Oct 2, 2013

Member

@Chwing fixed this!

Member

bochecha commented Oct 2, 2013

@Chwing fixed this!

@bochecha bochecha closed this Oct 2, 2013

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment