Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

No obvious error when Hyper-V is not enabled on the host #921

Closed
nobuto-m opened this issue Jul 18, 2019 · 1 comment

Comments

@nobuto-m
Copy link

commented Jul 18, 2019

Windows Pro has Hyper-V disabled out of the box, and it has to be enabled explicitly. At this moment, multipass launch on Windows fails with timeout and doesn't tell us what's wrong.

It would be nice if multipass tells us Hyper-V is not enabled and point us to some documents like the following link from a user experience point of view.
https://docs.microsoft.com/en-us/virtualization/hyper-v-on-windows/quick-start/enable-hyper-v

@Saviq

This comment has been minimized.

Copy link
Collaborator

commented Jul 18, 2019

Yes, totally. We're planning in #775 to implement extensive "health" checks for exactly this reason.

Before, we were just enabling Hyper-V ourselves (and checking your Windows version is enough), but now we've added VirtualBox support that wasn't an option any more.

@Saviq Saviq added the enhancement label Jul 18, 2019

@Saviq Saviq added this to To do in v0.9.0 via automation Jul 18, 2019

@Saviq Saviq added this to To do in 19.10 cycle via automation Jul 18, 2019

@townsend2010 townsend2010 self-assigned this Aug 1, 2019

@Saviq Saviq moved this from To do to In progress in v0.9.0 Aug 2, 2019

@Saviq Saviq closed this Sep 9, 2019

19.10 cycle automation moved this from To do to Done Sep 9, 2019

v0.9.0 automation moved this from In progress to Done Sep 9, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
3 participants
You can’t perform that action at this time.