Permalink
Browse files

Stop supporting Active Record 3.0

  • Loading branch information...
1 parent 6a47270 commit 3f2a8c36655d5d1b3bc7c95074b8b3dea92cc0bd @nertzy nertzy committed Apr 2, 2013
Showing with 19 additions and 10 deletions.
  1. +0 −1 .travis.yml
  2. +17 −7 README.rdoc
  3. +2 −2 pg_search.gemspec
View
1 .travis.yml
@@ -14,7 +14,6 @@ env:
- ACTIVE_RECORD_VERSION="~> 4.0.0.beta1"
- ACTIVE_RECORD_VERSION="~> 3.2.0"
- ACTIVE_RECORD_VERSION="~> 3.1.0"
- - ACTIVE_RECORD_VERSION="~> 3.0.0"
matrix:
allow_failures:
View
24 README.rdoc
@@ -13,20 +13,36 @@ PgSearch builds named scopes that take advantage of PostgreSQL's full text searc
Read the blog post introducing PgSearch at http://pivotallabs.com/pg-search/
+== REQUIREMENTS
+
+* ActiveRecord 3.1 or later
+* PostgreSQL
+* {PostgreSQL contrib packages for certain features}[https://github.com/Casecommons/pg_search/wiki/Installing-Postgres-Contrib-Modules]
+
== INSTALL
gem install pg_search
-=== Rails 3
+=== Rails 3.1 or later
In Gemfile
gem 'pg_search'
+=== Rails 3.0
+
+The newest versions of PgSearch no longer support Rails 3.0. However, the 0.5 series still works. It's not actively maintained, but submissions are welcome for backports and bugfixes.
+
+ gem 'pg_search', "~> 0.5.7"
+
+The 0.5 branch lives at https://github.com/Casecommons/pg_search/tree/0.2-stable
+
=== Rails 2
The newest versions of PgSearch no longer support Rails 2. However, the 0.2 series still works. It's not actively maintained, but submissions are welcome for backports and bugfixes.
+ gem 'pg_search', "~> 0.2.0"
+
The 0.2 branch lives at https://github.com/Casecommons/pg_search/tree/0.2-stable
=== Other ActiveRecord-based projects
@@ -581,12 +597,6 @@ To use this functionality you'll need to do a few things:
Please note that the :against column is only used when the tsvector_column is not present for the search type.
-== REQUIREMENTS
-
-* ActiveRecord 3
-* PostgreSQL
-* {PostgreSQL contrib packages for certain features}[https://github.com/Casecommons/pg_search/wiki/Installing-Postgres-Contrib-Modules]
-
== ATTRIBUTIONS
PgSearch would not have been possible without inspiration from
View
4 pg_search.gemspec
@@ -18,6 +18,6 @@ Gem::Specification.new do |s|
s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
s.require_paths = ["lib"]
- s.add_dependency 'activerecord', '>=3'
- s.add_dependency 'activesupport', '>=3'
+ s.add_dependency 'activerecord', '>=3.1'
+ s.add_dependency 'activesupport', '>=3.1'
end

0 comments on commit 3f2a8c3

Please sign in to comment.