Permalink
Browse files

Stop checking for ActiveRecord::Relation

We only support Active Record 3.1 or higher, so no need for this check
anymore.
  • Loading branch information...
nertzy committed Apr 2, 2013
1 parent 0d9eae3 commit e8d767800b3b784b87dea1a7d8f4e1a0a2f62ec3
Showing with 0 additions and 4 deletions.
  1. +0 −4 lib/pg_search/configuration.rb
@@ -96,10 +96,6 @@ def assert_valid_options(options)
raise ArgumentError, "the search scope #{@name} must have :against#{" or :associated_against" if defined?(ActiveRecord::Relation)} in its options"
end
- if options[:associated_against] && !defined?(ActiveRecord::Relation)
- raise ArgumentError, ":associated_against requires Active Record 3 or later"
- end
-
options.assert_valid_keys(VALID_KEYS)
VALID_VALUES.each do |key, values_for_key|

0 comments on commit e8d7678

Please sign in to comment.