Skip to content
Permalink
Browse files

Make all Pi boards compatible

  • Loading branch information...
NEMS Linux
NEMS Linux committed Feb 22, 2019
1 parent 9388537 commit c62309e03094bc8bf843bc5c6ea57f3c63342441
Showing with 5 additions and 9 deletions.
  1. +2 −4 build/160-raspi-config
  2. +1 −1 build/160-rpi-piwatcher
  3. +2 −4 build/160-rpimonitor
@@ -1,12 +1,10 @@
#!/bin/bash

printf "Installing raspi-config... "
platform=$(/usr/local/share/nems/nems-scripts/info.sh platform) # This is why we have to do this after 150-nems

if [[ $platform = "0" ]] || [[ $platform = "1" ]] || [[ $platform = "2" ]] || [[ $platform = "3" ]]; then
if [[ $platform < 10 ]]; then
echo "Installing raspi-config... "
apt update
apt -y install raspi-config
echo "Done."
else
echo "This is not a Pi, skipping."
fi
@@ -2,7 +2,7 @@

platform=$(/usr/local/bin/nems-info platform)

if [[ $platform = "0" ]] || [[ $platform = "1" ]] || [[ $platform = "2" ]] || [[ $platform = "3" ]]; then
if [[ $platform < 10 ]]; then
printf "Installing support for PiWatcher hardware... "
cd /tmp
git clone https://github.com/omzlo/piwatcher/
@@ -1,9 +1,9 @@
#!/bin/bash

printf "Installing rpimonitor... "
platform=$(/usr/local/share/nems/nems-scripts/info.sh platform) # This is why we have to do this after 150-nems

if [[ $platform = "0" ]] || [[ $platform = "1" ]] || [[ $platform = "2" ]] || [[ $platform = "3" ]]; then
if [[ $platform < 10 ]]; then
echo "Installing rpimonitor... "
apt update
apt -y install dirmngr libraspberrypi-bin
echo "deb http://giteduberger.fr rpimonitor/" > /etc/apt/sources.list.d/rpimonitor.list
@@ -17,6 +17,4 @@ if [[ $platform = "0" ]] || [[ $platform = "1" ]] || [[ $platform = "2" ]] || [[
cp -f /root/nems/nems-migrator/data/1.4/rpimonitor/template/* /etc/rpimonitor/template/
systemctl start rpimonitor
echo "Done."
else
echo "This is not a Pi, skipping."
fi

0 comments on commit c62309e

Please sign in to comment.
You can’t perform that action at this time.