Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

FLAT Crashes During Sound Initialisation on Arch Linux #32

Closed
Cheeseness opened this issue Aug 2, 2012 · 2 comments
Closed

FLAT Crashes During Sound Initialisation on Arch Linux #32

Cheeseness opened this issue Aug 2, 2012 · 2 comments
Labels

Comments

@Cheeseness
Copy link
Owner

Cheeseness commented Aug 2, 2012

Some Arch users have reported that the game was quitting at launch.

After some discussion in this thread, we have identified the issue as being related to which audio driver Allegro automatically selects (a possible upstream bug or an issue with the drivers included in some Arch versions). This was identified and a workaround discovered in this thread:
http://forum.freegamedev.net/viewtopic.php?f=20&t=3332

Create a file called allegro5.cfg in the same folder as the FLAT binary, and add the following lines:

[audio]
driver=alsa

@marcusmoller
Copy link
Contributor

marcusmoller commented May 12, 2013

This bug seems to be fixed upstream. I am able to compile and run the game without the configuration file on Arch x64.

Another user reported that he was able to do the same. We probably just need it confirmed by a x86 user.

@Cheeseness
Copy link
Owner Author

Cheeseness commented May 12, 2013

The original reporter of this bug has confirmed that it now works for them. I'm happy to close this (but also happy to have it re-opened if anybody else finds they're still effected by it).

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
Projects
None yet
Development

No branches or pull requests

2 participants