Error compiling on Windows 7 64-bit #129

Closed
alsoicode opened this Issue Jul 27, 2012 · 7 comments

Projects

None yet

8 participants

@alsoicode

Hello,

I have Erlang, MinGW and Git installed and on my PATH. When running windows-make.bat in my ChicagoBoss source directory cloned from Git, I get the following error:

C:\Users\brandon\source\ChicagoBoss>windows-make.bat
==> aleppo (get-deps)
==> bson (get-deps)
==> epgsql (get-deps)
==> gen_server2 (get-deps)
==> erlmc (get-deps)
==> medici (get-deps)
==> mongodb (get-deps)
==> mysql (get-deps)
==> poolboy (get-deps)
==> protobuffs (get-deps)
==> riakc (get-deps)
==> boss_db (get-deps)
==> erlydtl (get-deps)
==> gen_smtp (get-deps)
==> misultin (get-deps)
==> mochiweb (get-deps)
==> proper (get-deps)
==> proper_stdlib (get-deps)
==> mimetypes (get-deps)
==> simple_bridge (get-deps)
==> cowboy (get-deps)
==> mochicow (get-deps)
==> ChicagoBoss (get-deps)
==> aleppo (compile)
==> bson (compile)
==> epgsql (compile)
==> gen_server2 (compile)
==> erlmc (compile)
==> medici (compile)
==> mongodb (compile)
==> mysql (compile)
==> poolboy (compile)
==> protobuffs (compile)
==> riakc (compile)
==> boss_db (compile)
==> erlydtl (compile)
==> gen_smtp (compile)
==> misultin (compile)
==> mochiweb (compile)
==> proper (compile)
'make' is not recognized as an internal or external command,
operable program or batch file.
ERROR: Command [compile] failed!

Here's what I get from the MinGW shell: http://iambrandontaylor.com/static/images/mingw-make-errors.PNG

What am I doing wrong?

Thank you,
Brandon

@developerworks

Other errors is on winxp,erlang 5.9.1/15B01:

=INFO REPORT==== 3-Aug-2012::17:47:44 ===
    application: mimetypes
    exited: {shutdown,{mimetypes_app,start,[normal,[]]}}
    type: temporary
escript: exception error: no match of right hand side value
                 {error,{shutdown,{mimetypes_app,start,[normal,[]]}}}
ERROR: Command [compile] failed!
@purelander09

This also happens on Windows 7 64-bit using Erlang 5.9.1/15B01

@reterVision

I also have this issue on my machine which is also Windows 7 64-bit using Erlang 5.9.1/15B01.

@timClicks
Contributor

This appears to be a known issue with the mimetypes application: spawngrid/mimetypes#10

@rambocoder
Contributor

Is this issue fixed now and can be close spawngrid/mimetypes#16 due to that pull request on mimetypes repo?

@zkessin
Contributor
zkessin commented Jan 22, 2014

For now we are not going to support building on windows

@zkessin zkessin closed this Jan 22, 2014
@leeyisoft

我也在64位 win7 下面不能够 生成应用;在centos7.0下面都ok,求解决办法

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment