Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Test from quickstart does not work #237

Closed
aleksandr-vin opened this Issue · 3 comments

3 participants

@aleksandr-vin

Managed to make a functional test from quickstart and got this:


aleksandrvin@unha:~/hamster/zealousface$ ./rebar boss c=test_functional
==> zealousface (boss)

=INFO REPORT==== 4-Apr-2013::16:54:29 ===
Loading routes from "../zealousface/priv/zealousface.routes" ....Found tests: ["zealousface_test"]

Running: "zealousface_test"
Root test 2 failed

  • "No tag containing \"Zealousface stares at you!\""</li> <li>"HTTP Status not 200 OK" Last response: {404,"/greeting/hello", [{"Content-Type","text/html"}], {<<"html">>,[], [<<"The requested template (\"src/view/greeting/hello.{dtl,html,txt,jade,eex}\") was not found. Additionally, no handler was found for processing 404 errors. You probably want to modify ../zealousface/priv/zealousface.routes to prevent errors like this one.">>]}}</li> </ul> <p>Database: []</p> <h1></h1> <p>Passed: 0<br> Failed: 2<br> aleksandrvin@unha:~/hamster/zealousface$</p> <hr> <p>While requesting that url on a dev/production server I got right reply.</p> <p>ChicagoBoss v.8.5.0<br> Ubuntu quantal (12.10)<br> Linux unha 3.5.0-17-generic #28-Ubuntu SMP Tue Oct 9 19:31:23 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux</p>
@evanmiller
Owner

Try this

eed3461

@rambocoder

@evanmiller I can confirm that your fix solved the problem. Do you want to close the issue?

@evanmiller
Owner

Let's do it

@evanmiller evanmiller closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.