Skip to content
Permalink
Branch: master
Find file Copy path
Fetching contributors…
Cannot retrieve contributors at this time
146 lines (87 sloc) 4.04 KB

Mirakurun ChangeLog

see Commit Logs to check all.

2.10.0 (2019-03-21)

Server Changes

  • status: add more property for diagnostics.

2.9.0 (2019-03-14)

  • package: Activating Open Collective #45

Server Changes

  • db: improve error handling. #48
  • db: added integrity check. #35
  • tuner: fix EPIPE error occurred by decoder.kill #46
  • tuner-device: fix duplicate function call of _kill() #47

Dependencies

  • opencollective: ^1.0.3
  • opencollective-postinstall: ^2.0.1
  • dotenv: ^6.2.0^7.0.0
  • swagger-ui-dist: ^3.20.5^3.21.0
  • js-yaml: ^3.12.1^3.12.2
  • sift: 5.1.0^7.0.1
  • tail: ^1.4.0^2.0.2

2.8.4 (2019-01-30)

Server Changes

  • api: [Channel Scan API] support sort by non-integer channel string. #42

Dependencies

  • dotenv: ^6.1.0^6.2.0
  • express-openapi: ^3.6.0^3.7.0
  • js-yaml: ^3.12.0^3.12.1

2.8.3 (2019-01-15)

Server Changes

  • updater: fix update failure. (please note: this fixes effective for later than this version.)

2.8.2 (2019-01-15)

  • install: fix wrong expression to detect global install.

2.8.1 (2019-01-14)

Server Changes

Dependencies

  • swagger-ui-dist: ^3.20.5
  • swagger-ui: (removed)

2.8.0 (2019-01-03)

  • use --unsafe-perm instead of --unsafe.

Server Changes

  • node: change --max_old_space_size=256 to --max_old_space_size=512.
  • log: env LOG_STDOUT, LOG_STDERR are not used anymore.
  • install: add way to install not using --unsafe-perm.
  • cli: add init command to init as service manually.

2.7.7 (2019-01-03)

Server Changes

  • log: fix comply http logs to log level setting. #41

2.7.6 (2019-01-02)

Server Changes

  • install: fix missing colors dependency.

Dependencies

  • colors: ^1.3.3

2.7.5 (2018-12-25)

Server Changes

  • security: allow referrer from localhost.
  • epg: fix garbled parsing in extended description. #26 #40

Dependencies

  • body-parser: ^1.17.1^1.18.3
  • express-openapi: ^3.0.3^3.6.0
  • js-yaml: ^3.8.4^3.12.0
  • morgan: ^1.7.0^1.9.1
  • semver: ^5.3.0^5.6.0
  • tail: ^1.2.1^1.4.1

2.7.4 (2018-11-02)

Server Changes

  • epg: fix crash on epg gathering.

Dependencies

  • aribts: 1.3.3^1.3.4

2.7.2 (2018-10-19)

  • package: add support node@10
  • build: use rimraf instead of gulp-del
  • test: add (dummy)

Server Changes

  • ts-filter: add padding to PAT with 0xff. #33 #34
  • tuner: fix takeover strategy to lower priority first. #31
  • debug: allow non-root users.
  • debug: use dotenv.

Dependencies

  • express: ^4.15.2^4.16.4
  • express-openapi: ^1.4.0^3.0.3
  • sift: ^5.0.05.1.0

2.7.0 (2018-02-17)

Server Changes

  • remote: add multiplexing feature w/ remote Mirakurun(s).

2.6.1 (2018-02-15)

...Commit Logs before 2.6.1...

You can’t perform that action at this time.