New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Bug: Cannot find module `gatsby/graphql` on fresh install #22

Closed
Flaque opened this Issue Jul 26, 2018 · 2 comments

Comments

Projects
None yet
2 participants
@Flaque

Flaque commented Jul 26, 2018

This may be an issue with the Gatsby, but it only occurs with gatsby-mdx.

This Repo contains a fresh default template created by gatsby and then an installed gatsby-mdx plugin.

To see it crash, run:

yarn develop

To "fix" the issue, you can remove gatsby-mdx from the plugins in the gatsby-config.js.

For reference, the current versions in that repo:

    "@mdx-js/loader": "^0.15.0-0",
    "@mdx-js/mdx": "^0.15.0-0",
    "gatsby": "^1.9.277",
    "gatsby-link": "^1.6.46",
    "gatsby-mdx": "^0.0.3",
@ChristopherBiscardi

This comment has been minimized.

Owner

ChristopherBiscardi commented Jul 26, 2018

This looks like it's because of gatsby 1.0. The gatsby-mdx plugin is only compatible with gatsby 2.0. To start a new 2.0 site use

gatsby new gatsby-site https://github.com/gatsbyjs/gatsby-starter-default#v2

We have no intention of supporting 1.0 right now but gatsby-plugin-mdx is a 1.0 compatible plugin if you need that. It looks like gatsby-plugin-mdx is going to stop at 1.0 support. Alternatively, start using 2.0 for new projects :)

@Flaque

This comment has been minimized.

Flaque commented Jul 26, 2018

We have no intention of supporting 1.0 right now but gatsby-plugin-mdx is a 1.0 compatible plugin if you need that.

This sounds like the best plan :)

Sorry about that!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment